股票指标
专业的通达信指标网站

通达信MACD反身向上顶底背离指标公式

这其实就是一个很简单的MACD指标公式,里面给出的信号,一个是MACD两条线金叉的时候,另外一个信号是MACD的红色柱子重新放大的时候。这个指标的价值并不大,只要把他的买点信号搞清楚就行了。

DIFF:EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:EMA(DIFF,9);
MACD:2*(DIFF-DEA), COLORSTICK;
WW:=DEA>REF(DEA,1);
DD:=CROSS(DIFF,REF(DIFF,1));
TT:WW AND DD;
DRAWICON(CROSS(DIFF,DEA),DEA,1);
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
STICKLINE(低位金叉,0,0.3,8,0),COLORYELLOW;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,0.2,8,0),COLORFF80FF;
DRAWICON(二次金叉,DEA*0.9,1) ;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
STICKLINE(底背离,0,0.1,8,0),COLORRED;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
DRAWICON(CROSS(DIFF,DEA),DEA,1);
赞(0) 打赏
指标公式仅供学习研究,请勿以此为依据进行股票交易,依此入市,盈亏自负。股票指标 » 通达信MACD反身向上顶底背离指标公式

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏