股票指标
专业的通达信指标网站

通达信买卖风险指标公式

这是震荡指标,个人用法是当20以下出现金叉,并且出现量堆的时候,是理论上的进场点。

警戒:80,COLORCYAN;
启动:20,COLORBROWN;
T1:=5;
T2:=4;
P:=((2)*(CLOSE) + HIGH + LOW + OPEN)/(5);
BB:=MA(P,3);
CC:=(SUM(IF((P > REF(P,1)),(P)*(VOL),0),4))/(SUM(IF((P < REF(P,1)),(P)*(VOL),0),4));
DD:=REF(100 - (100)/(1 + CC),1);
A1:=HHV(P,15);
A2:=LLV(P,15);
A3:=A1 - A2;
A4:=(EMA((P - A2)/(A3),2))*(100);
B1:=HHV(P,60);
B2:=LLV(P,60);
B3:=B1 - B2;
B4:=(EMA((P - B2)/(B3),2))*(100);
C1:=HHV(P,240);
C2:=LLV(P,240);
C3:=C1 - C2;
C4:=(EMA((P - C2)/(C3),2))*(100);
长风险:=C4,LINETHICK1,COLORMAGENTA;
中风险:=B4,COLORAA7755;
短风险:=A4,COLORYELLOW;
散户买卖风险:A4,COLORYELLOW;
高:IF(FILTER((中风险 < REF(中风险,1)) AND (中风险 > 90) AND (BB < REF(BB,1)),5),92,100),COLORGREEN;
低:IF(FILTER((中风险 > REF(中风险,1)) AND (中风险 < 5) AND (CLOSE > REF(CLOSE,1)),5),14,0),COLORRED;
VAR4:=LLV(LOW,T1);
VAR5:=HHV(HIGH,T2);
散户:EMA(((P - VAR4)/(VAR5 - VAR4))*(100),T2),COLOR3333DD;
庄家:EMA((0.667)*(REF(散户,1)) + (0.333)*(散户),2),COLORDDCC00;
VAR6:=((HHV(HIGH,4) - P)/(HHV(HIGH,4) - LLV(LOW,4)))*(100) - 72;
VAR7:=((P - LLV(LOW,4))/(HHV(HIGH,4) - LLV(LOW,4)))*(100);
VAR8:=SMA(VAR7,2,1);
DRAWTEXT(CROSS(散户,庄家) AND (散户 < 50) AND (29 < 散户),20,'▲'),COLORRED;
DRAWTEXT(CROSS(庄家,散户) AND (散户 > 40) AND (71 > 散户),70,'▼'),COLORFF0000;
DRAWTEXT(CROSS(散户,庄家) AND (散户 < 30),30,'吸'),COLORRED;
DRAWICON(CROSS(散户,庄家) AND (散户 < 30),20,1),COLORYELLOW;
DRAWICON(CROSS(庄家,散户) AND (散户 > 70),80,2),COLORFF00FF;
VAR9:=CLOSE - REF(CLOSE,5);
VARA:=((EMA(EMA(VAR9,5),5))/(EMA(EMA(ABS(VAR9),5),5)))*(100);
VARB:=((EMA(EMA(VAR9,10),10))/(EMA(EMA(ABS(VAR9),10),10)))*(100);
VARC:=((EMA(EMA(VAR9,20),20))/(EMA(EMA(ABS(VAR9),20),20)))*(100);
卖出:=IF((VARA > 0) AND CROSS(VARC,VARA),10,0);
DRAWICON((卖出 > 0),60,2),COLOR00FF00;
CCI:=((P - MA(P,14))*(100))/((1.5)*(AVEDEV(P,14)));
RSI1:=((SMA(MAX(CLOSE - REF(CLOSE,1),0),6,1))/(SMA(ABS(CLOSE - REF(CLOSE,1)),6,1)))*(100);
STICKLINE((CCI > 100),106,100,3,0),COLOR00AC00;
STICKLINE((RSI1 > 80),105,102,3,0),COLOR00FE00;
STICKLINE((CCI < (-100)),(-6),0,3,0),COLORYELLOW;
STICKLINE((RSI1 < 25),(-6),(-2),3,0);
D1:=(中风险 > REF(中风险,1)) AND (短风险 > REF(短风险,1)) AND (长风险 > REF(长风险,1)) AND (长风险 < 8) AND (中风险 < 10) AND (短风险 < 15);
D2:=CROSS(短风险,中风险) AND (中风险 < 8);
D3:=CROSS(短风险,长风险) AND (长风险 < 8) AND (中风险 < 20);
DRAWICON(FILTER(D1 OR D2 OR D3 AND (DD < 15) AND (CLOSE > REF(CLOSE,1)),5),8,1),COLORFF0000;
DRAWICON(FILTER((中风险 < REF(中风险,1)) AND (短风险 < REF(短风险,1)) AND (长风险 < REF(长风险,1)) AND (中风险 > 95) AND (短风险 > 85) OR (长风险 > 100) AND (中风险 > 100) AND (短风险 > 100),5),95,2);
赞(0) 打赏
指标公式仅供学习研究,请勿以此为依据进行股票交易,依此入市,盈亏自负。股票指标 » 通达信买卖风险指标公式

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏