股票指标
专业的通达信指标网站

通达信买卖预测指标公式

这个指标有顶底,有买卖提示,这还不是最最主要的,主要的是可以学着布局,分别写不同信号,可以把多个指标放在一起,还能分层看,写这个指标的思路可以学习。

买入:0,COLORRED;
STICKLINE(CROSS(20,((SMA(MAX(CLOSE - REF(CLOSE,1),0),7,1))/(SMA(ABS(CLOSE - REF(CLOSE,1)),7,1)))*(100)),(-400),0,8,0),COLORRED;
STICKLINE(CROSS(((SMA(MAX(CLOSE - REF(CLOSE,1),0),7,1))/(SMA(ABS(CLOSE - REF(CLOSE,1)),7,1)))*(100),80),0,400,8,0),COLOR00FF00;
卖出:0,COLOR00FF00;
VAR1:=(HIGH + LOW + CLOSE)/(3);
VAR2:=(VAR1 - MA(VAR1,14))/((0.015)*(AVEDEV(VAR1,14)));
VAR3:=(VAR1 - MA(VAR1,70))/((0.015)*(AVEDEV(VAR1,70)));
VAR4:=IF((VAR2 >= 150) AND (VAR2 < 200) AND (VAR3 >= 150) AND (VAR3 < 200),100,IF((VAR2 <= (-150)) AND (VAR2 > (-200)) AND (VAR3 <= (-150)) AND (VAR3 > (-200)),(-100),0));
VAR5:=IF((VAR2 >= 150) AND (VAR2 < 200) AND (VAR3 >= 150) AND (VAR3 < 200),100,0);
VAR6:=IF((VAR2 <= (-150)) AND (VAR2 > (-200)) AND (VAR3 <= (-150)) AND (VAR3 > (-200)),(-100),0);
IF((VAR2 >= 200),200,IF((VAR2 <= (-200)),(-200),VAR4)),COLORFFFFFF;
顶:0 -IF((VAR3 >= 200),200,VAR5) + 400,COLORYELLOW;
底:0 -IF((VAR3 >= 200),0,IF((VAR3 <= (-200)),(-200),VAR6)) - 400,COLORFF00FF;

买卖预测之底选股指标公式:

VAR1:=(HIGH + LOW + CLOSE)/(3);
VAR2:=(VAR1 - MA(VAR1,14))/((0.015)*(AVEDEV(VAR1,14)));
VAR3:=(VAR1 - MA(VAR1,70))/((0.015)*(AVEDEV(VAR1,70)));
VAR6:=IF((VAR2 <= (-150)) AND (VAR2 > (-200)) AND (VAR3 <= (-150)) AND (VAR3 > (-200)),(-100),0);
底:0 -IF((VAR3 >= 200),0,IF((VAR3 <= (-200)),(-200),VAR6)) - 400;
赞(0) 打赏
指标公式仅供学习研究,请勿以此为依据进行股票交易,依此入市,盈亏自负。135股票指标 » 通达信买卖预测指标公式

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏