股票指标
专业的通达信指标网站

一个简单实用的修改版kdj公式

这是一个修改过的KDJ指标,给里面的区间填充了颜色,而且增加了线的颜色变化,让大家可以更清楚的看清楚指标的走向,可以说是一个非常实用的KDJ指标,希望对大家有帮助。

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1);
D:SMA(K,3,1);
J:3*K-2*D;
VARK:=K,COLORWHITE;
升K:=IF(VARK>REF(VARK,1),VARK,DRAWNULL),COLORRED;
平K:=IF(VARK=REF(VARK,1),VARK,DRAWNULL),COLORWHITE;
降K:=IF(VARK<REF(VARK,1),VARK,DRAWNULL),COLORGREEN;
VARD:=D,COLORWHITE;
升D:=IF(VARD>REF(VARD,1),VARD,DRAWNULL),COLORRED;
平D:=IF(VARD=REF(VARD,1),VARD,DRAWNULL),COLORWHITE;
降D:=IF(VARD<REF(VARD,1),VARD,DRAWNULL),COLORGREEN;
VARJ:=J,COLORWHITE;
升J:IF(VARJ>REF(VARJ,1),VARJ,DRAWNULL),COLORRED,LINETHICK2;
平J:IF(VARJ=REF(VARJ,1),VARJ,DRAWNULL),COLORWHITE,LINETHICK1;
降J:IF(VARJ<REF(VARJ,1),VARJ,DRAWNULL),COLORGREEN,LINETHICK1;
DRAWBAND(K,RGB(155,50,50),D,RGB(0,100,50));
STICKLINE(J<0,J,0,1,1),COLORYELLOW;
STICKLINE(J>100,J,100,1,1),COLORWHITE;
赞(0) 打赏
指标公式仅供学习研究,请勿以此为依据进行股票交易,依此入市,盈亏自负。股票指标 » 一个简单实用的修改版kdj公式

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏