股票指标
专业的通达信指标网站

通达信趋势成交量指标公式

这个指标是根据MACD改变而来的,但在外观呈现形式上,和MACD还是不一样的,个人用法是红柱代表资金强势,绿柱带便资金弱势,两条线可以当作是资金或者股价的运行趋势。

N:=5;
QJ0:=(HIGH+LOW+CLOSE)/3;
QJ1:=IF(HIGH=LOW,1,HIGH-MAX(OPEN,CLOSE));
QJ2:=IF(HIGH=LOW,1,MAX(CLOSE,OPEN)-QJ0);
QJ3:=IF(HIGH=LOW,1,MIN(OPEN,CLOSE)-LOW);
QJ4:=IF(HIGH=LOW,1,QJ0-MIN(CLOSE,OPEN));
QJ5:=VOL/(IF(HIGH=LOW,4,HIGH-LOW));
QJ6:="MACD.DIF">"MACD.DEA" AND "MACD.DEA"<0;
QJ7:="KDJ.K">"KDJ.D" AND "KDJ.D"<30;
QJ8:="MACD.DIF"<"MACD.DEA";
QJ9:="KDJ.K"<"KDJ.D" AND "KDJ.K">80;
特大:QJ4*QJ5,NODRAW;
大单:QJ3*QJ5,NODRAW;
中单:QJ1*QJ5,NODRAW;
小单:QJ2*QJ5,NODRAW;
W1:=SUM(大单,N)+SUM(特大,N);
W2:=SUM(小单,N)+SUM(中单,N);
量振1:=特大>大单 AND 大单>小单;
量振2:=特大<小单 AND 大单<小单;
标振1:=QJ6 AND QJ7;
标振2:=QJ8 AND QJ9;
A:=W1-W2;
A0:=IF(A>0,A,0);
B0:=IF(A<0,A,0);
STICKLINE(A0,0,A0,3,0),COLOR000066;
STICKLINE(A0,0,A0,2.5,0),COLOR0000AA;
STICKLINE(A0,0,A0,1,0),COLOR0000CC;
STICKLINE(B0,0,-B0,3,0),COLOR006600;
STICKLINE(B0,0,-B0,2.5,0),COLOR00AA00;
STICKLINE(B0,0,-B0,1,0),COLOR00CC00;
周趋势:MA(A,5),COLORFFFFFF;
M:=周趋势;
平滑值:EMA((5*M+4*REF(M,1)+3*REF(M,2)+2*REF(M,3)+REF(M,4))/15,1),COLOR00FFFF;
(量振1 AND 标振1 AND 周趋势>平滑值),COLORFF00FF,POINTDOT;
(量振2 AND 标振2 AND 周趋势<平滑值),COLOR00FF00,POINTDOT;
赞(0) 打赏
指标公式仅供学习研究,请勿以此为依据进行股票交易,依此入市,盈亏自负。股票指标 » 通达信趋势成交量指标公式

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏