股票指标
专业的通达信指标网站

通达信大众牛指标公式(带未来函数,反面教材)

这是一个反面教材的指标,并不是说这个指标买卖点和市场刚好相反,而是这个指标带有未来函数。

在UP这个输出中,用到了BARSLAST这样的一个函数,这个函数在很多检测中,并没有当作是未来函数,但实际上,这个函数是具备未来特性的。

我用通达信自带的训练模式做测试,发现买点和卖点,都有后补的现象,就是收盘的时候并没有,过几天趋势成立了,再给前面补上一个买或者卖的信号,所以就造成了看历史走势图,发现指标给的信号特别准,其实呢,就好比走势已经出来,我让你去给历史走势图标注高低点,你也能很容易的标出来一样的。

感兴趣的可以做一下测试,看看是不是这样。这样的指标是完全不具备参考意义的,还是发出来,当作一个反面教材。

当然,有兴趣的也可以把UP这一句重新写一下,改编一下,改成不带未来函数,看看准确率如何。

N1:=5;N2:=10;
LC:=REF(CLOSE,1);
A0:=(2*C+H+L)/4;
均线:=MA(A0,3)>REF(MA(A0,3),1);
安全线:2,COLORRED,POINTDOT,LINETHICK4;
A1:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*10;
K:MA(3*SMA(A1,6,1)-2*SMA(SMA(A1,5,1),5,1),3),LINETHICK1,COLORF00FF0;
D:MA(K,3),COLORFF0000,LINETHICK1;
J:3*K-2*D,LINETHICK1,COLORF00FF0;
DRAWBAND(K,RGB(155,50,50),D,RGB(0,100,50));
VAR1:=C-REF(C,1);
VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
MA5:=EMA(C,5);
MA13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),0),COLOR0000FF;
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),0),COLOR00FF00;
BT:=(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2))) AND
REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
底线:0,COLORFF00FF;
顶线:10,COLORFF0000;
STICKLINE(UP,0,0.2,3,0),COLOR0000FF;
STICKLINE(DOWN,0,0.2,3,0),COLOR00FF00;
STICKLINE(BT,0,3,2,0),COLOR000088;
STICKLINE(BT,0,3,1,0),COLOR0000CC;
STICKLINE(BT,0,3,0.22,0),COLOR0000FF;
DRAWTEXT(BT,3,'短牛'),COLOR0000FF;
TJ1:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HHV(H,21)*0.82;
STICKLINE(TJ1,0,2,3,0),COLOR880088;
STICKLINE(TJ1,0,2,1.5,0),COLORAA00AA;
STICKLINE(TJ1,0,2,0.8,0),COLORCC00CC;
STICKLINE(TJ1,0,2,0.2,0),COLORFF00FF;
DRAWTEXT(TJ1,2,'中牛'),COLORFF00FF;
HR:=HHV(HIGH,55);
HRY:=LLV(LOW,55);
HRY11:=HR*HRY;
HRY33:=SQRT(HRY11);
TJ2:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;
STICKLINE(TJ2,0,1,5,0),COLOR008888;
STICKLINE(TJ2,0,1,2,0),COLOR00AAAA;
STICKLINE(TJ2,0,1,1,0),COLOR00CCCC;
STICKLINE(TJ2,0,1,0.2,0),COLOR00FFFF;
DRAWTEXT(TJ2,1,'大牛'),COLOR00FFFF;
ST:=REF(UP,1)>REF(UP,2) AND DOWN<REF(UP,1);
STICKLINE(ST,10,9,5,0),COLOR008800;
STICKLINE(ST,10,9,2,0),COLOR00AA00;
STICKLINE(ST,10,9,1,0),COLOR00CC00;
STICKLINE(ST,10,9,0.2,0),COLOR00FF00;
DRAWTEXT(ST,9,'卖'),COLOR00FF00;
DIFF:EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:EMA(DIFF,9),COLORFFFF00;
A11:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:=REF(CLOSE,A11+1)>CLOSE AND DIFF>REF(DIFF,A11+1) AND CROSS(DIFF,DEA);
DRAWTEXT(底背离,-0.6,'底背离'),COLORWHITE;
A22:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A22+1)<CLOSE AND REF(DIFF,A22+1)>DIFF AND CROSS(DEA,DIFF);
DRAWTEXT(顶背离,11,'顶背离'),COLORWHITE;
赞(0) 打赏
指标公式仅供学习研究,请勿以此为依据进行股票交易,依此入市,盈亏自负。股票指标 » 通达信大众牛指标公式(带未来函数,反面教材)

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏