股票指标
专业的通达信指标网站

通达信超级终结者指标公式

两条线加上三个信号,有一定参考价值的,两条线可以看趋势,信号可以做选股。

X:=1;
LGL:=IF(EMA(C,5)/EMA(EMA(C,9),16)<=0.85 AND C/REF(C,1)>0.905 AND C/REF(C,1)<1.05 AND VOL/CAPITAL*100<5,50,0);
WR1:=-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))+100*X;
WR2:=-100*(HHV(HIGH,50)-CLOSE)/(HHV(HIGH,50)-LLV(LOW,50))+100;
WR3:=-100*(HHV(HIGH,70)-CLOSE)/(HHV(HIGH,70)-LLV(LOW,70))+100*X;
BIAS1 := ((CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100+10)*5;
BIAS2 := ((CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100+10)*5;
BIAS3 := ((CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+10)*5;
S1:=(WR1+WR2+WR3+BIAS1+BIAS2+BIAS3)/6*X;
S2:=EMA(S1,3);
S3:=ABS(BIAS1-BIAS3);
SX:=(S1+S3)/2;
XC1:=(-1)*(EMA(100*(1-WINNER(CLOSE)),1)-50)+50;
CCC:=XC1+SX;
ZJZ:=IF( LGL>0 AND CCC<0,200,0)*X;
LXL:=IF(SX<0 AND C=LLV(C,5) AND C/REF(C,1)>0.905 AND C/REF(C,1)<1.05 AND
VOL/CAPITAL*100<5,-50,0);
JBJ:=IF(CCC<0 AND LXL=-50,100,0)*X;
MA3:= MA(C,3);
C0:=REF(C,2)*0.865;
C1:=REF(C,13)*0.772;
BOT:=MIN(C0,C1);
HSL:=100*VOL/CAPITAL*X;
MA13:=MA(C,13)*X;
CXC:=IF((C-BOT)/C<3/100 AND SUM(HSL,5)/5<1.8,1,0);
VMC:=IF(CXC>0 AND (LXL<0 OR LGL>0),100,0);
V满仓:=VMC;
V半仓A:=IF(((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR (CXC>0 AND REF(C,1)/REF(C,2)>0.902)) OR
(((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR CXC>0) AND (LXL<0 OR LGL>0)) AND VMC<10 ,50,0) ;
V93:=(((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR CXC>0) AND (LXL<0 OR LGL>0)) ;
V90:=((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR (CXC>0 AND REF(C,1)/REF(C,2)>0.902));
V半仓:=V93 OR V90;
XMM87:=V满仓 OR V半仓;
XMM91:=VMC;
G:=MA(CLOSE,80)-MA(CLOSE,10)/3*X;
初级:IF(XMM87>0,87,0),STICK,LINETHICK2;
中级:IF(XMM91>0,91,0),STICK,LINETHICK2;
高级:IF(VMC>0 AND CLOSE<G,97,0),STICK,LINETHICK2;
终结者:MAX(MAX(高级,初级),中级),CIRCLEDOT,COLORYELLOW,LINETHICK2;
VAR2Q:=(MA(CLOSE,80)-MA(CLOSE,13)/3);
神奇线:= MA((CLOSE-VAR2Q)/VAR2Q,1);
买点1:= IF(CROSS(神奇线,0) AND LOW/REF(HIGH,1)<1.012,0.5,0), STICK;
稳赚:= IF(COUNT(神奇线>REF(神奇线,1),3)=3 AND COUNT(神奇线<0,10)=10 AND REF(神奇线,3)=LLV(神奇线,10),0.5,0);
买点2:= IF(REF(神奇线,2)=LLV(神奇线,20) AND REF(神奇线,2)<0.071 AND REF(神奇线,2)<REF(神奇线,1) AND NOT(REF(LOW,1)>REF(HIGH,2) AND LOW>REF(HIGH,1)) AND CLOSE>REF(CLOSE,1),0.5,0);
XA:=EMA(神奇线,12)*0.7;
XB:=EMA(神奇线,3);
底部将成:IF(LLV(XB-XA,12)>0,0,-30),COLORFFCC66;
DIFF := EMA(CLOSE,12) - EMA(CLOSE,26);
DEA := EMA(DIFF,9);
MACD := 2*(DIFF-DEA), COLORSTICK;
抄底:IF(底部将成<0 AND CROSS(MACD,0),50,0),COLORBLUE;
DRAWICON( 抄底>0,60 ,1 );
短线投机:EMA((CLOSE-LLV(CLOSE,55))/(HHV(CLOSE,55)-LLV(LOW,55))*100,5),LINETHICK2,COLORFF00FF;
获利盘:EMA(WINNER(CLOSE),5)*100,COLORFFCCCC;
A:=EMA(WINNER(CLOSE),10);
B:=EMA(WINNER(CLOSE),34);
VAR31:=MA(VOL,5)>MA(VOL,60);
介入: IF(A<0.15 AND ABS(A-B)<0.05 AND CROSS(A,B) AND VAR31,1,0)*100,COLORRED;
出货: IF(A>0.90 AND CLOSE<MA(CLOSE,5),1,0)*100,COLORGREEN;
赞(0) 打赏
指标公式仅供学习研究,请勿以此为依据进行股票交易,依此入市,盈亏自负。股票指标 » 通达信超级终结者指标公式

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏