股票指标
专业的通达信指标网站

变色MACD,适合超短和中线使用

根据MACD改编而来,在这个基础之上,通过对颜色的处理,可以更清楚的看到指标的变化,有时候看MACD柱子的高低,肉眼难以分辨,需要借助数值,有了这个指标公式,可以直接看颜色了。同时对买卖信号做了修正,感兴趣的还可以自己再改编一下。

VAR1:=(MA(CLOSE,80)-MA(CLOSE,13)/3);
VAR2:=( MA((CLOSE-VAR1)/VAR1,1));
买点: IF(CROSS(VAR2,0) AND LOW/REF(HIGH,1)<1.012,20,0);
买点1:IF(COUNT(VAR2>REF(VAR2,1),3)=3 AND
COUNT(VAR2<0,10)=10 AND REF(VAR2,3)=LLV(VAR2,10),60,0);
买点2: IF(REF(VAR2,2)=LLV(VAR2,20) AND
REF(VAR2,2)<0.071 AND REF(VAR2,2)<REF(VAR2,1) AND
NOT(REF(LOW,1)>REF(HIGH,2) AND LOW>REF(HIGH,1)) AND
CLOSE>REF(CLOSE,1),20,0);
MMA:=EMA(VAR2,12)*0.7;
MMB:=EMA(VAR2,3);
DIFF:( EMA(CLOSE,12) - EMA(CLOSE,26))*100,COLORRED;
DEA: EMA(DIFF,9),COLORFFFFFF,LINETHICK1;
MACD:= 2*(DIFF-DEA);
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2,0),COLORGREEN;
STICKLINE(MACD<REF(MACD,1)AND MACD<0,0,MACD,2,0),COLORFFCC33;
STICKLINE(MACD>REF(MACD,1)AND MACD,0,MACD,2,0),COLORYELLOW;
STICKLINE(MACD>REF(MACD,1)AND MACD>0,0,MACD,3,0),COLORMAGENTA;
赞(0) 打赏
指标公式仅供学习研究,请勿以此为依据进行股票交易,依此入市,盈亏自负。股票指标 » 变色MACD,适合超短和中线使用

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏