股票指标
专业的通达信指标网站

通达信KDJ红绿趋势指标公式

有KDJ的外在表现形式,但没有KDJ的灵敏性,算是长线KDJ吧,当价位线在零轴,或者零轴之上时,出现黄颜色的柱子,是一个大概率的进场点。

公式类型:其它类型
画图方法:副图
适用范围:电脑版通达信交易系统、手机通达信APP、通用
选股方法:电脑上支持选股,手机上不支持选股

VAR1:=HHV(HIGH,21);
VAR2:=LLV(LOW,21);
VAR3:=EMA((CLOSE-VAR2)/(VAR1-VAR2)*100,5);
VAR4:=EMA((CLOSE-VAR2)/(VAR1-VAR2)*100,20);
VAR5:=5;
IF(CROSS(VAR4,VAR3) AND VAR3>55,100,115);
VAR6:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;
VAR7:=SMA(VAR6,3,1);
VAR8:=SMA(VAR7,3,1);
VAR9:=3*VAR7-2*VAR8;
VARA:=LLV(LOW,5);
VARB:=HHV(HIGH,5);
VARC:=EMA((CLOSE-VARA)/(VARB-VARA)*100,4)*2;
VARD:=EMA(0.667*REF(VARC,1)+0.333*VARC,2);
VARE:=3*VARC-2*VARD;
VARF:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VAR10:=POW(MA(LOW,5),2)+MA(LOW,5);
VAR11:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VAR12:=(VARF-LLV(VAR10,64))/(HHV(VAR11,64)-LLV(VAR10,64))*150+65-10;
VAR13:=SMA(VAR12,3,1)*1.5-100;
VAR14:=SMA(VAR13,3,1);
VAR15:=3*VAR13-2*VAR14;
VAR16:=(HIGH+LOW+CLOSE*2)/4;
VAR17:=EMA(VAR16,13);
VAR18:=STD(VAR16,13);
VAR19:=(VAR16-VAR17)*100/VAR18;
VAR1A:=EMA(VAR19,5);
VAR1B:=EMA(VAR1A,13);
VAR1C:=EMA(VAR1A,13)+200-100;
VAR1D:=EMA(VAR1C,10);
VAR1E:=3*VAR1C-2*VAR1D;
VAR1F:=VAR7+VARC+VAR13+VAR1C;
VAR20:=VAR8+VARD+VAR14+VAR1D;
VAR21:=VAR9+VARE+VAR15+VAR1E;
VAR22:=(HIGH+LOW+CLOSE)/3;
VAR23:=AMOUNT/VOL/100;
VAR24:=SUM(AMOUNT,5)/SUM(VOL,5)/100;
VAR25:=(VAR22-MA(VAR22,34))/(0.015*AVEDEV(VAR22,34));
VAR26:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
VAR27:=(HIGH+LOW+CLOSE+VAR22)/4;
VAR28:=EMA(VAR27,24);
VAR29:=STD(VAR27,24);
VAR2A:=(VAR27-VAR28)/VAR29*100;
VAR2B:=(VAR22-MA(VAR22,24))/(0.015*AVEDEV(VAR22,24));
VAR2C:=EMA(VAR2A,5);
VAR2D:=(VAR23-MA(VAR23,21))/(0.015*AVEDEV(VAR23,21));
VAR2E:=(VAR24-MA(VAR24,90))/(0.015*AVEDEV(VAR24,90));
VAR2F:=((VAR2C+VAR2B+VAR25)/3+165)/4;
VAR30:=(EMA(EMA(EMA(VAR2F,15),10),5)-25)*2+VAR26;
VAR31:=(VAR1F+VAR20+VAR21*30)/32/5-15;
VAR32:=EMA(VAR31,13);
VAR33:=(VAR2F+VAR31)/2/1.1;
VAR34:=VAR33;
价位线:= EMA(VAR34,1),COLORFFFF00;
趋势线: EMA((VAR30+VAR32)/2,1),COLOR00FFFF;
趋均线: EMA(趋势线,2),COLOR0000FF;
STICKLINE(趋势线-REF(趋势线,1)>0,趋均线-3,0,10,0),COLOR0000FF;
STICKLINE(趋势线-REF(趋势线,1)<0,趋势线-3,0,4,1),COLOR00FF00;
红灯: STICKLINE(趋势线>115,120,110,8,1),COLOR0000FF ;
VAR37:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR38:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR39:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR3A:=(VAR37+2*VAR38+3*VAR39)/6;
VAR3B:=MA(VAR3A,3);
A:=IF(VAR3B<-6,0,-35);
VAR3C:=CROSS(价位线,0) AND COUNT(VAR3B<-12,2)>=1 OR CROSS(价位线,趋势线) AND COUNT(VAR3B<-12,2)>=1;
VAR3D:=STICKLINE(VAR3C,100,0,3,0);
DRAWICON(VAR3C,100,1);
DRAWICON(CROSS(价位线,趋势线) AND COUNT(VAR3B<-6,2)>=1 OR CROSS(价位线,0) AND COUNT(VAR3B<-6,1)>=1,40,1);
VAR3E:=(EMA(CLOSE,12)-EMA(CLOSE,26))*10;
VAR3F:=EMA(VAR3E,12);
STICKLINE(CROSS(100,价位线) OR CROSS(趋势线,价位线) AND 趋势线>80,0,趋势线,3,0);
价位:EMA(VAR34,3),COLORFFFF00;
均价线:EMA(价位线,12),COLORFF1110;
买:IF(CROSS(价位,均价线) AND 趋势线<趋均线,115,0),COLOR00FFFF,STICK,LINETHICK3;
赞(0) 打赏
指标公式仅供学习研究,请勿以此为依据进行股票交易,依此入市,盈亏自负。股票指标 » 通达信KDJ红绿趋势指标公式

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏