股票指标
专业的通达信指标网站

红色持股绿色持币的波段主力轨迹线

用在副图的红绿波段,加上了压力和支撑,以及运行区间,类似于KDJ的三条线,都波段特征会更明显一点。可以直接参考,有能力的也可以自己再修改一下,优化一下。

VAR2:=(C-REF(C,1))/REF(C,1)*100;
VAR3:=(C-LLV(L,18))/(HHV(H,18)-LLV(L,18))*100;
VAR4:=SMA(VAR3,9,1);
VAR5:=SMA(VAR4,3,1);
J:3*VAR4-2*VAR5,COLOR00FFFF;
VAR6:=J>1*REF(J,1);
VAR7:=LLVBARS(L,50);
VAR8:=SUM(V,VAR7);
VAR9:=HHVBARS(H,50);
VAR10:=SUM(V,VAR9);
VAR11:=(C-REF(O,VAR9))/REF(O,VAR9)*100;
VAR12:=VAR10/CAPITAL*100;
VAR13:=(C-REF(O,VAR7))/REF(O,VAR7)*100;
VAR14:=VAR8/CAPITAL*100;
VAR15:=MA(WINNER(C),10)*100;
VAR16:=EMA(VAR4,10);
A2:EMA(VAR4,10),COLORFFDDCC;
A3:=EMA(A2,10);
A4:=EMA(A3,10);
A5:=EMA(A4,10);
A6:=EMA(A5,10);
A7:=EMA(A6,10);
VAR17:=EMA(A7,10);
VAR18:=EMA(VAR17,10);
VAR19:=EMA(VAR18,10);
AA:=EMA(A5,10);
中期大底:LLV(J,AA),LINETHICK2,COLOR0000FF;
上:=IF(MA(H,3)*1.05,30,0)*10-AA;
下:=IF(MA(L,3)*0.96,30,0)*2/中期大底;
中:=IF(MA(H,3)*1.05,30,0);
电:=J;
DRAWTEXT(CROSS(A4,AA) AND VAR11<0,AA,'●底'),COLORFFFF00;
DRAWTEXT(CROSS(A2,J) AND A2>100,A2+4.22,'●峰'),COLOR00FFFF;
STICKLINE(J>=A2,A2,J,6,0),COLOR0000FF;
STICKLINE(J<=A2,J,A2,6,0),COLOR00FF00;
压力:HHV(J,60),COLOR00FFFF;
支撑:=LLV(AA,13);
STICKLINE(J<=中期大底 AND 中-REF(中,1)>0 AND C>=O*0.99,1,88,3,0),COLOR0000FF;
DRAWICON(J<=中期大底 AND 中-REF(中,1)>0 AND C>=O*0.99,88,1),COLOR00FF00;
STICKLINE(FILTER(CROSS(上,中期大底) AND 中-REF(中,1)>=0,3),中期大底,70,3,0),COLOR00FF00;
DRAWICON(FILTER(CROSS(上,中期大底) AND 中-REF(中,1)>=0,3),70,1);
STICKLINE(CROSS(上,下) AND C>=O,中期大底,60,2,0),COLORFF0000;
B0:=MA(C,3);
B01:=MA(C,4);
B1:=(H+L+C)/3;
B2:=HHV(B1,15);
B3:=LLV(B1,15);
B4:=B2-B3;
B5:MA((B1-B3)/B4,2)*100,COLOR000080;
B6:=HHV(B1,4*15);
B7:=LLV(B1,4*15);
B8:=B6-B7;
B9:=MA((B1-B7)/B8,2)*100;
BA:=HHV(B1,16*15);
BB:=LLV(B1,16*15);
BC:=BA-BB;
BD:=MA((B1-BB)/BC,2)*100;
顶线:=98;
底线:=1;
赞(0) 打赏
指标公式仅供学习研究,请勿以此为依据进行股票交易,依此入市,盈亏自负。135股票指标 » 红色持股绿色持币的波段主力轨迹线

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏