股票指标
专业的通达信指标网站

在布林线基础之上增加变色和买卖点提示,形成布林彩K

彩色布林线BOLL指标,在boll布林轨线基础之上增加K线变色,以及增加买卖和清仓提示。最好是用在主图,当然,如果说嫌弃颜色太乱,或者不想看这些花里胡哨的东西,放在副图也是可以的,或者自己把那些变色的部分去掉也行。

N:=20;
MA5:=MA(C,5);
MA18:=MA(CLOSE,18);
MA10:=MA(C,10);
MA30:=MA(C,30);
VAR1:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);
VAR2:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);
VAR3:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
A:=(3*C+L+O+H)/6;
VAR4:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
CB:=EMA(VAR4,13);
{红}
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,3,0),COLOR0000FF;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,0.5,0),COLORCC66FF;
{蓝}
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,3,0),COLORFF9900;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,0.5,0),COLORFFCC00;
{粉}
STICKLINE(VAR1,C,(O+C)/2,3,0),COLORFF11FF;
STICKLINE(VAR1,C,(O+C)/2,0.5,0),COLORFFDDFF;
{灰}
STICKLINE(VAR2,C,(O+C)/2,3,0),COLOR999999;
STICKLINE(VAR2,C,(O+C)/2,0.5,0),COLORFFBBFF;
{绿}
STICKLINE(VAR3,O,(O+C)/2,3,0),COLOR00BB00;
STICKLINE(VAR3,O,(O+C)/2,0.5,0),COLOR00FF00;
卖:=HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX);
DRAWTEXT(FILTER(卖=1,1),HIGH*1.02,'卖'),COLORGREEN;
买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
DRAWTEXT(FILTER(买=1,5),LOW-0.01,'买'),COLORRED;
加码:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
DRAWTEXT(FILTER((CROSS(加码,0) OR CROSS(CLOSE,CB)) AND 买=1,3),LOW-0.1,'加'),COLORWHITE;
跟:=MA18>=REF(MA18,3) AND CROSS(CLOSE,MA18);
DRAWTEXT(跟,LOW*0.96,'跟'),COLORCC66FF;
MID:=MA(C,N);
VART1:=POW((C-MID),2);
VART2:=MA(VART1,N);
VART3:=SQRT(VART2);
UPPER:=MID+2*VART3;
LOWER:=MID-2*VART3;
BOLL:REF(MID,1),COLORFFFFFF;
UB:REF(UPPER,1),COLOR00FFFF;
LB:REF(LOWER,1),COLORFF00FF;
BB:=V>MA(V,5) ;
DD:=V<MA(V,5);
IF(BB,UB,DRAWNULL),COLORRED,LINETHICK3;
IF(DD,LB,DRAWNULL),COLORBLUE,LINETHICK3;
五日乖离率:=(C-MA5)/MA5*100;
三拾日乖离率:=(C-MA30)/MA30*100;
JL05:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;
JL10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
JL30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((MA5-REF(MA5,1))/REF(MA5,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3);
强势狙击:=FILTER(JL30>30 AND JL10>45 AND CROSS(JL05,60),10);
加仓:=FILTER(COUNT(CROSS(JL05,30),5)>=1 AND MA5>REF(MA5,1)AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA10>REF(MA10,1)AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1),10) ;
清仓:=FILTER(COUNT(CROSS(30,JL05),5)>=1 AND (MA30 OR O>MA30) AND MA5<REF(MA5,1)AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10<REF(MA10,1),10);
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA5>REF(MA5,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<MA30;
JL:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10>REF(MA10,1) ;
减仓:=FILTER(JL,10);
买入:=FILTER(MR,10);
DRAWTEXT(减仓,HIGH*1.02,'减仓'),COLORFF99FF;
DRAWTEXT(加仓 ,LOW*0.98,'加仓'),COLORRED;
DRAWTEXT(买入,LOW*0.98,'买入'),COLORYELLOW;
DRAWTEXT(清仓,HIGH*1.02,'清仓'),COLORGREEN;
DRAWTEXT(强势狙击,LOW*0.98,'强势狙击'),COLORYELLOW;
赞(0) 打赏
指标公式仅供学习研究,请勿以此为依据进行股票交易,依此入市,盈亏自负。135股票指标 » 在布林线基础之上增加变色和买卖点提示,形成布林彩K

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏