股票指标
专业的通达信指标网站

给MACD增加彩色带

优化版本的MACD指标,增加了彩带功能,相比原版MACD,有那么一丝丝的改进。

SHORT:=6;
LONG:=9;
MID:=3;
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG),LINETHICK1,COLOR0000FF;
DEA:EMA(DIF,MID); 
DRAWBAND(DIF,RGB(500,180,280),DEA,RGB(380,280,180));
MACD:(DIF-DEA)*2,COLORSTICK;
向上:IF(DIF>=REF(DIF,1),DIF,DRAWNULL),LINETHICK2,COLORRED;
向下:IF(DIF<REF(DIF,1),DIF,DRAWNULL),COLORGREEN,LINETHICK2;
DRAWICON(CROSS(DIF,DEA) AND DIF>REF(DIF,1) AND DEA<0,DIF,0);
赞(0) 打赏
指标公式仅供学习研究,请勿以此为依据进行股票交易,依此入市,盈亏自负。股票指标 » 给MACD增加彩色带

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏