股票指标
专业的通达信指标网站

漂亮的双向成交量指标

一个关于资金流向的指标,比较复杂,不容易看懂,主要是没有绝对化,而是相对化的,成交量没有和流通盘做对比。

EV:=VOL;
实际V(万手):EV/10000;
VAR1:=DYNAINFO(17)*REF(MA(VOL,5),1);
VAR2:=DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT;
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买盘:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+
(CLOSE-LOW)),VOL/2)),POINTDOT,COLORRED;
买:买盘/10000,COLORYELLOW,NODRAW;
卖盘:=IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,
0-AA*(HIGH-LOW),0-VOL/2)),LINETHICK0,COLORGREEN;
卖:卖盘/10000,COLORYELLOW,NODRAW;
差额:(买盘+卖盘)/10000,COLORYELLOW;
BB:=(买盘+卖盘);
换手:VOL/CAPITAL*100,CIRCLEDOT,COLORYELLOW;
成交额(千万):AMOUNT/10000000,POINTDOT,COLORYELLOW;
S1:=VOL/(((REF(V,1)+REF(V,2)+REF(V,3)+REF(V,4)+REF(V,5))/1200)*FROMOPEN);
量比:MA(S1,1),COLORYELLOW;
量坑:=MA(VOL,233);
F:=VOL<量坑;
TYP:=(HIGH+LOW+CLOSE)/3;
HH:=CONST(HHV(EV,144));
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
R:DRAWTEXT(F AND CCI<-180,HH/1.35,'☉'),COLORYELLOW;
RSV:=(CLOSE - LLV(LOW,18))/(HHV(HIGH,18) - LLV(LOW,18));
K:=EMA(RSV,3);
D:=EMA(K,3);
J:=3*K-2*D;
KDJ1:=REF(COUNT(J<REF(J,1),5)>=3,1) AND REF(J,1)<0.03;
KDJ2:=J>REF(J,1);
KDJ3:=REF(COUNT(J>REF(J,1),5)>=3,1) AND REF(J,1)>0.99;
KDJ4:=J<REF(J,1);
STICKLINE(买盘>0,0,VOL,2,1),COLORWHITE;
STICKLINE(买盘>0,0,买盘,3.2,0),COLOR000033;
STICKLINE(买盘>0,0,买盘,2.5,0),COLOR000066;
STICKLINE(买盘>0,0,买盘,1.9,0),COLOR000099;
STICKLINE(买盘>0,0,买盘,1.3,0),COLOR0000FF;
STICKLINE(买盘>0,0,买盘,0.9,0),COLORCC66FF;
STICKLINE(卖盘<0,0,卖盘,3.2,0),COLOR990000;
STICKLINE(卖盘<0,0,卖盘,2.5,0),COLORCC0000;
STICKLINE(卖盘<0,0,卖盘,1.9,0),COLORFF4400;
STICKLINE(卖盘<0,0,卖盘,1.3,0),COLORFFCC00;
STICKLINE(卖盘<0,0,卖盘,0.9,0),COLORCYAN;
STICKLINE((卖盘+买盘)>0,0,(卖盘+买盘),0.5,0),COLORYELLOW;
STICKLINE((卖盘+买盘)<0,0,(卖盘+买盘),0.3,0),COLORGRAY;
VAR22:=(CLOSE-LLV(LOW,24))/(HHV(HIGH,24)-LLV(LOW,24))*200*10;
能量:=SMA(VAR22,5,1),COLORRED;
三日内净流入:SUM (BB,3), LINETHICK2,COLORGREEN;
流入:IF (三日内净流入>REF(三日内净流入,1),三日内净流入,DRAWNULL),COLORLIMAGENTA,LINETHICK2;
CCII:=(TYP-MA(TYP,9))/(0.016*AVEDEV(TYP,9));
提款机1:=CROSS(CCII,-140);
超买:=CROSS(180,CCII)COLORGREEN,LINETHICK3;
JJ:=(H+L+C)/3;QJ0:=VOL/IF(H=L,4,H-L);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(C,O)),QJ0*(MIN(O,C)-L));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(O,C)-L),QJ0*(JJ-MIN(C,O)));
QJ3:=QJ0*(H-MAX(O,C));QJ4:=QJ0*(MAX(C,O)-JJ);
QJ5:=QJ1+QJ2;QJ6:=QJ3+QJ4;DD:=(QJ5-QJ6)/(QJ5+QJ6)*100;
DDX:=((QJ1+QJ2)-(QJ3+QJ4))/SUM(VOL,10)*100;DDZ:=DD*17;
DDY:=((QJ2+QJ4)-(QJ1+QJ3))/SUM(VOL,10)*100;
提款机2:=CROSS(CCII,-140) AND ((DDX>0 AND DDY>0) OR DDZ>400),COLORRED;
BIAS:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
提款机3:=IF(BIAS<=-16,1,0);
KM1:DRAWICON( FILTER(KDJ1 AND KDJ2,3) AND 能量<700 ,HH,1);
KM2:DRAWICON( 提款机1 AND 能量<600 ,HH,1);
KM3:DRAWICON( 提款机2 AND 能量<600 ,HH,1);
KM4:DRAWICON( 提款机3 AND 能量<600 ,HH,1);
KM5:DRAWICON( FILTER(KDJ3 AND KDJ4,3) AND 能量>1400 ,HH,2);
KM6:DRAWICON( 超买 AND 能量>1400 ,HH,2);
赞(0) 打赏
指标公式仅供学习研究,请勿以此为依据进行股票交易,依此入市,盈亏自负。135股票指标 » 漂亮的双向成交量指标

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏