股票指标
专业的通达信指标网站

五线组合通道线主图指标

比较花里胡哨的一个主图指标,有5条通道线,还有很多信号,内容很丰富,不过信号太多把主图都遮住了,大家各取所需吧,感兴趣的可以研究一下。

VARA:=(MA(C,13)+MA(C,17))/2;
VARB:=(STD(C,13)+STD(C,17))/2;
VARC:=IF((C>REF(C,1)),88,0);
VARD:=VARA+0.72*VARB;
VARF:=IF(((C)/(REF(C,1))>1.05) AND H/C<1.01 AND VARC>0,91,0);
VARE:=IF(VARB>1.88 ,MA(VARD,3),VARD);
VARG:=EMA(EMA(C,9),9);
CON:=(VARG-REF(VARG,1))/REF(VARG,1)*1000;
HCON:=100*WINNER(C*0.95);
VAR1:=EMA(EMA(EMA(C,5),5),5);
VAR2:=VAR1-REF(VAR1,1)+VAR1;
VAR3:=CROSS(VAR2,MA(VAR2,26));
VAR4:=CROSS(MA(C,13),MA(C,21));
VAR5:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
VAR6:=3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1);
VAR7:=IF(VAR6<=10,30,0);
VARJ:=SMA(VAR5,3,1);
VARK:=SMA(VARJ,3,1);
VARL:=EMA(SMA((C-LLV(L,19))/(HHV(H,19)-LLV(L,19))*100,8,1),3);
VARM:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
VAR8:=(VARL>20 AND VARL<80);
VAR9:=((VARL-REF(VARL,1))>3 AND VAR8);
VAR10:=EMA(((C-LLV(L,22))/(HHV(H,22)-LLV(L,22)))*100,5);
VAR11:=EMA(((C-LLV(L,22))/(HHV(H,22)-LLV(L,22)))*50,13);
止赢:VARE*1.1,COLORRED,LINETHICK2;
压力:VARE*1.05,COLORBLUE,LINETHICK2;
支撑:VARE*0.95,COLOR18FF18,LINETHICK2;
反转:VARE*0.9,COLORYELLOW,LINETHICK2;
平衡:VARE,COLORFFFFFF,LINETHICK3;
DRAWTEXT(ISLASTBAR,止赢,'止赢'),COLORRED;
DRAWTEXT(ISLASTBAR,压力,'压力'),COLORBLUE;
DRAWTEXT(ISLASTBAR,支撑,'支撑'),COLOR18FF18;
DRAWTEXT(ISLASTBAR,反转,'反转'),COLOR18CCFF;
DRAWTEXT(ISLASTBAR,平衡,'平衡'),COLORFFFFFF;
DRAWTEXT(FILTER((VARF>90),34),LOW*0.965,'◆'),COLORRED;
STICKLINE(HCON>50 AND COST(85)<C AND CON>0,O,C,1.8,0),COLORFF00FF;
DRAWTEXT(VAR3 AND VAR4,L*0.95,'圆底'),COLORYELLOW;
STICKLINE(CROSS(VARJ,VARK) AND CROSS(MACD.DIF, MACD.DEA),C,O,1,0),COLORYELLOW;
DRAWTEXT(VAR7<REF(VAR7,1),L*0.98,'抢'),COLORYELLOW;
DRAWTEXT(FILTER(VAR9,5),L*0.97,'加'),COLORFF00FF;
DRAWICON(CROSS(76,VARM),H,6);
重心:AMOUNT/VOL/100,POINTDOT,LINETHICK5,COLORYELLOW;
布林极限:BB,COLORFF00FF,NODRAW;
RSI1:RSI.RSI1,COLORRED,NODRAW;
KDJJ:KDJ.J,COLORWHITE,NODRAW;
STICKLINE(CROSS(VAR10, VAR11),O,C,1.6,1),COLORRED;
STICKLINE(CROSS(VAR10, VAR11),O,C,1,1),COLORRED;
DRAWTEXT(FILTER(CROSS(C,反转) OR CROSS(C,支撑) OR CROSS(C,平衡) OR CROSS(C,压力),3),L*0.995,'买'),COLORRED;
DRAWTEXT(FILTER(CROSS(反转,C) OR CROSS(支撑,C) OR CROSS(平衡,C) OR CROSS(压力,C),3),H*1.02,'卖'),COLORGREEN;
AA1:=MA(C,5);
BB1:=MA(C,15);
AF:=CROSS(AA1,BB1);
STICKLINE(AF,LLV(L,4),LLV(L,4),50,1),COLORRED,LINETHICK3;
DRAWTEXT(AF,LLV(L,4),'止损线'),COLORYELLOW;
E1:=BARSCOUNT(C);
AH:=HHV(H,200);
AL:=LLV(L,200);
B0:=(AH-AL)/40;
KB1:=H+B0;
KB2:=L-B0;
STICKLINE((E1+0)/34=FLOOR((E1+0)/34),KB2,KB2-0.8*B0,1,0),COLORYELLOW,LINETHICK3;
DRAWTEXT((E1+0)/34=FLOOR((E1+0)/34),KB2-B0,'时窗'),COLORYELLOW;
MA18:=MA(CLOSE,18);
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
DRAWTEXT(FILTER(买=1,5),LOW,'★买一'),COLORRED;
加1:=MA18>=REF(MA18,3) AND CROSS(CLOSE,MA18);
DRAWTEXT(加1,LOW*0.99,'★加一'),COLORCC66FF;
卖一:=HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX);
DRAWTEXT(FILTER(卖一=1,1),HIGH*1.01,'★卖一'),COLORGREEN;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,LOW*0.99,'老鼠仓'),COLOR4080FF;
XXS:=MA(LOW,5)*(1-5/100);
XXS1:=MA(HIGH,5)*(1+5/100);
均线:=C,COLORGREEN;
AAAA:=CLOSE/REF(CLOSE,3)<=0.85 AND CROSS(C,XXS) AND C>REF(C,1),LINETHICK0 ;
DRAWTEXT(AAAA,L*0.95,'下影买'),COLORRED;
BBAA:=CROSS(XXS1,C);
DRAWTEXT(CROSS(XXS1,C),H,'开盘逃'),COLORWHITE;
DDDD:=CROSS(C,XXS1);
DRAWTEXT(DDDD,H,'明日走'),COLORYELLOW;
AAA:=MA(LOW,5)*(1-5/100);
BBB:=(HHV(AAA,5)+LLV(AAA,5))/2;
DRAWTEXT(CROSS(BBB,L) AND BBB>REF(BBB,1),L*0.98,'←斋主回马枪'),COLORWHITE;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
DRAWTEXT(REF(CROSS(DEA,DIF),1) AND CROSS(DIF,DEA),L*0.97,'★←老李夺命抢'),COLORMAGENTA;
X1:=(C+L+H)/3;
BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),
EMA8,'★∠45升'),COLORWHITE;
HR:=HHV(HIGH,55);
HRY:=LLV(LOW,55);
HRY11:=HR*HRY;
HRY33:SQRT(HRY11),COLORGREEN,LINETHICK2;
IF(C>HRY33 AND HRY33 >=REF(HRY33 ,1), HRY33 ,DRAWNULL),LINETHICK2,COLORRED;
BB5:=ATAN(EMA(X1,7)-REF(EMA(X1,7),1))*3.1416*10;
EMA3:=EMA(C,3);
DRAWTEXT(FILTER(BB5>1 AND EMA(X1,7)>REF(EMA(X1,7),1),10),
LOW*0.99,'★∠45'),COLORFFFFFF;
TT:=FILTER(BB5>1 AND EMA(X1,7)>REF(EMA(X1,7),1),10);
VAR27:=REF(CLOSE,1);
VAR28:=SMA(MAX(CLOSE-VAR27,0),5.5,1)/SMA(ABS(CLOSE-VAR27),6,1)*100;
DRAWICON((IF(CROSS(76,VAR28),1,0)) OR CROSS(70,RSI),H*1.01,2);
DRAWICON((IF(CROSS(VAR28,21),1,0)),L*0.97,1);
DRAWTEXT((IF(CROSS(76,VAR28),1,0)) OR CROSS(84,RSI),H*1.03,'快跑') ,COLORYELLOW;
股价:MA(C,3),COLORGREEN,LINETHICK2;
B:=股价<REF(股价,1);
短线:IF(B-1,股价,DRAWNULL)COLORMAGENTA,LINETHICK2;
VAR4A:=EMA(CLOSE,3);
DRAWICON(COUNT(REF(VAR4A,1)<REF(VAR4A,2),5)=5 AND VAR4A>REF(VAR4A,1),L*0.98,4);
DRAWTEXT(COUNT(REF(VAR4A,1)<REF(VAR4A,2),5)=5 AND VAR4A>REF(VAR4A,1),L*0.96,'出拳');
赞(0) 打赏
指标公式仅供学习研究,请勿以此为依据进行股票交易,依此入市,盈亏自负。股票指标 » 五线组合通道线主图指标

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏