股票指标
专业的通达信指标网站

仿钱龙长短线指标源码,通达信可用

仿照钱龙长线、钱龙短线写的指标,是两个指标,一长一短,两个子表可以结合着使用,个人测试了一下,有一定的参考价值。

{指标名----钱龙长线}
LC:=REF(CLOSE,1);
{昨日收盘价}
VID:=SUM(VOL,2)/(((HHV(HIGH,2)-LLV(LOW,2)))*100);
{VID是成交密度的一种表示方法,反映了两天交易的分布情况,即两天来单位成交量。
通常情况,当股价创出新高而成交密度未创出新高时,升势将尽。当股价创出新低
而成交密度未创出新低时,底部将至。}
RC:=(CLOSE-LC)*VID;
{RC表达的是有效成交量(单位是手)。}
LONG:=SUM(RC,0);
{LONG类似OBV,表示累加有效成交量,长期看总是向上的,对近期行情的研判帮助有限。}
DIFF:=SMA(LONG,10,1);
DEA:=SMA(LONG,20,1);
LON:=DIFF-DEA;
{LON引入其短中期的移动平均量之差,可明显表示出中短线资金的流向。
指标为正值时,代表资金进场;指标为负值时,代表资金撤退。}

{中短线资金流向棒状线颜色及意义提示}
STICKLINE(LON>REF(LON,1) AND LON>0,0,LON,1,0),COLORRED;
STICKLINE(LON<REF(LON,1) AND LON>0,0,LON,1,0),COLORCC00CC;
STICKLINE(LON>REF(LON,1) AND LON<0,0,LON,1,0),COLOR0088FF;
STICKLINE(LON<REF(LON,1) AND LON<0,0,LON,1,0),COLORGREEN;
红色牛:LON,COLORRED;
紫色调整:LON,COLORFF00FF;
绿色熊:LON,COLOR00FF00;
褐色反弹:LON,COLOR0088FF;

{钱龙长线指标值及移动平均值}
QLCX:LON,COLORFFFFFF;
QLCXMA:MA(LON,10),COLOR00FFFF;
{其中短中期的移动平均参数应该可以自行设置,从而可以关注相应期间内的资金流向。
利用其与LON的金叉与死叉,更有利于对趋势的研判。}
{LONT : LON, COLORSTICK;}
{LONT是中短线资金流向棒状线}
{钱龙长线
当指标曲线向上交叉其平均线时,视为长线买进信号。
当指标曲线向下交叉其平均线时,视为长线卖出信号。};
{指标名----钱龙短线}
L2:=5;
L3:=10;
VAR1:=MA((VOL-REF(VOL,1))/REF(VOL,1),L2);
VAR2:=(CLOSE-MA(CLOSE,L3))/MA(CLOSE,L3)*100;
MY:VAR2*(1+VAR1);
钱龙短线:MY, COLORSTICK;
MA(钱龙短线,5);
V0:0,COLORFFA2AF;
{钱龙短线指标
当指标曲线向上交叉其平均线时,视为短线买进信号。
当指标曲线向下交叉其平均线时,视为短线卖出信号。};
赞(0) 打赏
指标公式仅供学习研究,请勿以此为依据进行股票交易,依此入市,盈亏自负。股票指标 » 仿钱龙长短线指标源码,通达信可用

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏