股票指标
专业的通达信指标网站

通达信神器的boll布林线指标

boll布林线指标优化改进版,在原boll通道线的基础之上增加了开始建仓、加仓、减仓、空仓观望,等等一些信号。不足之处是信号的准确度,还有就是把原来的K线图都盖住了。

MID2 := MA(CLOSE,21),COLORWHITE;
UPPER2:=MID2 + 1.96*STD(CLOSE,21),COLORYELLOW;
LOWER2:=MID2 - 1.96*STD(CLOSE,21),COLORYELLOW;
UP2:=MID2 + 2.56*STD(CLOSE,21),COLORFF00FF;
LOOW2:=MID2 - 2.56*STD(CLOSE,21),COLORFF00FF;
{上升趋势}
STICKLINE(C>=MID2,MID2,UP2,2,0),COLOR330066;
{下降趋势}
STICKLINE(C<MID2,MID2,LOOW2,2,0),COLOR545454;
MID:MID2,COLORWHITE;
UPPER:UPPER2,COLORYELLOW;
UP:UP2,COLORFF00FF;
LOWER:LOWER2,COLORYELLOW;
LOOW:LOOW2,COLORFF00FF;
开口:=UP-LOOW;
相离:=C-MID;
DRAWTEXT(C>=MID AND REF(开口,1)=HHV(开口,20),UPPER,'减仓'),COLOR00FF00;
DRAWTEXT(C>=MID AND REF(相离,1)=LLV(相离,5),MID,'加仓');
股价多头:=C>MA(C,5) AND MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20);
DRAWTEXT(FILTER(股价多头,20),LOOW*0.95,'开始建仓'),COLORRED;
DRAWICON(FILTER(股价多头,20),LOWER,1),COLORRED;
DRAWTEXT(CROSS(MID,C),UP,'空仓观望'),COLORYELLOW;
DRAWICON(CROSS(MID,C),UPPER,2),COLORYELLOW;

{K线}
{STICKLINE((CLOSE > OPEN),CLOSE,OPEN,5.2,0),COLOR070084;}
STICKLINE((CLOSE > OPEN),CLOSE,OPEN,4,1),COLOR0000A3;
STICKLINE((CLOSE > OPEN),CLOSE,OPEN,3.5,0),COLOR000033;
STICKLINE((CLOSE > OPEN),CLOSE,OPEN,3,0),COLOR000066;
STICKLINE((CLOSE > OPEN),CLOSE,OPEN,2.0,0),COLOR000099;
STICKLINE((CLOSE > OPEN),CLOSE,OPEN,1.5,0),COLOR0000CC;
STICKLINE((CLOSE > OPEN),CLOSE,OPEN,1.0,0),COLOR0000FF;
STICKLINE((CLOSE > OPEN),CLOSE,OPEN,0.5,0),COLORCC66FF;
STICKLINE((CLOSE > OPEN),OPEN,LOW,0.3,0),COLORRED;
STICKLINE((CLOSE > OPEN),CLOSE,HIGH,0.3,0),COLORRED;
{STICKLINE((CLOSE = OPEN AND C>REF(C,1)),CLOSE,OPEN,5.2,0),COLOR070084;}
STICKLINE((CLOSE = OPEN AND C>REF(C,1)),CLOSE,OPEN,4,1),COLOR0000A3;
STICKLINE((CLOSE = OPEN AND C>REF(C,1)),CLOSE,OPEN,3.5,0),COLOR0000B7;
STICKLINE((CLOSE = OPEN AND C>REF(C,1)),CLOSE,OPEN,3,0),COLOR0000CD;
STICKLINE((CLOSE = OPEN AND C>REF(C,1)),CLOSE,OPEN,2.0,0),COLOR0000E9;
STICKLINE((CLOSE = OPEN AND C>REF(C,1)),CLOSE,OPEN,1.5,0),COLOR0754E9;
STICKLINE((CLOSE = OPEN AND C>REF(C,1)),CLOSE,OPEN,1.0,0),COLOR076EF3;
STICKLINE((CLOSE = OPEN AND C>REF(C,1)),CLOSE,OPEN,0.5,0),COLOR077BF3;
STICKLINE((CLOSE = OPEN AND C>REF(C,1)),OPEN,LOW,0.3,0),COLOR0000CD;
STICKLINE((CLOSE = OPEN AND C>REF(C,1)),CLOSE,HIGH,0.3,0),COLOR0000CD;
{STICKLINE((OPEN > CLOSE),CLOSE,OPEN,5.2,0),COLORFF5B00;}
STICKLINE((OPEN > CLOSE),CLOSE,OPEN,4,1),COLORFF6C00;
STICKLINE((OPEN > CLOSE),CLOSE,OPEN,3.5,0),COLORFF7B00;
STICKLINE((OPEN > CLOSE),CLOSE,OPEN,2,0),COLORFF9C00;
STICKLINE((OPEN > CLOSE),CLOSE,OPEN,1.5,0),COLORFFBE00;
STICKLINE((OPEN > CLOSE),CLOSE,OPEN,1,0),COLORFFCC00;
STICKLINE((OPEN > CLOSE),CLOSE,OPEN,0.5,0),COLORFFFF00;
STICKLINE((OPEN > CLOSE),CLOSE,LOW,0.3,0),COLORFF9C00;
STICKLINE((OPEN > CLOSE),OPEN,HIGH,0.3,0),COLORFF9C00;
{STICKLINE((OPEN = CLOSE AND C<REF(C,1)),CLOSE,OPEN,5.2,0),COLORFF5B00;}
STICKLINE((OPEN = CLOSE AND C<REF(C,1)),CLOSE,OPEN,4,1),COLORFF6C00;
STICKLINE((OPEN = CLOSE AND C<REF(C,1)),CLOSE,OPEN,3.5,0),COLORFF7B00;
STICKLINE((OPEN = CLOSE AND C<REF(C,1)),CLOSE,OPEN,2,0),COLORFF9C00;
STICKLINE((OPEN = CLOSE AND C<REF(C,1)),CLOSE,OPEN,1.5,0),COLORFFBE00;
STICKLINE((OPEN = CLOSE AND C<REF(C,1)),CLOSE,OPEN,1,0),COLORFFCC00;
STICKLINE((OPEN = CLOSE AND C<REF(C,1)),CLOSE,OPEN,0.5,0),COLORFFFF00;
STICKLINE((OPEN = CLOSE AND C<REF(C,1)),CLOSE,LOW,0.3,0),COLORFF9C00;
STICKLINE((OPEN = CLOSE AND C<REF(C,1)),OPEN,HIGH,0.3,0),COLORFF9C00;
赞(0) 打赏
指标公式仅供学习研究,请勿以此为依据进行股票交易,依此入市,盈亏自负。股票指标 » 通达信神器的boll布林线指标

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏