股票指标
专业的通达信指标网站

通达信成交量和量比指标

成交量修改的指标,融合了量比,动神线、鬼力线,有空头释放,逢高出货等提示,我个人不太习惯用这个指标,不过身边有人说用的还行,大家自己看看。

V11A:=((((H>L) AND (C>O)) AND (H=C)) AND (L=O));
V12A:=((V*(C-O))/(H-L));
VD1A:=IF(V11A,V12A,0);
VZ1A:=IF(V11A,0,0);
V21A:=((((H>L) AND (C>O)) AND (H=C)) AND (L<O));
V22A:=(V*(((C-O)/(H-L)) + (((2/3)*(O-L))/(H-L))));
V23A:=((((V*1)/3)*(O-L))/(H-L));
VD2A:=IF(V21A,V22A,0);
VZ2A:=IF(V21A,V23A,0);
V31A:=((((H>L) AND (C>O)) AND (H>C)) AND (L=O));
V32A:=(V*(((C-O)/(H-L)) + (((1/3)*(H-C))/(H-L))));
V33A:=((((V*2)/3)*(H-C))/(H-L));
VD3A:=IF(V31A,V32A,0);
VZ3A:=IF(V31A,V33A,0);
V41A:=((((H>L) AND (C>O)) AND (H>C)) AND (L<O));
V42A:=(V*((((C-O)/(H-L)) + (((1/3)*(H-C))/(H-L))) + (((2/3)*(O-L))/(H-L))));
V43A:=(V*((((2/3)*(H-C))/(H-L)) + (((1/3)*(O-L))/(H-L))));
VD4A:=IF(V41A,V42A,0);
VZ4A:=IF(V41A,V43A,0);
V51A:=((((H>L) AND (C<O)) AND (H=O)) AND (L=C));
V52A:=((V*(O-C))/(H-L));
VD5A:=IF(V51A,0,0);
VZ5A:=IF(V51A,V52A,0);
V61A:=((((H>L) AND (C<O)) AND (H=O)) AND (L<C));
V62A:=((((V*(C-L))/(H-L))*2)/3);
V63A:=(V*(((O-C)/(H-L)) + (((1/3)*(C-L))/(H-L))));
VD6A:=IF(V61A,V62A,0);
VZ6A:=IF(V61A,V63A,0);
V71A:=((((H>L) AND (C<O)) AND (H>O)) AND (L=C));
V72A:=((((V*1)/3)*(H-O))/(H-L));
V73A:=(V*(((O-C)/(H-L)) + (((2/3)*(H-O))/(H-L))));
VD7A:=IF(V71A,V72A,0);
VZ7:=IF(V71A,V73A,0);
V81A:=((((H>L) AND (C<O)) AND (H>O)) AND (L<C));
V82A:=(V*((((1/3)*(H-O))/(H-L)) + (((2/3)*(C-L))/(H-L))));
V83A:=(V*((((O-C)/(H-L)) + (((2/3)*(H-O))/(H-L))) + (((1/3)*(C-L))/(H-L))));
VD8A:=IF(V81A,V82A,0);
VZ8A:=IF(V81A,V83A,0);
V91A:=((((H>L) AND (C=O)) AND (H=C)) AND (L<C));
V92A:=((V*2)/3);
V93A:=((V*1)/3);
VD9A:=IF(V91A,V92A,0);
VZ9A:=IF(V91A,V93A,0);
V101A:=((((H>L) AND (C=O)) AND (H>C)) AND (L=C));
V102A:=((((V*1)/3)*(H-L))/(H-L));
V103A:=((((V*2)/3)*(H-L))/(H-L));
VD10A:=IF(V101A,V102A,0);
VZ10A:=IF(V101A,V103A,0);
V111A:=((((H>L) AND (C=O)) AND (H>C)) AND (L<C));
V112A:=(V*((((1/3)*(H-C))/(H-L)) + (((2/3)*(C-L))/(H-L))));
V113A:=(V*((((2/3)*(H-C))/(H-L)) + (((1/3)*(C-L))/(H-L))));
VD11A:=IF(V111A,V112A,0);
VZ11A:=IF(V111A,V113A,0);
V121A:=(((((H=L) AND (C=O)) AND (H=C)) AND (L=C)) AND ((((C-REF(C,1))/REF(C,1))*100)>9.75));
VD12A:=IF(V121A,V,0);
V122A:=(((((H=L) AND (C=O)) AND (H=C)) AND (L=C)) AND ((((C-REF(C,1))/REF(C,1))*100)<(0-9.75)));
VZ12A:=IF(V122A,V,0);
V131A:=((((((H=L) AND (C=O)) AND (H=C)) AND (L=C)) AND ((((C-REF(C,1))/REF(C,1))*100)<9.75)) AND ((((C-REF(C,1))/REF(C,1))*100)>(0-9.75)));
VD13A:=IF(V131A,(0.5*V),0);
V132A:=((((((H=L) AND (C=O)) AND (H=C)) AND (L=C)) AND ((((C-REF(C,1))/REF(C,1))*100)<9.75)) AND ((((C-REF(C,1))/REF(C,1))*100)>(0-9.75)));
VZ13A:=IF(V132A,(0.5*V),0);
真神:=VD1A + VD2A + VD3A + VD4A + VD5A + VD6A + VD7A + VD8A + VD9A + VD10A + VD11A + VD12A + VD13A;
V11:=((((H>L) AND (C>O)) AND (H=C)) AND (L=O));
V12:=((V*(C-O))/(H-L));
VD1:=IF(V11,V12,0);
VZ1:=IF(V11,0,0);
V21:=((((H>L) AND (C>O)) AND (H=C)) AND (L<O));
V22:=(V*(((C-O)/(H-L)) + (((2/3)*(O-L))/(H-L))));
V23:=((((V*1)/3)*(O-L))/(H-L));
VD2:=IF(V21,V22,0);
VZ2:=IF(V21,V23,0);
V31:=((((H>L) AND (C>O)) AND (H>C)) AND (L=O));
V32:=(V*(((C-O)/(H-L)) + (((1/3)*(H-C))/(H-L))));
V33:=((((V*2)/3)*(H-C))/(H-L));
VD3:=IF(V31,V32,0);
VZ3:=IF(V31,V33,0);
V41:=((((H>L) AND (C>O)) AND (H>C)) AND (L<O));
V42:=(V*((((C-O)/(H-L)) + (((1/3)*(H-C))/(H-L))) + (((2/3)*(O-L))/(H-L))));
V43:=(V*((((2/3)*(H-C))/(H-L)) + (((1/3)*(O-L))/(H-L))));
VD4:=IF(V41,V42,0);
VZ4:=IF(V41,V43,0);
V51:=((((H>L) AND (C<O)) AND (H=O)) AND (L=C));
V52:=((V*(O-C))/(H-L));
VD5:=IF(V51,0,0);
VZ5:=IF(V51,V52,0);
V61:=((((H>L) AND (C<O)) AND (H=O)) AND (L<C));
V62:=((((V*(C-L))/(H-L))*2)/3);
V63:=(V*(((O-C)/(H-L)) + (((1/3)*(C-L))/(H-L))));
VD6:=IF(V61,V62,0);
VZ6:=IF(V61,V63,0);
V71:=((((H>L) AND (C<O)) AND (H>O)) AND (L=C));
V72:=((((V*1)/3)*(H-O))/(H-L));
V73:=(V*(((O-C)/(H-L)) + (((2/3)*(H-O))/(H-L))));
VD7:=IF(V71,V72,0);
VZ7A:=IF(V71,V73,0);
V81:=((((H>L) AND (C<O)) AND (H>O)) AND (L<C));
V82:=(V*((((1/3)*(H-O))/(H-L)) + (((2/3)*(C-L))/(H-L))));
V83:=(V*((((O-C)/(H-L)) + (((2/3)*(H-O))/(H-L))) + (((1/3)*(C-L))/(H-L))));
VD8:=IF(V81,V82,0);
VZ8:=IF(V81,V83,0);
V91:=((((H>L) AND (C=O)) AND (H=C)) AND (L<C));
V92:=((V*2)/3);
V93:=((V*1)/3);
VD9:=IF(V91,V92,0);
VZ9:=IF(V91,V93,0);
V101:=((((H>L) AND (C=O)) AND (H>C)) AND (L=C));
V102:=((((V*1)/3)*(H-L))/(H-L));
V103:=((((V*2)/3)*(H-L))/(H-L));
VD10:=IF(V101,V102,0);
VZ10:=IF(V101,V103,0);
V111:=((((H>L) AND (C=O)) AND (H>C)) AND (L<C));
V112:=(V*((((1/3)*(H-C))/(H-L)) + (((2/3)*(C-L))/(H-L))));
V113:=(V*((((2/3)*(H-C))/(H-L)) + (((1/3)*(C-L))/(H-L))));
VD11:=IF(V111,V112,0);
VZ11:=IF(V111,V113,0);
V121:=(((((H=L) AND (C=O)) AND (H=C)) AND (L=C)) AND ((((C-REF(C,1))/REF(C,1))*100)>9.75));
VD12:=IF(V121,V,0);
V122:=(((((H=L) AND (C=O)) AND (H=C)) AND (L=C)) AND ((((C-REF(C,1))/REF(C,1))*100)<(0-9.75)));
VZ12:=IF(V122,V,0);
V131:=((((((H=L) AND (C=O)) AND (H=C)) AND (L=C)) AND ((((C-REF(C,1))/REF(C,1))*100)<9.75)) AND ((((C-REF(C,1))/REF(C,1))*100)>(0-9.75)));
VD13:=IF(V131,(0.5*V),0);
V132:=((((((H=L) AND (C=O)) AND (H=C)) AND (L=C)) AND ((((C-REF(C,1))/REF(C,1))*100)<9.75)) AND ((((C-REF(C,1))/REF(C,1))*100)>(0-9.75)));
VZ13:=IF(V132,(0.5*V),0);
魔鬼:=VZ1 + VZ2 + VZ3 + VZ4 + VZ5 + VZ6 + VZ7 + VZ8 + VZ9 + VZ10 + VZ11 + VZ12 + VZ13;
量比A:(V/MA(V,5)),LINETHICK0,COLORYELLOW;
V10:=真神;
V20:=魔鬼;
JX1:=BARSSINCE(V10);
JY1:=IF(((121>JX1) AND (JX1>0)),JX1,120);
JY2:=IF(((4>JX1) AND (JX1>0)),JX1,3);
V30:=MA(V,JY2);
动神:V10,COLORF00FF0;
鬼力:V20,COLORBBBBBB;
神比:=(动神/V30);
鬼比:=(鬼力/V30); V2:=(H-L);
V3:=ABS((O-C));
V4:=(H-IF((C>O),C,O));
V5:=(IF((C>O),O,C)-L);
V6:=((V3/V2)*V);
V7:=((V4/V2)*V);
V8:=((V5/V2)*V);
V9:=IF(((V/CAPITAL)>0.001),1,EXP(ABS(LOG(((V/CAPITAL)*100)))));
VA:=(((C-MA(C,5))/MA(C,5))*100);
VB:=(((MA(C,5)>MA(C,10)) AND (MA(C,10)>MA(C,30))) AND (MA(C,30)>MA(C,60)));
VC:=((MA(C,5)<MA(C,10)) AND (MA(C,10)<MA(C,30)));
V40:=((IF((((V6 >= V7) AND (V6 >= V8)) AND (C>O)),V6,动神) + 动神)/2);
V41B:=((IF(((V7>V6) AND (V7>V8)),V7,动神) + 动神)/2);
V42B:=((IF(((V8>V6) AND (V8>V7)),V8,动神) + 动神)/2);
V50:=((IF((((V6 >= V7) AND (V6 >= V8)) AND (C<O)),V6,鬼力) + 鬼力)/2);
STICKLINE((鬼力>0),鬼力,0,3,0),COLORFF3399;
多头:STICKLINE((C>MA(C,30)),0,V,3,1),COLORRED;
空头:STICKLINE((C<MA(C,30)),0,V,3,0),COLORGREEN;
STICKLINE((鬼力>0),鬼力,0,3,0),COLORFF3399;
上攻量:STICKLINE((((V6 >= V7) AND (V6 >= V8)) AND (C>O)),0,V6,3,0),COLOR66FFFF;
下攻量:STICKLINE((((V6 >= V7) AND (V6 >= V8)) AND (C<O)),0,V6,3,0),COLOR6633FF;
上探量:STICKLINE(((V7>V6) AND (V7>V8)),0,V7,3,0),COLORCCCC66;
下探量:STICKLINE(((V8>V6) AND (V8>V7)),0,V8,3,0),COLORFF6633;
相对地量:STICKLINE(((V9>2) AND (V<(MA(V,5)/2))),0,V,3,0),COLOR9966CC;
地量:DRAWTEXT(((V9>2) AND (V<(MA(V,5)/2))),V,'地量'),COLORF00FF0;
放量:STICKLINE((V>(MA(V,5)*2.5)),0,V,3,0),COLORFFFFFF;
STICKLINE((动神>0),动神,0,1.5,0),COLORF00FF0;
逢高出货:DRAWTEXT(((((((((V7>V6) AND (VA>2)) AND (V9>V8)) AND (C>MA(C,5))) AND (C>MA(C,30))) AND (H>MA(C,60))) AND (V>MA(V,5))) AND (V7 >= MA(V,5))),V,'逢高出货'),COLORF00FF0;
逢低跟进:DRAWTEXT(((((((V8>V6) AND (V8>V7)) AND (VA<(0-2))) AND (C<MA(C,30))) AND (V8<(MA(V,5)/2))) AND (MA(V,5)<MA(V,10))),V,'低进'),COLORFF00FF;
强势参与:DRAWTEXT((((((V6>(MA(V,5)*2)) AND (V6 >= V7)) AND (V6 >= V8)) AND (C>O)) OR ((V>(MA(V,5)*3)) AND VB)),V,'强势参与'),COLORCC99CC;
空头释放:DRAWTEXT(((((((V6 >= V7) AND (V6 >= V8)) AND (C<O)) AND ((V6/V)>0.7)) AND VC) AND (V6>MA(V,5))),(V6*2),'空头释放'),COLORF00FF0;
赞(0) 打赏
指标公式仅供学习研究,请勿以此为依据进行股票交易,依此入市,盈亏自负。股票指标 » 通达信成交量和量比指标

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏