股票指标
专业的通达信指标网站

通达信震荡警戒指标

不同区域做了不同的颜色填充,我把前面的颜色填充去掉之后,并没有发现未来函数,就把颜色又添加进去了。所以,不需要考虑未来函数的问题,只需要考虑信号的准确度就行了,感兴趣的自己琢磨一下。

STICKLINE(100,120,50,5,0),COLOR669900;
STICKLINE(50,50,0,5,0),COLOR666600;
STICKLINE(1,0,-50,5,0),COLOR006600;
STICKLINE(-50,-50,-120,5,0),COLOR003300;
VARC:=SMA(((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10)))*(100),4,1);
VARD:=SMA(((CLOSE-LLV(LOW,11))/(HHV(HIGH,11)-LLV(LOW,11)))*(100),4,1);
VARE:=SMA(((CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12)))*(100),4,1);
VARF:=SMA(((CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13)))*(100),4,1);
VAR10:=SMA(((CLOSE-LLV(LOW,14))/(HHV(HIGH,14)-LLV(LOW,14)))*(100),4,1);
VAR11:=SMA(((CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15)))*(100),4,1);
VAR12:=SMA(((CLOSE-LLV(LOW,16))/(HHV(HIGH,16)-LLV(LOW,16)))*(100),4,1);
VAR13:=SMA(((CLOSE-LLV(LOW,17))/(HHV(HIGH,17)-LLV(LOW,17)))*(100),4,1);
VAR14:=SMA(((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18)))*(100),4,1);
VAR17:=SMA(((CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20)))*(100),4,1);
VAR18:=(HIGH+LOW+CLOSE)/(3);
VAR19:=(VAR18-MA(VAR18,14))/((0.015)*(AVEDEV(VAR18,14)));
VAR1A:=(VAR18-MA(VAR18,70))/((0.015)*(AVEDEV(VAR18,70)));
VAR1B:=IF((VAR19>=150) AND (VAR19<200) AND (VAR1A>=150) AND (VAR1A<200),(-10),0);
VAR1C:=IF((VAR19<=(-150)) AND (VAR19>(-200)) AND (VAR1A<=(-150)) AND (VAR1A>(-200)),10,0);
VAR1D:=((CLOSE-MA(CLOSE,13))/(MA(CLOSE,13)))*(100);
VAR1E:=100-ABS(VAR1D);
趋势: (SMA((VAR11-50)*(2),3,1)+SMA((VARD-50)*(2),3,1))/(2),COLORRED,LINETHICK2;
D: ((3)*(VAR17-50))*(2)-(2)*(SMA((VAR17-50)*(2),3,1)),COLOR00FFFF;
警1:IF((BARSCOUNT(CLOSE)<70),120,IF((VAR1A>=200) AND (VAR19>=150),(-15),VAR1B)+120),COLORCCFF66;
警2:IF((BARSCOUNT(CLOSE)<13),100,IF((VAR1E<88) AND (VAR1D>0),85,100)),COLORCCFFCC;
警3:IF((BARSCOUNT(CLOSE)<13),(-100),0-IF((VAR1E<92) AND (VAR1D<0),85,100)),COLORGREEN;
警4:IF((BARSCOUNT(CLOSE)<70),(-120),IF((VAR1A<=(-200)) AND (VAR19<=(-150)),15,VAR1C)-120),COLORBLUE;
{警戒区:}
VAR50:=(HIGH+LOW+CLOSE)/3;
VAR60:=(VAR50-MA(VAR50,10))/(0.015*AVEDEV(VAR50,10));
VAR70:=(VAR50-MA(VAR50,30))/(0.015*AVEDEV(VAR50,30));
VAR80:=IF(VAR60>=150 AND VAR60<200 AND VAR70>=150 AND VAR70<200,100,0);
VAR90:=IF(VAR60<=-150 AND VAR60>-200 AND VAR70<=-150 AND VAR70>-200,-100,VAR80);
警5: (IF((VAR70>=200 AND VAR60>=150),100,IF(VAR70<=-200 AND VAR60<=-150,-100,VAR90))+0.01),COLORSTICK,COLORRED,LINETHICK1;
VARK1:=3*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1),3,1);
VARK2:=EMA(VARK1,3), COLORBLACK,COLORYELLOW;
STICKLINE(VARK2<=13,-20,-18,8,0),COLOR0066FF;
STICKLINE(VARK2<=13 AND (VARK2-REF(VARK2,1))/REF(VARK2,1)*100>13,-20,-10,1,0),COLORMAGENTA;
赞(0) 打赏
指标公式仅供学习研究,请勿以此为依据进行股票交易,依此入市,盈亏自负。股票指标 » 通达信震荡警戒指标

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏