股票指标
专业的通达信指标网站

通达信趋势MACD和买卖选股指标公式

根据MACD改变的一个指标,个人感觉这个指标信号有点频繁,周期太短,容易把大牛放跑了,所以参考价值不是特别大,有意义的地方在于这个指标的设计,有一定的新颖独到之处,学习指标编程和实现某些功能的,可以借鉴一下。

DIF1:=EMA(CLOSE,6) - EMA(CLOSE,13);
DEA1:=EMA(DIF1,5);
MACD1:=2*(DIF1-DEA1),STICK;
MACD2:EMA(MACD1,5)COLORWHITE;
蓝:STICKLINE(MACD1<MACD2 AND MACD1<0,0,MACD1,1,0),COLORBLUE;
粉:STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,1,1),COLORMAGENTA;
红:STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,1,1),COLORRED;
绿:STICKLINE(MACD1<MACD2 AND MACD1>0,0,MACD1,1,0),COLORGREEN;
A:DRAWTEXT(CROSS(粉,蓝),MACD1 -0.1,'买')COLORGREEN;
B:DRAWTEXT(CROSS(绿,红),MACD2 -0.01,'卖')COLORYELLOW;
赞(0) 打赏
指标公式仅供学习研究,请勿以此为依据进行股票交易,依此入市,盈亏自负。股票指标 » 通达信趋势MACD和买卖选股指标公式

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏