股票指标
专业的通达信指标网站

通达信自动画百分线指标公式

一个带有买卖点和自动画百分比线的指标,买点有时候准,有时候不准,凑合着看,毕竟信号这东西,出现之后还需要自己判断一下呢。画线工具指标一般都带有未来函数,但这个指标没有未来函数,还是有一定参考价值的。

M1:MA(C,5);
M2:MA(C,8);
M3:MA(C,13);
MA30:=MA(C,30);
N:=60;M:=1;
高:=REF(HHV(H,N),M);
低:=REF(LLV(L,N),M);
H33:=高-(高-低)*0.33;
H中:=高-(高-低)*0.5;
H66:=高-(高-低)*0.66;
顶点:REFDATE(高,DATE),COLORAAAA00;
%33:REFDATE(H33,DATE),COLORAAAAAA;
%50:REFDATE(H中,DATE),COLORAAAA00;
%66:REFDATE(H66,DATE),COLORAAAAAA;
低点:REFDATE(低,DATE),COLORAAAA00;
DRAWTEXT(ISLASTBAR,顶点,'顶'),COLORAAAAAA;
DRAWTEXT(ISLASTBAR,%33,'%33'),COLORAAAAAA;
DRAWTEXT(ISLASTBAR,%50,'%50'),COLORRED;
DRAWTEXT(ISLASTBAR,%66,'%66'),COLORAAAAAA;
DRAWTEXT(ISLASTBAR,低点,'低'),COLORAAAAAA;

{长脚}
长脚:=(MIN(C,O)-L)/L*100>3.5 AND (MIN(C,O)-L)/(MAX(C,O)-MIN(C,O))>1.3 AND L<=LLV(L,50);
STICKLINE(长脚,H,L,0.0,1),COLORFFFFFF;
STICKLINE(长脚,O,C,3,1),COLORFFFFFF;
十字:=(MIN(CLOSE,OPEN)-LOW)/MIN(CLOSE,OPEN)>0.015 AND (H-MAX(CLOSE,OPEN))/MAX(CLOSE,OPEN)>0.015 AND MAX(CLOSE,OPEN)/MIN(CLOSE,OPEN)<1.012;
STICKLINE(十字,H,L,0,1),COLOR00FFFF;
STICKLINE(十字,C,O,3,0),COLOR00FFFF;
哎呀:=C/MA(C,5)<0.96 AND O/REF(L,1)<0.99 AND C>REF(L,1) AND MA(C,3)/REF(MA(C,3),1)<0.98;
STICKLINE(哎呀,H,L,0,1),COLORFFFFFF,LINETHICK1;
STICKLINE(哎呀,C,O,1,0),COLORFFFFFF,LINETHICK1;
DRAWTEXT(哎呀,LOW,'哎呀'),COLORFFFFFF;
桩:=C/REF(C,1)>1.03 AND V/REF(V,1)>2 AND C=HHV(C,7);
STICKLINE(桩,C,O,3,0),COLOR0000FF,LINETHICK1;
STICKLINE(桩,C,O,2,0),COLOR00AAFF,LINETHICK1;
STICKLINE(桩,C,O,1,0),COLOR00FFFF,LINETHICK1;
赞(0) 打赏
指标公式仅供学习研究,请勿以此为依据进行股票交易,依此入市,盈亏自负。股票指标 » 通达信自动画百分线指标公式

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏