股票指标
专业的通达信指标网站

通达信空头趋势关注指标公式

内容很丰富的指标,使用前需要先把源码理顺了,不然看着信号有点多,会有点乱的。里面包含买入、筹码介入等多个信号。

VAR01:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),15,1);
VAR02:=HIGH-REF(HIGH,5);
VAR03:=REF(LOW,5)-LOW;
VAR04:=SMA(IF(VAR02>0 AND VAR02>VAR03,VAR02,0),15,1);
VAR05:=SMA(IF(VAR03>0 AND VAR03>VAR02,VAR03,0),15,1);
VAR06:=LLV(LOW,27);
VAR07:=HHV(HIGH,34);
VAR08:=EMA((CLOSE-VAR06)/(VAR07-VAR06)*4,4)*25;
VAR09:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);
做空:VAR05*100/VAR01,COLORLIBLUE;
提示买入:IF(VAR09<=8,8,0),STICK,COLORWHITE,LINETHICK2;
买入:IF(CROSS(VAR09,8),110,0),STICK,COLOR0000CC,LINETHICK2;
DRAWTEXT(CROSS(VAR09,8),105,'B'),COLORWHITE;
VAR10:=MA(C,2)>REF(MA(C,2),1);
VAR11:=MA(C,10)>MA(C,20);
VAR12:=(CLOSE*2+HIGH+LOW)/4;
VAR13:=EMA(VAR12,12)-EMA(VAR12,50);
VAR14:=EMA(VAR13,2);
VAR15:=(CROSS(VAR13,VAR14) AND VAR13<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03)
OR (CROSS(VAR13,VAR14) AND VAR13<=-0.14 ) OR (CROSS(VAR13,VAR14) AND VAR13<=0.05
AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)) AND VAR10 AND VAR11;
STICKLINE(VAR15>0,60,110,2,0),COLORRED;
DRAWTEXT(VAR15,90,'←黑马'),COLORYELLOW;
VAR16:=REF(LOW,1);
VAR17:=(SMA(ABS(LOW-VAR16),13,1))/(SMA(MAX(LOW-VAR16,0),13,1))*100;
VAR18:=MA(VAR17,13);
VAR19:=LLV(LOW,34);
VAR20:=EMA(IF(LOW<=VAR19,VAR18,0),3);
VAR21:=SMA(SMA((CLOSE-LLV(LOW,54))/(HHV(HIGH,54)-LLV(LOW,54))*100,7,1),5,1);
VAR22:=SMA((CLOSE-LLV(LOW,54))/(HHV(HIGH,54)-LLV(LOW,54))*100,7,1)*16.18-VAR21*10.9;
VAR23:=FILTER(IF(VAR22<=VAR21 AND VAR20>REF(VAR20,1),VAR20*8,0),20);
DRAWTEXT(VAR23,35,'←洗盘'),COLORGREEN;
STICKLINE(VAR23=1,35,110,2,0),COLORGREEN;
VAR24:=3;
VAR25:=(3)*(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1)) - (2)*(SMA(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1),3,1));
买点:IF((VAR25<=3),15,0),COLORYELLOW,LINETHICK2;
补仓:IF((VAR25<5),10,0),COLORRED,LINETHICK2;
VAR26:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR27:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA
((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR28:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA
((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR29:=VAR27<REF(VAR28,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
VAR30:=(HIGH+LOW+CLOSE)/3;
VAR31:=(VAR30-MA(VAR30,14))/(0.015*AVEDEV(VAR30,14));
VAR32:=(VAR30-MA(VAR30,70))/(0.015*AVEDEV(VAR30,70));
VAR33:=IF(VAR31>=150 AND VAR31<200 AND VAR32>=150 AND VAR32<200,10,0);
VAR34:=IF(VAR31<=-150 AND VAR31>-200 AND VAR32<=-150 AND VAR32>-200,-10,VAR33);
VAR35:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR36:=100-ABS(VAR35);
VAR37:=IF(VAR36<90,VAR36,100);
VAR38:=IF(VAR26>0,VAR26,0);
VAR39:=IF(VAR32>=200 AND VAR31>=150,15,IF(VAR32<=-200 AND VAR31<=-150,-15,VAR34))+60;
VAR40:=VAR38>60 AND VAR39>70 AND VAR37<100;
VAR41:=((CLOSE-MA(CLOSE,18))/MA(CLOSE,18)*100+(CLOSE-MA(CLOSE,90))/MA(CLOSE,90)*100+(CLOSE-MA(CLOSE,72))/MA(CLOSE,72)*100)/3;
DRAWTEXT(VAR29 AND COUNT(VAR29,30)=1,70,'←筹码进入'),COLORMAGENTA;
STICKLINE(VAR29 AND COUNT(VAR29,30)=1,60,110,2,0),COLORMAGENTA;
DRAWTEXT(VAR40 AND COUNT(VAR40,30)=1,35,'←出逃'),COLORCYAN;
STICKLINE(VAR40 AND COUNT(VAR40,30)=1,50,110,2,0),COLORCYAN;
DRAWTEXT(FILTER(VAR41<-9 AND VAR41>REF(VAR41,1),78),55,'←买票'),COLORWHITE;
STICKLINE(FILTER(VAR41<-9 AND VAR41>REF(VAR41,1),78),55,110,2,0),COLORWHITE;
快:=COUNT(CLOSE>REF(CLOSE,2),4)/4*100;
慢:=COUNT(CLOSE>REF(CLOSE,2),6)/6*100;
关注:IF(快=0 AND 慢=0,10,0),COLORCYAN,LINETHICK2;
风险:IF(快=100 AND 慢>=80,100,110),COLORLIGREEN;
FXSJ:=BARSLAST(风险=90);
DRAWTEXT(CROSS(关注,1),20,'关注'),COLORRED;
DRAWTEXT(CROSS(LAST(关注,5,1),0.8),17,'地下室'),COLORYELLOW;
DRAWTEXT(FXSJ=1,107,'走'),COLORGREEN;
DRAWICON(风险=100,115,2);
赞(1) 打赏
指标公式仅供学习研究,请勿以此为依据进行股票交易,依此入市,盈亏自负。股票指标 » 通达信空头趋势关注指标公式

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏