股票指标
专业的通达信指标网站

通达信智慧波段公式

波段指标,在横盘或者上升趋势可以用,在下降通道的空头趋势不适用。下降通道容易抄底抄在半山腰,选股的话得用综合选股。

JM:=1;
TT:=39;
N:=5;
VAR1A:=4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1);
VAR2A:=8;
{DRAWICON(CROSS(VAR1A,VAR2A),8,3)};
VARO5A:=LLV(LOW,27);
VARO6A:=HHV(HIGH,34);
VARO7A:=EMA((CLOSE-VARO5A)/(VARO6A-VARO5A)*4,4)*25;
AA:=REF(CLOSE,1);
BBB:=SMA(MAX(CLOSE-AA,0),5,1)/SMA(ABS(CLOSE-AA),5,1)*1000;
HHH:=BBB-LLV(BBB,10);
SS:=(MA(HHH,2)*3+HHH*13)/64;
短线买点:=IF(SS>13,MA(SS,2),SS);
MM:=WINNER(H/2+L/2)*100;
WW:=3;
VAR2:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
VAR3:=((REF(VAR2,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR4:=((REF(VAR3,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR5:=((REF(VAR4,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR6:=((REF(VAR5,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR7:=((REF(VAR6,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR8:=((REF(VAR7,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR9:=((REF(VAR8,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARA:=((REF(VAR9,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARB:=((REF(VARA,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARC:=((REF(VARB,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARD:=((REF(VARC,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARE:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2)));
VARF:=((REF(VARE,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR10:=((REF(VARF,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR11:=((REF(VAR10,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR12:=((REF(VAR11,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR13:=((REF(VAR12,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR14:=((REF(VAR13,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR15:=((REF(VAR14,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR16:=((REF(VAR15,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR17:=((REF(VAR16,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR18:=((REF(VAR17,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR19:=((REF(VAR18,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR1AA:=(REF((((((((((((VARE OR VARF) OR VAR10) OR VAR11) OR VAR12) OR VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18) OR VAR19),1) AND VAR2);
VARAA:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VARBA:=SMA(VARAA,3,1);
VARCA:=SMA(VARBA,3,1);
智慧波段1:EMA(3*VARBA-2*VARCA,3)*JM,COLORYELLOW;
加速:=智慧波段1;
买入:IF(MM>REF(MM,1) AND VAR1A>REF(VAR1A,1)
AND 短线买点>REF(短线买点,1) AND VAR1A<80 AND 短线买点>5
AND VAR1AA=1 AND REF(加速,1)<TT,150,0)*JM,COLORRED,LINETHICK2;
R加速:=REF(加速,1);
DRAWICON(CROSS(R加速,加速),加速,2);
DRAWICON(CROSS(加速,R加速) AND R加速<50,R加速,11);
{MC:=IF(C<REF(L,1)*1.01,1,0);
DRAWICON(CROSS(MC,0.9),100,2)};
B1:=(HHV(H,9)-C)/(HHV(H,9)-LLV(LOW,9))*100- 70;
B2:=SMA(B1,9,1)+100;
B3:=(C-LLV(L,9))/(HHV(H,9)- LLV(L,9))*100;
B4:=SMA(B3,3,1);
B5:=SMA(B4,3,1)+100;
B6:=(B5-B2);
模量:=VOL*240;
LF:=100*(EMA(IF(C>O,模量,0),10)-EMA(IF(C<O,模量,0),10))/EMA(VOL,5);
JF:=50*EMA((2*C-REF(C,1)-REF(O,1)),10)/EMA(H-L,5);
LJF:=SMA((JF+LF)/2,3,1);
量价指标:=JF+LF;
量价趋势:=LJF;
量价动力:=3*LJF-2*SMA(LJF,3,1);
SZ:=ABS((C-O)/O)*10000;
买2:IF((MM>REF(MM,1) AND VAR1A>REF(VAR1A,1)
AND 短线买点>REF(短线买点,1) AND VAR1A<80 AND 短线买点>5 AND (CROSS(加速,R加速))
AND R加速<55
AND REF(SZ,1)<150)
OR (MM>REF(MM,1) AND VAR1A>REF(VAR1A,1)
AND 短线买点>REF(短线买点,1) AND VAR1A<80 AND 短线买点>5 AND (CROSS(加速,R加速))
AND R加速<55 AND REF(SZ,1)<150)*JM
,100,0),COLORYELLOW;
买3:IF((MM>REF(MM,1) AND VAR1A>REF(VAR1A,1)
AND 短线买点>REF(短线买点,1) AND VAR1A<80 AND 短线买点>5 AND (CROSS(加速,R加速))
AND CROSS(量价指标,REF(量价指标,1)) AND REF(量价指标,1)<量价趋势*1.4 AND
R加速<55)
OR (MM>REF(MM,1) AND VAR1A>REF(VAR1A,1)
AND 短线买点>REF(短线买点,1) AND VAR1A<80 AND 短线买点>5 AND (CROSS(加速,R加速))
AND CROSS(量价指标,量价趋势) AND R加速<55)*JM
,70,0),COLORRED;
买4:IF((MM>REF(MM,1) AND VAR1A>REF(VAR1A,1)
AND 短线买点>REF(短线买点,1) AND VAR1A<80 AND 短线买点>5 AND (CROSS(加速,R加速))
AND CROSS(量价指标,REF(量价指标,1)) AND REF(量价指标,1)<量价趋势*1.4)
OR (MM>REF(MM,1) AND VAR1A>REF(VAR1A,1)
AND 短线买点>REF(短线买点,1) AND VAR1A<80 AND 短线买点>5 AND (CROSS(加速,R加速))
AND CROSS(量价指标,量价趋势))*JM,40,0),COLORMAGENTA;
赞(0) 打赏
指标公式仅供学习研究,请勿以此为依据进行股票交易,依此入市,盈亏自负。股票指标 » 通达信智慧波段公式

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏