股票指标
专业的通达信指标网站

通达信有买卖点的布林主图公式指标

类似boll通道线的指标,原来3条线的基础之上,加了3条线,并且加入了买卖参考信号。

JL01:=MA(C,3);
LJL07:=(3*C+L+O+H)/6;
牛线: (20*LJL07+19*REF(LJL07,1)+18*REF(LJL07,2)+17*REF(LJL07,3)+16*REF(LJL07,4)+15*REF(LJL07,5)+14*REF(LJL07,6)+13*REF(LJL07,7)+12*REF(LJL07,8)+11*REF(LJL07,9)+10*REF(LJL07,10)+9*REF(LJL07,11)+8*REF(LJL07,12)+7*REF(LJL07,13)+6*REF(LJL07,14)+5*REF(LJL07,15)+4*REF(LJL07,16)+3*REF(LJL07,17)+2*REF(LJL07,18)+REF(LJL07,20))/210,COLORRED;
马线:MA(牛线,6),COLORYELLOW,LINETHICK4,POINTDOT;
上限:马线+3*STD(CLOSE,20),COLORMAGENTA,CROSSDOT;
下限:马线-2.9*STD(CLOSE,20),COLOR2693FF,CROSSDOT;
买:马线-2*STD(CLOSE,20),LINETHICK2,COLORFF937F;
卖:马线+2*STD(CLOSE,20),LINETHICK2,COLOR00FF00;
等待:IF(JL01<=牛线,马线,DRAWNULL),COLORMAGENTA,LINETHICK4,POINTDOT;
VAR1:=(C>REF(C,1) AND C>REF(C,2));
VAR2:=(REF(VAR1,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR3:=(REF(VAR2,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR4:=(REF(VAR3,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR5:=(REF(VAR4,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR6:=(REF(VAR5,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR7:=(REF(VAR6,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR8:=(REF(VAR7,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR9:=(REF(VAR8,1) AND C>=REF(C,1) AND C<=REF(C,2));
VARA:=(REF(VAR9,1) AND C<=REF(C,1) AND C>=REF(C,2));
VARB:=(REF(VARA,1) AND C>=REF(C,1) AND C<=REF(C,2));
VARC:=(REF(VARB,1) AND C<=REF(C,1) AND C>=REF(C,2));
持股:IF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,牛线,DRAWNULL),COLORRED,LINETHICK1;
VARD:=(C<REF(C,1) AND C<REF(C,2));
VARE:=(REF(VARD,1) AND C>=REF(C,1) AND C<=REF(C,2));
VARF:=(REF(VARE,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR10:=(REF(VARF,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR11:=(REF(VAR10,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR12:=(REF(VAR11,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR13:=(REF(VAR12,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR14:=(REF(VAR13,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR15:=(REF(VAR14,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR16:=(REF(VAR15,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR17:=(REF(VAR16,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR18:=(REF(VAR17,1) AND C>=REF(C,1) AND C<=REF(C,2));
持币:IF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,牛线,DRAWNULL),COLORGRAY,LINETHICK1;
LW05:=MA(C,5);
LW10:=MA(C,10);
LW30:=MA(C,30);
五日乖离率:=(C-LW05)/LW05*100;
三拾日乖离率:=(C-LW30)/LW30*100;
JL05:=ATAN((LW05/REF(LW05,1)-1)*100)*180/3.1416;
JL10:=ATAN((LW10/REF(LW10,1)-1)*100)*180/3.1416;
JL30:=ATAN((LW30/REF(LW30,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((LW05-REF(LW05,1))/REF(LW05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3);
强势狙击:=FILTER(JL30>30 AND JL10>45 AND CROSS(JL05,60),10);
加仓:=FILTER(COUNT(CROSS(JL05,30),5)>=1 AND LW05>REF(LW05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND LW10>REF(LW10,1)AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
清仓:=FILTER(COUNT(CROSS(30,JL05),5)>=1 AND (C>LW30 OR O>LW30) AND LW05<REF(LW05,1) AND 三拾日乖离率<REF(三拾日乖离率,1) AND LW10<REF(LW10,1),10);
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND LW05>REF(LW05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<LW30;
JL:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND LW10>REF(LW10,1) ;
减仓:=FILTER(JL,10);
买入:=FILTER(MR,10);
DRAWTEXT(减仓,HIGH*1.02,'←减仓'),COLORFF99FF;
DRAWTEXT(加仓 ,LOW*0.98,'←加仓'),COLORRED;
DRAWTEXT(买入,LOW*0.98,'←买入'),COLORYELLOW;
DRAWTEXT(清仓,HIGH*1.02,'←清仓'),COLORGREEN;
DRAWTEXT(强势狙击,LOW*0.98,'←强势狙击'),COLORYELLOW;
赞(0) 打赏
指标公式仅供学习研究,请勿以此为依据进行股票交易,依此入市,盈亏自负。股票指标 » 通达信有买卖点的布林主图公式指标

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏