股票指标
专业的通达信指标网站

通达信趋势线指标公式

这是一个震荡指标,有超买和超卖的趋势提示,在KDJ基础之上多加了一条辅助线,再超卖区域出现金叉,并且有信号提示,才是参考进场点。

M1:=WINNER( MA(CLOSE,1))*200;
M2:=WINNER(MA(CLOSE,20))*200;
VAR1:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=3*VAR2-2*VAR3;
VAR5:=LLV(LOW,5);
VAR6:=HHV(HIGH,5);
VAR7:=EMA((CLOSE-VAR5)/(VAR6-VAR5)*100,4)*2;
VAR8:=EMA(0.667*REF(VAR7,1)+0.333*VAR7,2);
VAR9:=3*VAR7-2*VAR8;
VARA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VARB:=POW(MA(LOW,5),2)+MA(LOW,5);
VARC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARD:=(VARA-LLV(VARB,64))/(HHV(VARC,64)-LLV(VARB,64))*150+65-10;
VARE:=SMA(VARD,3,1)*1.5-100;
VARF:=SMA(VARE,3,1);
VAR10:=3*VARE-2*VARF;
VAR11:=(HIGH+LOW+CLOSE*2)/4;
VAR12:=EMA(VAR11,13);
VAR13:=STD(VAR11,13);
VAR14:=(VAR11-VAR12)*100/VAR13;
VAR15:=EMA(VAR14,5);
VAR17:=EMA(VAR15,13)+200-100;
VAR18:=EMA(VAR17,10);
VAR19:=3*VAR17-2*VAR18;
VAR1A:=VAR2+VAR7+VARE+VAR17;
VAR1B:=VAR3+VAR8+VARF+VAR18;
VAR1C:=VAR4+VAR9+VAR10+VAR19;
VAR1D:=(HIGH+LOW+CLOSE)/3;
VAR20:=(VAR1D-MA(VAR1D,34))/(0.015*AVEDEV(VAR1D,34));
VAR21:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
VAR22:=(HIGH+LOW+CLOSE+VAR1D)/4;
VAR23:=EMA(VAR22,24);
VAR24:=STD(VAR22,24);
VAR25:=(VAR22-VAR23)/VAR24*100;
VAR26:=(VAR1D-MA(VAR1D,24))/(0.015*AVEDEV(VAR1D,24));
VAR27:=EMA(VAR25,5);
VAR2A:=((VAR27+VAR26+VAR20)/3+165)/4;
VAR2B:=(EMA(EMA(EMA(VAR2A,15),10),5)-25)*2+VAR21;
VAR2C:=(VAR1A+VAR1B+VAR1C*30)/32/5-15;
VAR2D:=EMA(VAR2C,13);{13}
VAR2E:=(VAR2A+VAR2C)/2/1.1;
VAR28:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR29:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR30:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR31:=REF(CLOSE,1);
VAR32:=SMA(MAX(CLOSE-VAR31,0),5,1)/SMA(ABS(CLOSE-VAR31),5,1)*100;
VAR33:=(HIGH+LOW+CLOSE)/3;
VAR34:=(VAR33-MA(VAR33,14))/(0.015*AVEDEV(VAR33,14));
VAR35:=(VAR28>=-15.8 AND VAR28<=-12.2 AND VAR29<=-20.8 AND VAR30<=-27.5 AND VAR32<=11.7 AND VAR34<=-145)*100;
多空比例:IF((M1-M2)>-0.02,M1-M2,-0.02),COLORF0F000;
超短:EMA(VAR2E,3),COLORRED ;
短线:EMA(超短,5),COLORWHITE;
趋势:EMA((VAR2B+VAR2D)/2,2) ,COLORYELLOW;
底部:0,COLORF00FF0,LINETHICK2;
界线:50,POINTDOT,COLORYELLOW;
风险:80,COLORWHITE;
顶:100,COLORBLUE;
逃命:120,COLORGREEN;
DRAWTEXT(CROSS(短线,超短) AND CROSS(趋势,超短) AND CROSS(趋势,短线),REF(超短,2)*1.2,'逃'),COLORBLUE;
DRAWICON(CROSS(超短,短线),超短,9);
DRAWICON(CROSS(短线,超短),短线,2);
DRAWICON(CROSS(超短,趋势),趋势,5);
A:=超短>REF(超短,1) AND 短线 >REF(短线,1) AND 趋势>REF(趋势,1) AND 多空比例>REF(多空比例,1);
DRAWICON(A,趋势,1);
赞(0) 打赏
指标公式仅供学习研究,请勿以此为依据进行股票交易,依此入市,盈亏自负。股票指标 » 通达信趋势线指标公式

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏