股票指标
专业的通达信指标网站

通达信量能趋势指标公式

有点类似于KDJ指标的外在表现形式,都是三条线,那么用法也可以参考KDJ指标的用法,只是三条线的算法和KDJ并不一样,底背离和强势底背离信号。

N:=4;
VAR1:=IF(C>=REF(C,1),V,0);
VAR2:=IF(C<REF(C,1),V,0);
VAR3:=SUM(VAR1,N);
VAR4:=SUM(VAR2,N);
能量:3*SMA((VAR3-LLV(VAR4,34))/(HHV(VAR3,34)-LLV(VAR4,34))*100,5,1)
-2*SMA(SMA((VAR3-LLV(VAR4,34))/(HHV(VAR3,34)-LLV(VAR4,34))*100,5,1),3,1),
COLORMAGENTA;
MA3:MA(能量,3),COLORWHITE;
MA6:MA(能量,6),COLORGREEN;
高拐点:=IF(REF(MA3,1)=HHV(MA3,4) AND MA3<REF(MA3,1) AND REF(MA3,1)>70
,REF(MA3,1),0),COLORCYAN;
低拐点:=IF(REF(MA3,1)=LLV(MA3,4) AND MA3>REF(MA3,1) AND REF(能量,1)<18
,REF(MA3,1),0),COLORYELLOW;
STICKLINE(低拐点=REF(MA3,1),-10,10,4,0),COLORYELLOW;
顶背离:IF(高拐点<HHV(高拐点,20) AND 高拐点=REF(MA3,1) AND
C>REF(C,BARSLAST(HHV(高拐点,20))),1,DRAWNULL);
DRAWTEXT(顶背离=1,MA3*1.10,'顶背'),COLORGREEN;
底背离:IF(低拐点>LLV(低拐点,20) AND 低拐点>0 AND
C<REF(C,BARSLAST(LLV(低拐点,20))),1,-10),COLORYELLOW;
DRAWTEXT(底背离=1,32,'底背'),COLORYELLOW;
HL:=EMA(WINNER(CLOSE)*75,3);
DRAWTEXT(低拐点=REF(MA3,1) AND LLV(HL,10)<=25 AND BARSLAST(LLV(HL,10))<=5,
20,'强底'),COLORMAGENTA;
死叉:IF(高拐点>0,110,130),COLORGREEN;
追:=IF(CROSS(能量,MA3) AND RANGE(MA3,20,50),1,0);
DRAWICON(追=1,0.8*MA3,7);
减:=IF(CROSS(MA3,能量) AND RANGE(MA3,50,70),1,0);
DRAWICON(减=1,1.1*MA3,8);

量能趋势之底背离选股指标公式:

N:=4;
VAR1:=IF(C>=REF(C,1),V,0);
VAR2:=IF(C<REF(C,1),V,0);
VAR3:=SUM(VAR1,N);
VAR4:=SUM(VAR2,N);
能量:=3*SMA((VAR3-LLV(VAR4,34))/(HHV(VAR3,34)-LLV(VAR4,34))*100,5,1)-2*SMA(SMA((VAR3-LLV(VAR4,34))/(HHV(VAR3,34)-LLV(VAR4,34))*100,5,1),3,1);
MA3:=MA(能量,3);
低拐点:=IF(REF(MA3,1)=LLV(MA3,4) AND MA3>REF(MA3,1) AND REF(能量,1)<18,REF(MA3,1),0);
底背离:IF(低拐点>LLV(低拐点,20) AND 低拐点>0 AND C<REF(C,BARSLAST(LLV(低拐点,20))),1,-10);

量能趋势之强底选股指标公式:

N:=4;
VAR1:=IF(C>=REF(C,1),V,0);
VAR2:=IF(C<REF(C,1),V,0);
VAR3:=SUM(VAR1,N);
VAR4:=SUM(VAR2,N);
能量:=3*SMA((VAR3-LLV(VAR4,34))/(HHV(VAR3,34)-LLV(VAR4,34))*100,5,1)-2*SMA(SMA((VAR3-LLV(VAR4,34))/(HHV(VAR3,34)-LLV(VAR4,34))*100,5,1),3,1);
MA3:=MA(能量,3);
低拐点:=IF(REF(MA3,1)=LLV(MA3,4) AND MA3>REF(MA3,1) AND REF(能量,1)<18,REF(MA3,1),0);
HL:=EMA(WINNER(CLOSE)*75,3);
强底:低拐点=REF(MA3,1) AND LLV(HL,10)<=25 AND BARSLAST(LLV(HL,10))<=5;

量能趋势之追选股指标公式:

N:=4;
VAR1:=IF(C>=REF(C,1),V,0);
VAR2:=IF(C<REF(C,1),V,0);
VAR3:=SUM(VAR1,N);
VAR4:=SUM(VAR2,N);
能量:=3*SMA((VAR3-LLV(VAR4,34))/(HHV(VAR3,34)-LLV(VAR4,34))*100,5,1)-2*SMA(SMA((VAR3-LLV(VAR4,34))/(HHV(VAR3,34)-LLV(VAR4,34))*100,5,1),3,1);
MA3:=MA(能量,3);
追:CROSS(能量,MA3) AND RANGE(MA3,20,50);
赞(0) 打赏
指标公式仅供学习研究,请勿以此为依据进行股票交易,依此入市,盈亏自负。135股票指标 » 通达信量能趋势指标公式

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏