查看: 0|回复: 0

天机决策主图指标公式(通达信)

[复制链接]

89

主题

89

帖子

273

积分

中级会员

Rank: 3Rank: 3

积分
273
发表于 2019-5-12 14:33:16 | 显示全部楼层 |阅读模式
指标
适用软件: 通达信
画图位置: 主图
未来函数: 无未来
更多交流: QQ群:50203834 公众号:金股典/jingudian 
  1. MA5:MA(C,5);
  2. MA6:=MA(C,6);
  3. MA10:MA(C,10);
  4. MA20:MA(C,20);
  5. A2:=REF(MA20,1);J1:=(MA20-A2)/A2*100;MJ1:=MA(J1,3);
  6. MA30:MA(C,30);
  7. MA55:MA(C,60);
  8. MA120:MA(C,120);
  9. 乖离2:=(MA20-MA30)/MA30*100;
  10. VAR1:=IF(BETWEEN(乖离2,-2,5),2,0);
  11. MAX1:=MAX(MA20,MA30);
  12. MAX2:=MAX(MAX1,MA55);
  13. MINN:=MIN(MA20,MA30);
  14. MIN2:=MIN(MINN,MA55);
  15. K1:=(MAX2/MIN2-1)*100;
  16. VAR2:=IF(K1<=8,1,0);
  17. 上火车轨:=MA20>MA30 AND MA20>REF(MA20,1) AND MA30>REF(MA30,1) AND MA20-MA30>REF((MA20-MA30),1) ;
  18. STICKLINE(上火车轨,MA20,MA30,0,0),COLORRED;
  19. 神枪手:=DRAWTEXT(FILTER(上火车轨 AND "MACD.DIF"<0.15 AND
  20. "MACD.DIF">REF("MACD.DIF",1) AND MA(V,60)>REF(MA(V,60),1) AND
  21. MA(V,5)>MA(V,10) AND J1>REF(J1,1) AND
  22. ( L<=MA20 AND C>MA20 OR (CROSS(MA5,MA20)) ),5),L*0.98,'←神枪手');
  23. 神枪手选股:=FILTER(上火车轨 AND "MACD.DIF"<0.15 AND
  24. "MACD.DIF">REF("MACD.DIF",1) AND MA(V,60)>REF(MA(V,60),1) AND
  25. MA(V,5)>MA(V,10) AND J1>REF(J1,1) AND
  26. ( L<=MA20 AND C>MA20 OR (CROSS(MA5,MA20)) ),5);{44.40%15240}
  27. 短线暴涨:DRAWTEXT(FILTER( (VAR1 OR VAR2) AND MA10>REF(MA10,1) AND
  28. COUNT(MA30>REF(MA30,1),3)=3 AND MA30>MA55 AND
  29. COUNT(CROSS(MA5,MA30),3) AND J1>MJ1 AND MA(V,5)>MA(V,60)
  30. AND MA(V,60)>REF(MA(V,60),1),5),MA55*0.99,'短线暴涨'),COLORRED;
  31. DRAWTEXT(CROSS("KDJ.K"(5,2,3),"KDJ.D"(5,2,3)) AND "KDJ.D"(5,2,3)<30
  32. AND J1>MJ1 AND MA55>REF(MA55,1) AND COUNT(J1<1,3)>=1
  33. ,L*0.995,'←买入'),COLORYELLOW;
  34. DRAWTEXT(CROSS("KDJ.D"(5,2,3),"KDJ.K"(5,2,3)) AND "KDJ.D"(5,2,3)>65
  35. AND J1<MJ1 AND COUNT(J1>1,3)>=1,H*1.005,'←卖出'),COLORGREEN;
  36. DRAWTEXT(CROSS("KDJ.D"(18,9,6),"KDJ.K"(18,9,6)) AND "KDJ.D"(18,9,6)>60 AND "KDJ.J"(45,15,15)>90,H*1.03,'←顶'),COLORRED;
  37. DRAWTEXT(CROSS(MA5,MA6) AND "KDJ.K"(5,3,3)>=50 AND "KDJ.J"(5,3,3)<31 ,L*0.92,'←再买'),COLORMAGENTA;
  38. XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));
  39. XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);
  40. XL3:=CROSS(XL2,(0 - 20));
  41. DRAWTEXT(FILTER(((XL1 > 0) AND LOW),5),(LOW - 0.4),'买点');
  42. DRAWTEXT((XL3 > 0),(LOW - 0.2),'绝对底部');
  43. X6:=REF(CLOSE,1);
  44. X7:=((SMA(MAX((CLOSE - X6),0),7,1) / SMA(ABS((CLOSE - X6)),7,1)) * 100);
  45. X8:=CROSS(79,X7);
  46. X9:=FILTER(X8,4);
  47. DRAWTEXT(X9,(HIGH * 1.02),'出货'),COLOR9000F5;
  48. STICKLINE(C>1.098*REF(C,1),C,O,0,0),COLORYELLOW;
  49. VVAR1:=AMOUNT/VOL/7;
  50. VVAR2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
复制代码

11.jpg
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版| 感谢您的支持,本条链接自定义

Powered by Discuz! X3.1 © 2001-2015 Comsenz Inc. GMT+8, 2019-5-20 20:36 , Processed in 0.045000 second(s), 10 queries , Eaccelerator On.

135股票论坛 ( 京ICP备14020393号-1 ) QQ
快速回复 返回顶部 返回列表