查看: 0|回复: 0

私募进场修改指标公式(通达信)

[复制链接]

89

主题

89

帖子

273

积分

中级会员

Rank: 3Rank: 3

积分
273
发表于 2019-5-12 19:17:20 | 显示全部楼层 |阅读模式
指标
适用软件: 通达信
画图位置: 主图
未来函数: 无未来
更多交流: QQ群:50203834 公众号:金股典/jingudian 
  1. XXCC: EMA(EMA(EMA(EMA(CLOSE,3),3),3),3),LINETHICK1,COLOR0000FF;
  2. XXCC1: EMA(REF(XXCC,1),3),LINETHICK1,COLOR00FFFF;
  3. ZZCC: EMA(EMA(EMA(EMA(EMA(CLOSE,65),3),3),3),3),LINETHICK1,COLORFF0000;
  4. AA:= MA(WINNER(CLOSE*0.95)*100,3);
  5. VAR83:= 1/WINNER(CLOSE);
  6. VAR84:= (CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
  7. VAR85:= 100-ABS(VAR84);
  8. VAR86:= 3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
  9. VAR87:= 3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
  10. VAR88:= 100-VAR87;
  11. VAR89:= 100-VAR86;
  12. VAR90:= MA(WINNER(CLOSE*0.95)*100,3);
  13. VAR91:= IF(VAR83>5,IF(VAR83<100,VAR83,VAR85-10),0);
  14. VAR92:= MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
  15. VAR93:= 100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
  16. VAR94:= 100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
  17. VAR95:= VAR93<REF(VAR94,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
  18. AAE:= WINNER(CLOSE+CLOSE*15/100)*100;
  19. BBE:= WINNER(CLOSE+CLOSE*0/100)*100;
  20. CCE:= AAE-BBE;
  21. DDE:= (WINNER(CLOSE-CLOSE*0.1/100)-WINNER(CLOSE-CLOSE*15/100))*100;
  22. EEE:= CCE<3 AND DDE<0.5 AND OPEN<LOW;
  23. AE1:= DYNAINFO(6);
  24. AE2:= IF(LOW>AE1,0,IF(HIGH<AE1,1,(AE1-LOW+0.01)/(HIGH-LOW+0.01)));
  25. AE3:= VOL/WINNER(LOW);
  26. AE4:= REF(HHV(CLOSE,120),1);
  27. AE5:= REF(LLV(CLOSE,120),1);
  28. AE6:= 100*(CLOSE-AE5)/(AE4-AE5);
  29. AE7:= AE2>0 OR AE2=1;
  30. AE8:= AE7 AND AE3/REF(AE3,3)>=3 AND AE6<80;
  31. AE9:= REF(AE8,1) OR REF(AE8,2) OR REF(AE8,3) OR REF(AE8,4);
  32. AE10:= AE8 AND AE9;
  33. AE11:= IF(FILTER(AE8,3),5,0);
  34. AE12:= FILTER(IF(FILTER(AE10,3) OR EEE,10,0),3);
  35. VARA:= (CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
  36. VARB:= SMA(VARA,3,1);
  37. VARC:= SMA(VARB,3,1);
  38. 探索:= EMA(3*VARB-2*VARC,3);
  39. 主力:= (-1)*(EMA(VAR89,1)-50)+50;
  40. Z1:= MA(主力,9);
  41. VARD:= (-1)*(EMA(VAR89,1)-50)+50;
  42. VARE:= (-1)*(EMA(VAR89,12)-50)+50;
  43. LCC:= REF(CLOSE,1);
  44. RSI1:= SMA(MAX(CLOSE-LCC,0),6,1)/SMA(ABS(CLOSE-LCC),6,1)*100;
  45. 天涯:= IF(RSI1>93 OR AA>90 AND RSI1>80,80,100);
  46. 苦海:= EMA(100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14)),6);
  47. ZS:= MA(探索,3);
  48. ZM:= MA(MA(探索,3),3);
  49. A11:= 3*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1)-2*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1);
  50. 黑马线:= EMA(A11,5);
  51. A12:= (黑马线-REF(黑马线,1))/REF(黑马线,1)*100;
  52. A4:= (CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
  53. 趋势线3:= MA(3*SMA(A4,6,1)-2*SMA(SMA(A4,5,1),5,1),2);
  54. A5:= (HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))*100;
  55. N:= 3;
  56. VAR1:= REF((LOW+OPEN+CLOSE+HIGH)/4,1);
  57. VAR2:= SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);
  58. VAR3:= EMA(VAR2,10);
  59. VAR4:= LLV(LOW,33);
  60. VAR5:= EMA(IF(LOW<=VAR4,VAR3,0),5);
  61. VAR6:= REF(CLOSE,1);
  62. VAR7:= SMA(MAX(CLOSE-VAR6,0),6,1)/SMA(ABS(CLOSE-VAR6),6,1)*100;
  63. VAR8:= LLV(LOW,5)=LLV(LOW,45) AND CLOSE>=OPEN*1.04;
  64. VAR9:= CLOSE>(REF(HIGH,1)+REF(LOW,1))/2;
  65. VAR10:= VAR8 AND VAR9;
  66. VAR11:= (2*CLOSE+HIGH+LOW)/4;
  67. VAR12:= LLV(LOW,13);
  68. VAR13:= HHV(HIGH,13);
  69. VAR14:= LLV(LOW,1)=LLV(LOW,35) AND CLOSE>=OPEN*1.04;
  70. VAR15:= CLOSE>(REF(HIGH,1)+REF(LOW,1))/2;
  71. VAR16:= EMA((VAR11-VAR12)/(VAR13-VAR12)*100,13);
  72. VAR17:= ((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
  73. VAR18:= 1/WINNER(CLOSE);
  74. VAR19:= MA(CLOSE,13);
  75. VAR20:= 100-ABS((CLOSE-VAR19)/VAR19*100);
  76. VAR21:= LLV(LOW,75);
  77. VAR22:= HHV(HIGH,75);
  78. VAR23:= (VAR22-VAR21)/100;
  79. VAR24:= SMA((CLOSE-VAR21)/VAR23,20,1);
  80. VAR25:= SMA((OPEN-VAR21)/VAR23,20,1);
  81. VAR26:= 3*VAR24-2*SMA(VAR24,15,1);
  82. VAR27:= MA(HHV(HIGH,485),17);
  83. VAR28:= MA(HHV(HIGH,222),17);
  84. VAR29:= MA(HHV(HIGH,96),17);
  85. VAR30:= MA(LLV(LOW,485),17);
  86. VAR31:= MA(LLV(LOW,222),17);
  87. VAR32:= MA(LLV(LOW,96),17);
  88. VAR33:= MA((VAR30*0.96+VAR31*0.96+VAR32*0.96+VAR27*0.558+VAR28*0.558+VAR29*0.558)/6,17);
  89. VAR34:= MA((VAR30*1.25+VAR31*1.23+VAR32*1.2+VAR27*0.55+VAR28*0.55+VAR29*0.65)/6,17);
  90. VAR35:= MA((VAR30*1.3+VAR31*1.3+VAR32*1.3+VAR27*0.68+VAR28*0.68+VAR29*0.68)/6,17);
  91. VAR36:= LLV(LOW,30);
  92. VAR37:= MA((VAR33*3+VAR34*2+VAR35)/6*1.738,17);
  93. VAR38:= IF(DATE<=1050531,VAR37,VAR37*DAY);
  94. VAR39:= LOW;
  95. VAR40:= REF(LOW,1);
  96. VAR41:= SMA(ABS(VAR39-VAR40),3,1)/SMA(MAX(VAR39-VAR40,0),N,1)*100;
  97. VAR42:= MA(IF(CLOSE*1.35<=VAR38,VAR41*10,VAR41/10),N);
  98. VAR43:= HHV(VAR42,30);
  99. VAR44:= 1080531;
  100. VAR45:= 3*VAR25-2*SMA(VAR25,15,1);
  101. VAR46:= 100-VAR45;
  102. VAR47:= IF(900101<DATE AND DATE<99991232,1,0);
  103. VAR49:= REF(LOW,1)*0.9;
  104. VAR50:= LOW*0.9;
  105. VAR51:= (VAR50*VOL+VAR49*(CAPITAL-VOL))/CAPITAL;
  106. VAR52:= EMA(VAR51,30);
  107. VAR53:= CLOSE-REF(CLOSE,1);
  108. VAR54:= MAX(VAR53,0);
  109. VAR55:= ABS(VAR53);
  110. VAR56:= SMA(VAR54,7,1)/SMA(VAR55,7,1)*100;
  111. VAR57:= SMA(VAR54,13,1)/SMA(VAR55,13,1)*100;
  112. VAR58:= BARSCOUNT(CLOSE);
  113. VAR59:= SMA(MAX(VAR53,0),6,1)/SMA(ABS(VAR53),6,1)*100;
  114. VAR60:= (-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
  115. VAR61:= (CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
  116. VAR62:= SMA((SMA(VAR61,4,1)-50)*2,3,1);
  117. VAR63:= (INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
  118. VAR64:= SMA(VAR63,4,1);
  119. VAR65:= SMA(VAR64,3,1);
  120. VAR66:= (HHV(HIGH,30)-CLOSE)/CLOSE*100;
  121. VAR67:= VAR59<=25 AND VAR60<(-95) AND VAR66>20 AND VAR62<(-30) AND VAR65<30 AND VAR52-CLOSE>=(-0.25) AND VAR56<22 AND VAR57<28 AND VAR58>50;
  122. VAR68:= (HIGH+LOW+CLOSE)/3;
  123. VAR69:= (VAR68-MA(VAR68,14))/(0.015*AVEDEV(VAR68,14));
  124. VAR70:= (VAR68-MA(VAR68,70))/(0.015*AVEDEV(VAR68,70));
  125. VAR71:= IF(VAR69>=150 AND VAR69<200 AND VAR70>=150 AND VAR70<200,10,0);
  126. VAR72:= IF(VAR69<=(-150) AND VAR69>(-200) AND VAR70<=(-150) AND VAR70>(-200),-10,VAR71);
  127. VAR73:= (CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
  128. VAR74:= REVERSE(VAR73);
  129. VAR75:= SMA(VAR73,3,1);
  130. 绝佳买点:= IF(DATE<=VAR44,MA(IF(LOW<=VAR36,(VAR42+VAR43*2)/2,0),N),100000000);
  131. 跑:= FILTER(REF(黑马线,1)>90 AND A12<0 ,7);
  132. 买线:= EMA(CLOSE,2);
  133. 卖线:= EMA(SLOPE(CLOSE,21)*20+CLOSE,42);
  134. 指數位置:= 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
  135. 抄底:= CROSS(指數位置,10);
  136. A1:= VOL=HHV(VOL,120);
  137. A2:= CLOSE/OPEN>1.05;
  138. TJ:= A1 AND A2;
  139. 龙:= VAR10;
  140. 买4:= VAR14;
  141. AA1:= AMOUNT/VOL;
  142. BB1:= LOW<AA1*0.9;
  143. CC1:= (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>1.2;
  144. DD1:= LOW<MA(CLOSE,5)*0.921;
  145. EE1:= VOL<MA(VOL,5)*1.5;
  146. FF1:= BB1 AND CC1 AND DD1 AND EE1;
  147. 买3:= FILTER(FF1,3) AND DATE<=1080530;
  148. 二十天最低跌幅:= HHV(CLOSE,20)/LLV(CLOSE,20);
  149. RSV:= (CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
  150. K:= SMA(RSV,3,1);
  151. D:= SMA(K,3,1);
  152. J:= 3*K-2*D;
  153. X:= LLV(J,2)=LLV(J,8);
  154. 买1:= CROSS(J,REF(J+0.01,1)) AND X AND J<20 AND 二十天最低跌幅>=1.3 ;
  155. 长期底部:= LLV(HIGH,30);
  156. 上:= SMA(LOW,5,2)*0.96;
  157. 短期底部:= LLV(HIGH,30)*0.93;
  158. LC:= REF(CLOSE,1);
  159. RSI:= SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
  160. 大顶:= FILTER(VAR17>20 AND FILTER(VAR17<REF(VAR17,1),5),5);
  161. VAR76:= (OPEN+LOW+HIGH+CLOSE)/4;
  162. MAN:= SMA(HIGH,21,2)*1.05;
  163. 短底2:= EMA(VAR76,5);
  164. 支撑:= HHV(短底2,60);
  165. VAR77:= (HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
  166. VAR78:= SMA(VAR77,5,1);
  167. VAR79:= SMA(VAR78,8,1);
  168. VAR80:= CROSS(VAR78,VAR79) AND VAR79<5;
  169. VAR81:= CLOSE>LLV(CLOSE,60)+0.3*LLV(CLOSE,60) AND VAR80;
  170. VAR82:= IF(CLOSE>1000,VAR80,VAR81);
  171. 黑马起步:= VAR82;
  172. 逃:= FILTER(HIGH>支撑 AND CLOSE<支撑 AND CLOSE/OPEN>0-1.06 AND CLOSE<OPEN,5);
  173. 逃命:= 黑马起步>0;
  174. 选逃:= FILTER(逃命 OR 逃 OR CROSS(84,RSI) OR 大顶,3);
  175. 上线:= SMA(CLOSE,6.5,1);
  176. 下线:= SMA(CLOSE,13.5,1);
  177. WW:= 1;
  178. 散户:= SMA(VAR75,3,1)*VAR47*WW;
  179. 新庄:= SMA(散户,3,1)*VAR47*WW;
  180. 高抛:= CROSS(新庄,散户) AND 新庄>75;
  181. 买:= CROSS(买线,卖线);
  182. 卖:= CROSS(卖线,买线);
  183. 大黑马:= CROSS(趋势线3,0) AND 黑马线<40;
  184. 大买:= FILTER(绝佳买点>30000,5);
  185. 选底:= FILTER(LOW<=上 AND HIGH>=短期底部 AND CLOSE>=长期底部 AND CLOSE/OPEN>1.03,3);
  186. 稳赚10买:= FILTER(买3 OR 选底,3) AND COUNT(买1+买4+龙,3)>0;
  187. 大资金进场:= VAR95 AND COUNT(VAR95,30)=1;
  188. STICKLINE(买线>=卖线,LOW,HIGH,1,0),COLOR0000FF;
  189. STICKLINE(买线>=卖线,CLOSE,OPEN,4.5,0),COLOR0000AA;
  190. STICKLINE(买线>=卖线 ,CLOSE,OPEN,4,0),COLOR0000CC;
  191. STICKLINE(买线>=卖线 ,CLOSE,OPEN,3,0),COLOR0000CC;
  192. STICKLINE(买线>=卖线 ,CLOSE,OPEN,2,0),COLOR0000EE;
  193. STICKLINE(买线<卖线 ,CLOSE,OPEN,4.5,0),COLORAAAA00;
  194. STICKLINE(买线<卖线 ,CLOSE,OPEN,4,0),COLORBBBB00;
  195. STICKLINE(买线<卖线 ,CLOSE,OPEN,3,0),COLORCCCC00;
  196. STICKLINE(买线<卖线 ,CLOSE,OPEN,2,0),COLOREEEE00;
  197. STICKLINE(买线<卖线 ,LOW,HIGH,1,0),COLORFFFF00;
  198. 选买:= FILTER(买3 OR 选底,3) AND COUNT(买1+买4+龙,3)>0 ;
  199. STICKLINE(选买 ,CLOSE,HHV(HIGH,90)*0.94,0.3,0),COLORFF0000;
  200. DRAWTEXT(选买 ,HHV(HIGH,90)*1,'稳赚'),COLORFF0000;
  201. DRAWTEXT(选买 ,HHV(HIGH,90)*0.97,'10%买'),COLORFF0000;
  202. DRAWTEXT(选逃,HIGH*1.04,'逃'),COLOR00FFFF;
  203. DRAWTEXT(买,LOW*0.996,'买'),COLOR0000FF;
  204. DRAWTEXT(卖,HIGH*1,'卖'),COLOR00FFFF;
  205. DRAWTEXT(AE12,HIGH*1.095,'私募'),COLOR008000;
  206. DRAWTEXT(AE12,HIGH*1.06,'加仓'),COLOR008000;
  207. DRAWTEXT(VAR95 AND COUNT(VAR95,30)=1,HIGH*1.095,'大资金'),COLOR008000;
  208. DRAWTEXT(VAR95 AND COUNT(VAR95,30)=1,HIGH*1.06,'进场'),COLOR008000;
  209. DRAWTEXT(跑,HIGH*1.02,'跑'),COLOR00FFFF;
  210. DRAWTEXT(大黑马,LOW*0.98,'大黑马'),COLORFFFFFF;
  211. DRAWTEXT(CROSS(新庄,散户) AND 新庄>75,HIGH*1.04,'抛'),COLOR00FFFF;
  212. DRAWTEXT(大买,LOW*0.96,'大买'),COLOR0000FF;
  213. DRAWTEXT(IF(选底,100,0),LOW*0.995,'底'),COLOR399C71;
  214. DRAWTEXT(AE12 OR VAR95 AND COUNT(VAR95,30)=1,HIGH*1.01,'↓'),COLOR008000;
  215. VAR330:=0;
  216. 位置:= (CLOSE+REF(CLOSE,105))/2;
复制代码

11.jpg
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版| 感谢您的支持,本条链接自定义

Powered by Discuz! X3.1 © 2001-2015 Comsenz Inc. GMT+8, 2019-5-20 21:09 , Processed in 0.041328 second(s), 11 queries , Eaccelerator On.

135股票论坛 ( 京ICP备14020393号-1 ) QQ
快速回复 返回顶部 返回列表