查看: 0|回复: 0

量能趋势指标公式(通达信)

[复制链接]

110

主题

110

帖子

338

积分

中级会员

Rank: 3Rank: 3

积分
338
发表于 2019-5-12 19:31:52 | 显示全部楼层 |阅读模式
指标
适用软件: 通达信
画图位置: 副图
未来函数: 无未来
更多交流: QQ群:50203834 公众号:金股典/jingudian 
  1. N:=4;
  2. VAR1:=IF(C>=REF(C,1),V,0);
  3. VAR2:=IF(C<REF(C,1),V,0);
  4. VAR3:=SUM(VAR1,N);
  5. VAR4:=SUM(VAR2,N);
  6. 能量:3*SMA((VAR3-LLV(VAR4,34))/(HHV(VAR3,34)-LLV(VAR4,34))*100,5,1)
  7. -2*SMA(SMA((VAR3-LLV(VAR4,34))/(HHV(VAR3,34)-LLV(VAR4,34))*100,5,1),3,1),
  8. COLORMAGENTA;
  9. MA3:MA(能量,3),COLORWHITE;
  10. MA6:MA(能量,6),COLORGREEN;
  11. 高拐点:=IF(REF(MA3,1)=HHV(MA3,4) AND MA3<REF(MA3,1) AND REF(MA3,1)>70
  12. ,REF(MA3,1),0),COLORCYAN;
  13. 低拐点:=IF(REF(MA3,1)=LLV(MA3,4) AND MA3>REF(MA3,1) AND REF(能量,1)<18
  14. ,REF(MA3,1),0),COLORYELLOW;
  15. STICKLINE(低拐点=REF(MA3,1),-10,10,4,0),COLORYELLOW;
  16. 顶背离:IF(高拐点<HHV(高拐点,20) AND 高拐点=REF(MA3,1) AND
  17. C>REF(C,BARSLAST(HHV(高拐点,20))),1,DRAWNULL);
  18. DRAWTEXT(顶背离=1,MA3*1.10,'顶背'),COLORGREEN;
  19. 底背离:IF(低拐点>LLV(低拐点,20) AND 低拐点>0 AND
  20. C<REF(C,BARSLAST(LLV(低拐点,20))),1,-10),COLORYELLOW;
  21. DRAWTEXT(底背离=1,32,'底背'),COLORYELLOW;
  22. HL:=EMA(WINNER(CLOSE)*75,3);
  23. DRAWTEXT(低拐点=REF(MA3,1) AND LLV(HL,10)<=25 AND BARSLAST(LLV(HL,10))<=5,
  24. 20,'强底'),COLORMAGENTA;
  25. 死叉:IF(高拐点>0,110,130),COLORGREEN;
  26. 追:=IF(CROSS(能量,MA3) AND RANGE(MA3,20,50),1,0);
  27. DRAWICON(追=1,0.8*MA3,7);
  28. 减:=IF(CROSS(MA3,能量) AND RANGE(MA3,50,70),1,0);
  29. DRAWICON(减=1,1.1*MA3,8);
复制代码

11.jpg
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版| 感谢您的支持,本条链接自定义

Powered by Discuz! X3.1 © 2001-2015 Comsenz Inc. GMT+8, 2019-7-20 22:09 , Processed in 0.030826 second(s), 10 queries , Eaccelerator On.

135股票论坛 ( 京ICP备14020393号-1 ) QQ
快速回复 返回顶部 返回列表