查看: 0|回复: 0

战无不胜主图指标公式(通达信)

[复制链接]

89

主题

89

帖子

273

积分

中级会员

Rank: 3Rank: 3

积分
273
发表于 2019-5-12 19:36:49 | 显示全部楼层 |阅读模式
指标
适用软件: 通达信
画图位置: 主图
未来函数: 无未来
更多交流: QQ群:50203834 公众号:金股典/jingudian 
  1. JL01:=MA(C,3);
  2. LJL07:=(3*C+L+O+H)/6;
  3. 牛线: (20*LJL07+19*REF(LJL07,1)+18*REF(LJL07,2)+17*REF(LJL07,3)+16*REF(LJL07,4)+15*REF(LJL07,5)+14*REF(LJL07,6)+13*REF(LJL07,7)+12*REF(LJL07,8)+11*REF(LJL07,9)+10*REF(LJL07,10)+9*REF(LJL07,11)+8*REF(LJL07,12)+7*REF(LJL07,13)+6*REF(LJL07,14)+5*REF(LJL07,15)+4*REF(LJL07,16)+3*REF(LJL07,17)+2*REF(LJL07,18)+REF(LJL07,20))/210,COLORRED;
  4. 马线:MA(牛线,6),COLORYELLOW,LINETHICK4,POINTDOT;
  5. 上限:马线+3*STD(CLOSE,20),COLORMAGENTA,CROSSDOT;
  6. 下限:马线-2.9*STD(CLOSE,20),COLOR2693FF,CROSSDOT;
  7. 买:马线-2*STD(CLOSE,20),LINETHICK2,COLORFF937F;
  8. 卖:马线+2*STD(CLOSE,20),LINETHICK2,COLOR00FF00;
  9. 等待:IF(JL01<=牛线,马线,DRAWNULL),COLORRED,LINETHICK4,POINTDOT;
  10. VAR1:=(C>REF(C,1) AND C>REF(C,2));
  11. VAR2:=(REF(VAR1,1) AND C<=REF(C,1) AND C>=REF(C,2));
  12. VAR3:=(REF(VAR2,1) AND C>=REF(C,1) AND C<=REF(C,2));
  13. VAR4:=(REF(VAR3,1) AND C<=REF(C,1) AND C>=REF(C,2));
  14. VAR5:=(REF(VAR4,1) AND C>=REF(C,1) AND C<=REF(C,2));
  15. VAR6:=(REF(VAR5,1) AND C<=REF(C,1) AND C>=REF(C,2));
  16. VAR7:=(REF(VAR6,1) AND C>=REF(C,1) AND C<=REF(C,2));
  17. VAR8:=(REF(VAR7,1) AND C<=REF(C,1) AND C>=REF(C,2));
  18. VAR9:=(REF(VAR8,1) AND C>=REF(C,1) AND C<=REF(C,2));
  19. VARA:=(REF(VAR9,1) AND C<=REF(C,1) AND C>=REF(C,2));
  20. VARB:=(REF(VARA,1) AND C>=REF(C,1) AND C<=REF(C,2));
  21. VARC:=(REF(VARB,1) AND C<=REF(C,1) AND C>=REF(C,2));
  22. 持股:IF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,牛线,DRAWNULL),COLORRED,LINETHICK1;
  23. VARD:=(C<REF(C,1) AND C<REF(C,2));
  24. VARE:=(REF(VARD,1) AND C>=REF(C,1) AND C<=REF(C,2));
  25. VARF:=(REF(VARE,1) AND C<=REF(C,1) AND C>=REF(C,2));
  26. VAR10:=(REF(VARF,1) AND C>=REF(C,1) AND C<=REF(C,2));
  27. VAR11:=(REF(VAR10,1) AND C<=REF(C,1) AND C>=REF(C,2));
  28. VAR12:=(REF(VAR11,1) AND C>=REF(C,1) AND C<=REF(C,2));
  29. VAR13:=(REF(VAR12,1) AND C<=REF(C,1) AND C>=REF(C,2));
  30. VAR14:=(REF(VAR13,1) AND C>=REF(C,1) AND C<=REF(C,2));
  31. VAR15:=(REF(VAR14,1) AND C<=REF(C,1) AND C>=REF(C,2));
  32. VAR16:=(REF(VAR15,1) AND C>=REF(C,1) AND C<=REF(C,2));
  33. VAR17:=(REF(VAR16,1) AND C<=REF(C,1) AND C>=REF(C,2));
  34. VAR18:=(REF(VAR17,1) AND C>=REF(C,1) AND C<=REF(C,2));
  35. 持币:IF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,牛线,DRAWNULL),COLORLIGRAY,LINETHICK1;
  36. STICKLINE(C>=O,C,O,3,0),COLOR000045;
  37. STICKLINE(C>=O,C,O,2.5,0),COLOR000065;
  38. STICKLINE(C>=O,C,O,2,0),COLOR000085;
  39. STICKLINE(C>=O,C,O,1.5,0),COLOR0000A5;
  40. STICKLINE(C>=O,C,O,1,0),COLOR0000C5;
  41. STICKLINE(C>=O,C,O,0.5,0),COLOR0000E5;
  42. STICKLINE(C>=O,H,L,0,0),COLOR0000F5;
  43. STICKLINE(C<O,C,O,3,0),COLOR353500;
  44. STICKLINE(C<O,C,O,2.5,0),COLOR454500;
  45. STICKLINE(C<O,C,O,2,0),COLOR555500;
  46. STICKLINE(C<O,C,O,1.5,0),COLOR656500;
  47. STICKLINE(C<O,C,O,1,0),COLOR757500;
  48. STICKLINE(C<O,C,O,0.5,0),COLOR858500;
  49. STICKLINE(C<O,H,L,0,0),COLOR959500;
  50. LW05:=MA(C,5);
  51. LW10:=MA(C,10);
  52. LW30:=MA(C,30);
  53. 五日乖离率:=(C-LW05)/LW05*100;
  54. 三拾日乖离率:=(C-LW30)/LW30*100;
  55. JL05:=ATAN((LW05/REF(LW05,1)-1)*100)*180/3.1416;
  56. JL10:=ATAN((LW10/REF(LW10,1)-1)*100)*180/3.1416;
  57. JL30:=ATAN((LW30/REF(LW30,1)-1)*100)*180/3.1416;
  58. 速度5:=SMA(EMA((LW05-REF(LW05,1))/REF(LW05,1),3)*100,3,1);
  59. 加速度5:=EMA((速度5-REF(速度5,1)),3);
  60. 强势狙击:=FILTER(JL30>30 AND JL10>45 AND CROSS(JL05,60),10);
  61. 加仓:=FILTER(COUNT(CROSS(JL05,30),5)>=1 AND LW05>REF(LW05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND LW10>REF(LW10,1)AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
  62. 清仓:=FILTER(COUNT(CROSS(30,JL05),5)>=1 AND (C>LW30 OR O>LW30) AND LW05<REF(LW05,1) AND 三拾日乖离率<REF(三拾日乖离率,1) AND LW10<REF(LW10,1),10);
  63. MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND LW05>REF(LW05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<LW30;
  64. JL:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND LW10>REF(LW10,1) ;
  65. 减仓:=FILTER(JL,10);
  66. 买入:=FILTER(MR,10);
  67. DRAWTEXT(减仓,HIGH*1.02,'←减仓'),COLORFF99FF;
  68. DRAWTEXT(加仓 ,LOW*0.98,'←加仓'),COLORRED;
  69. DRAWTEXT(买入,LOW*0.98,'←买入'),COLORYELLOW;
  70. DRAWTEXT(清仓,HIGH*1.02,'←清仓'),COLORGREEN;
  71. DRAWTEXT(强势狙击,LOW*0.98,'←强势狙击'),COLORYELLOW;
  72. {DRAWICON(减仓,HIGH*1.02,18);
  73. DRAWICON(加仓 ,LOW*0.98,23);
  74. DRAWICON(买入,LOW*0.98,5);
  75. DRAWICON(清仓 ,HIGH*1.02,6);
  76. DRAWICON(强势狙击,LOW*0.98,15);};
复制代码

11.jpg
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版| 感谢您的支持,本条链接自定义

Powered by Discuz! X3.1 © 2001-2015 Comsenz Inc. GMT+8, 2019-5-20 21:33 , Processed in 0.030909 second(s), 10 queries , Eaccelerator On.

135股票论坛 ( 京ICP备14020393号-1 ) QQ
快速回复 返回顶部 返回列表