查看: 0|回复: 0

零延迟威廉线指标公式(通达信)

[复制链接]

89

主题

89

帖子

273

积分

中级会员

Rank: 3Rank: 3

积分
273
发表于 6 天前 | 显示全部楼层 |阅读模式
指标
适用软件: 通达信
画图位置: 副图
未来函数: 无未来
更多交流: QQ群:50203834 公众号:金股典/jingudian 
  1. R:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));{零延迟威廉线}
  2. PERIODD:=10;
  3. EMA1:=EMA(R,PERIODD);
  4. EMA2:=EMA(EMA1,5);
  5. DIFFERENCE:=EMA1-EMA2;
  6. ZEROLAGEMA:=EMA1+DIFFERENCE;
  7. PR:100-ABS(ZEROLAGEMA), COLORRED ,LINETHICK1;
  8. MOVEAVG:MA(PR,5), COLORWHITE ,LINETHICK1;
  9. K:=15;
  10. FFILTER:=(K/100)*STD(PR-REF(PR,1),10);
  11. XA:=IF(PR<REF(PR,1),PR,0);
  12. XN:=BARSLAST(XA>0 );
  13. AMALOW:=REF(PR,XN);
  14. YA:=IF(PR>REF(PR,1),PR,0);
  15. YN:=BARSLAST(YA>0) ;
  16. AMAHIGH :=REF(PR,YN);
  17. RR:=IF( AMAHIGH-PR>FFILTER,-1,0) ;
  18. TT:=IF( PR- AMALOW>FFILTER,1,RR) ;
  19. 80, LINETHICK1;
  20. 20, LINETHICK1;
复制代码

11.jpg
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版| 感谢您的支持,本条链接自定义

Powered by Discuz! X3.1 © 2001-2015 Comsenz Inc. GMT+8, 2019-5-20 20:36 , Processed in 0.029879 second(s), 10 queries , Eaccelerator On.

135股票论坛 ( 京ICP备14020393号-1 ) QQ
快速回复 返回顶部 返回列表