查看: 0|回复: 0

主力骗线点指标公式(通达信)

[复制链接]

348

主题

348

帖子

1060

积分

金牌会员

Rank: 6Rank: 6

积分
1060
发表于 2019-5-17 14:28:11 | 显示全部楼层 |阅读模式
指标
适用软件: 通达信
画图位置: 副图
未来函数: 无未来
更多交流: QQ群:50203834 公众号:金股典/jingudian 
  1. VAR1:= EMA(EMA(CLOSE,13),13);
  2. 控盘指数: (VAR1-REF(VAR1,1))/REF(VAR1,1)*1000,POINTDOT,COLORFFCCCC;
  3. STICKLINE(控盘指数<0,控盘指数,0,2,0),COLORGRAY;
  4. 无庄控盘: 控盘指数<0,LINETHICK0,COLORGRAY;
  5. STICKLINE(控盘指数>REF(控盘指数,1) AND 控盘指数>0 AND 控盘指数<3,控盘指数,0,2,1),COLORRED;
  6. STICKLINE(控盘指数>REF(控盘指数,1) AND 控盘指数>0 AND 控盘指数>3,控盘指数,0,2,1),COLORRED;
  7. STICKLINE(控盘指数>REF(控盘指数,1) AND 控盘指数>3,控盘指数,3,4,1),COLORFF00FF;
  8. 主力控盘: 控盘指数>REF(控盘指数,1) AND 控盘指数>0,LINETHICK0,COLORRED;
  9. STICKLINE(控盘指数<REF(控盘指数,1) AND 控盘指数>0,控盘指数,0,2,0),COLOR00FF00;
  10. 控盘减弱: 控盘指数<REF(控盘指数,1) AND 控盘指数>0,LINETHICK0,COLOR00FF00;
  11. VARA:= EMA(0.667*REF(控盘指数,1)+0.333*控盘指数,2);
  12. STICKLINE(控盘指数>VARA,控盘指数,VARA,2,0),COLORRED;
  13. B2:= 控盘指数>VARA;
  14. 准备: B2>REF(B2,1) AND 控盘指数<(-2),COLORYELLOW;
  15. DRAWTEXT(准备,3,'准备'),COLORYELLOW;
  16. B1:= (控盘指数>REF(控盘指数,1) AND 控盘指数>0)=1;
  17. 开始控盘: B1>REF(B1,1),COLORMAGENTA,LINETHICK3;
  18. A:=(3*C+L+O+H)/6;
  19. X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
  20. 14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
  21. +7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
  22. REF(A,20))/210;
  23. MTM:=C-REF(C,1);
  24. DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
  25. CB:=EMA(X,13);
  26. 买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
  27. DRAWICON(FILTER(买=1,5),L*0.11,1);
  28. DIFF:(EMA(CLOSE,12) - EMA(CLOSE,26))*20,COLORWHITE,LINETHICK1;
  29. DEA:EMA(DIFF,9),COLORYELLOW,LINETHICK1;
  30. MACD:2*(DIFF-DEA), COLORSTICK;
  31. MACD1:=2*(DIFF-DEA),COLORRED,NODRAW;
  32. MACD2:=EMA(MACD1,3),COLORCYAN,NODRAW;
  33. STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,2,0),COLORRED;
  34. STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,2,0),COLORYELLOW;
  35. STICKLINE(MACD1<MACD2,0,MACD1,1,0),COLORGREEN;
  36. S1:=MACD<0;
  37. S2:= (MACD>=0);
  38. S3:=BARSLAST(CROSS(DIFF,DEA));
  39. S4:=REF(S3,S3+1);
  40. S5:=DEA>REF(DEA,S4);
  41. S6:=DEA;
  42. 上成立:=CROSS(DIFF,DEA) AND S5;
  43. 下成立:=CROSS(DIFF,DEA) AND S6;
  44. L1:=(EMA(CLOSE,3) - EMA(CLOSE,13));
  45. L2:=EMA(L1,9);
  46. L3:=BARSLAST(CROSS(L1,L2));
  47. L4:=REF(L3,L3+1);
  48. L5:=L2;
  49. 变盘:CROSS(L1,L2) AND L5,NODRAW,COLORD6FF9C;
  50. STICKLINE(变盘,5,0,0,1),COLORD6FF9C;
  51. LS:=IF(DIFF>DEA AND DIFF>0,1,0);
  52. 加速上扬:IF(REF(LS=0,1) AND LS=1,0.1,0);
  53. XG1:CROSS(MACD1,MACD2) AND MACD1<0,NODRAW;
  54. XG2:CROSS(DIFF,DEA),NODRAW;
  55. M1:=MACD>REF(MACD,1) AND DIFF<DEA;
  56. 绿柱短了:M1 AND COUNT(M1,10)=1 AND C>MA(C,55) AND COUNT(MACD<0,5)>=5,NODRAW;
  57. DRAWTEXT(绿柱短了,MACD,'买点来了');
  58. DIFL:=EMA(V,12)-EMA(V,26);
  59. DIF:=EMA(C,12)-EMA(C,26);
  60. BL:=DIFL>REF(DIFL,1) AND DIF<REF(DIF,1);
  61. 四天: REF(BL,3)=1 AND REF(BL,2)=1 AND REF(BL,1)=1 AND BL;
  62. 三天:REF(BL,2)=1 AND REF(BL,1)=1 AND BL;
  63. {VERTLINE(上成立,3),COLORYELLOW;
  64. VERTLINE(下成立,3),COLORRED;}
  65. IF(DIFF>DEA,DIFF,DRAWNULL),COLORFF11CC,LINETHICK1;
  66. IF(DIFF>DEA AND DIFF<0,DIFF,DRAWNULL),COLORRED,LINETHICK1;
  67. RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
  68. K:=SMA(RSV,3,1);
  69. D:=SMA(K,3,1);
  70. DRAWTEXT(FILTER(D>80,6),H*1.018,'D>80');
  71. DRAWTEXT(FILTER(CROSS(K,D) AND D<26,6),H*0.95,'KD低位金叉'),COLORFFCCCC;
  72. STICKLINE(FILTER(CROSS(K,D) AND D<26,6),H*0.97,H*0.95,4,0),COLORFFCCCC;
  73. DIFFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
  74. DEAF :=EMA(DIFFF,9);
  75. MACDD:=2*(DIFFF-DEAF);
  76. DRAWTEXT(FILTER(CROSS(DIFFF,DEAF) AND DEAF<0,6),L-0.02,'MACD低位金叉'),COLORRED;
  77. STICKLINE(FILTER(CROSS(DIFFF,DEAF) AND DEAF<0,6),L-0.02,L-0.1,4,0),COLOR00FF00;
  78. DRAWTEXT(FILTER(CROSS(DIFFF,DEAF) AND DEAF>0,13),H+0.25,'MACD下拐点'),COLORYELLOW;
  79. STICKLINE(FILTER(CROSS(DIFFF,DEAF) AND DEAF>0,13),H+0.02,H+0.12,4,0),COLORBLUE;
  80. DRAWTEXT(FILTER(CROSS(MACDD,0),13),L*0.65,'MACD上拐点'),COLORRED;
  81. STICKLINE(FILTER(CROSS(MACDD,0),13),L*0.97,L*0.95,4,0),COLORWHITE;
  82. ROC:=(CLOSE-REF(CLOSE,21))/REF(CLOSE,21)*100;
  83. DRAWTEXT(FILTER(CROSS(ROC,0),6),L-2.25,'骗线拐点'),COLORWHITE;
  84. STICKLINE(FILTER(CROSS(ROC,0),6),L-0.02,L-0.15,4,0),COLORFF00FF;
复制代码

11.jpg
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版| 感谢您的支持,本条链接自定义

Powered by Discuz! X3.1 © 2001-2015 Comsenz Inc. GMT+8, 2019-9-17 13:17 , Processed in 0.033298 second(s), 11 queries , Eaccelerator On.

135股票指标 ( 京ICP备14020393号-1 ) QQ
快速回复 返回顶部 返回列表