查看: 0|回复: 0

最佳买入选股指标公式(通达信)

[复制链接]

348

主题

348

帖子

1060

积分

金牌会员

Rank: 6Rank: 6

积分
1060
发表于 2019-5-17 14:33:44 | 显示全部楼层 |阅读模式
指标
适用软件: 通达信
画图位置: 副图
未来函数: 无未来
更多交流: QQ群:50203834 公众号:金股典/jingudian 
  1. LC:=REF(CLOSE,1);
  2. RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
  3. TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
  4. HD:=(HIGH - REF(HIGH,1));
  5. LD:=(REF(LOW,1) - LOW);
  6. DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
  7. DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
  8. PDI:=((DMP * 100) / TR1);
  9. MDI:=((DMM * 100) / TR1);
  10. ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
  11. AV:=(RSI5 + ADX);
  12. DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
  13. WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
  14. NEWVOL:=(RSI5 - WR10);
  15. 最佳买入:=(AV + NEWVOL);
  16. 最佳买入选股:IF(CROSS(最佳买入,0),1,0),STICK,COLORRED;
  17. STICKLINE(最佳买入选股,0,5,7.5,0),COLOR102099;
  18. STICKLINE(最佳买入选股,0,5,6,0),COLOR1020AA;
  19. STICKLINE(最佳买入选股,0,5,5.5,0),COLOR1020BB;
  20. STICKLINE(最佳买入选股,0,5,4,0),COLOR1020CC;
  21. STICKLINE(最佳买入选股,0,1,3.5,0),COLOR1020DD;
  22. STICKLINE(最佳买入选股,0,1,2,0),COLOR1020EE;
  23. STICKLINE(最佳买入选股,0,1,1,0),COLOR1020FF;
  24. RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 50);
  25. K:=SMA(RSV,3,1);
  26. D:=SMA(K,3,1);
  27. J:=3*K-2*D;
  28. X:=LLV(J,2)=LLV(J,8);
  29. 最佳买入时机: IF(CROSS(J,3),1,0),STICK,COLORFFFF00;
  30. STICKLINE(最佳买入时机,0,1,3,0),COLOR999900;
  31. {STICKLINE(最佳买入时机,0,5,3.5,0),COLORBBBB00;}
  32. STICKLINE(最佳买入时机,0,1,2,0),COLORDDDD00;
  33. STICKLINE(最佳买入时机,0,1,1,0),COLORFFFF00;
  34. 机构建仓: IF(最佳买入<5,-0.1,0),STICK,COLOR00FF00,LINETHICK1;
  35. 机构建仓日:STICKLINE(机构建仓,0,-0.1,3,0),COLOR00FF00,LINETHICK6;
复制代码

11.jpg
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版| 感谢您的支持,本条链接自定义

Powered by Discuz! X3.1 © 2001-2015 Comsenz Inc. GMT+8, 2019-9-17 13:02 , Processed in 0.055912 second(s), 11 queries , Eaccelerator On.

135股票指标 ( 京ICP备14020393号-1 ) QQ
快速回复 返回顶部 返回列表