查看: 0|回复: 0

等待底部买卖无敌指标公式(通达信)

[复制链接]

104

主题

104

帖子

320

积分

中级会员

Rank: 3Rank: 3

积分
320
发表于 2019-5-28 10:47:41 | 显示全部楼层 |阅读模式
指标
适用软件: 通达信
画图位置: 副图
未来函数: 无未来
更多交流: QQ群:50203834 公众号:金股典/jingudian 
  1. {无敌}
  2. I:=MA(BARSLAST(HIGH=HHV(HIGH,16))*IF(CLOSE<OPEN,VOL,1),3);
  3. R:=MA(BARSLAST(LOW=LLV(LOW,18))*IF(CLOSE>OPEN,VOL,1),4);
  4. 短线逃顶:=IF(I,0,1),COLORGREEN;
  5. DRAWICON(短线逃顶,98,8);
  6. VAR1K:=EMA(C,12)-EMA(C,20);
  7. VAR2K:=EMA(VAR1K,9);
  8. 牛魔王A:=(OPEN<=MA(CLOSE,5) AND OPEN<=MA(CLOSE,10) AND OPEN<=MA(CLOSE,30) AND CLOSE>=MA(CLOSE,5) AND CLOSE>=((SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28))*100)/100 AND (VAR2K-REF(VAR2K,1))>0 AND (VAR1K-REF(VAR1K,1))>0);
  9. DRAWICON(牛魔王A,98,6);
  10. 易股:=(VAR1K>VAR2K AND REF(VAR1K,1)<=REF(VAR2K,1) AND VAR1K<0 AND VAR2K<-0.2 AND (-100*(HHV(CLOSE,10)-CLOSE)/(HHV(CLOSE,10)-LLV(LOW,10))+100)>45 AND (VAR2K-REF(VAR2K,1))>0);
  11. DRAWICON(易股,90,4);
  12. VAR2J:=LLV(LOW,10);
  13. VAR3J:=HHV(HIGH,25);
  14. {警戒线:= 2.8*VAR1J;
  15. 减仓线:= 3.2*VAR1J;
  16. 动力线:=EMA((CLOSE-VAR2J)/(VAR3JO-VAR2J)*4,4);
  17. DRAWICON(CROSS(动力线,警戒线),99,5);}
  18. {黑马发现的底部}{}
  19. VAZ4:=(CLOSE-LLV(CLOSE,126))/(HHV(CLOSE,126)-LLV(CLOSE,126))*100;
  20. VAZ24:=VAZ4=0;
  21. STICKLINE(VAZ24>0,-3,-9,1,2), ,COLORRED,LINETHICK3 ;
  22. VAZ25:=VAZ4=100;
  23. STICKLINE(VAZ25>0,101,105,1,2), ,COLORGREEN,LINETHICK2;
  24. {睡猫买入}
  25. {N: DMA(AMOUNT/VOL/100,VOL/CAPITAL)/CLOSE;}{N日平均:EMA(成本比,N);}
  26. 睡猫: IF(C<MA(EMA(CLOSE,34)*0.82,5) AND CLOSE/DMA(AMOUNT/VOL/100,VOL/CAPITAL)<0.64{下轴成本为0.64},30,0)LINETHICK2,COLORFFFF00;
  27. {}
  28. {南极}
  29. 南极: ((((MA(CLOSE,5))-CLOSE)/CLOSE>3/100) AND (((MA(CLOSE,10))-(MA(CLOSE,5)))/(MA(CLOSE,5))>0.03) AND (LLV(CLOSE,30)=LLV(CLOSE,120)))*40,LINETHICK2,COLOR33FFCC;
  30. {一剑封喉}
  31. VAR9A:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),0-VOL,0)),0);
  32. VAR9B:=SUMBARS(VOL,CAPITAL);
  33. VAR9C:=IF(CLOSE>LLV(CLOSE,VAR9B),1,-1);
  34. VAR9D:=IF(VAR9A>LLV(VAR9A,VAR9B),1,-1);
  35. VAR9E:=VAR9C*VAR9D;
  36. VAR9F:=IF(VAR9E=-1,1,0);
  37. YJFH: (VAR9F AND CLOSE=LLV(CLOSE,120))*48,COLOR3300CC, LINETHICK1,STICK,COLORRED;
  38. {精品出山}
  39. VARP3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
  40. VARP4:=SMA(VARP3,3,1);
  41. VARP5:=SMA(VARP4,3,1);
  42. VARP6:=3*VARP4-2*VARP5;
  43. VARP7:=SMA(CLOSE/HHV(HIGH,120),3,1)*100;
  44. VARP9:=VARP7>REF(VARP7,20) AND VARP7>75 AND FILTER(VARP7/REF(LLV(LOW,20),10)>1.18,20);
  45. VARPC:=SMA(MAX(CLOSE-(REF(CLOSE,1)),0),6,1)/SMA(ABS(CLOSE-(REF(CLOSE,1))),6,1)*100;
  46. DRAWTEXT(VARP7<68 AND BARSLAST(CROSS(68,VARP7))>2 AND VARP5<30 AND CROSS(VARP6,VARP5),-5,'★'),COLORYELLOW;
  47. {牛魔王}
  48. VARI1:=(CLOSE+HIGH+LOW+OPEN)/4;
  49. VARI8:=MA(VARI1,34);
  50. VARI9:=(VARI1-VARI8)/VARI8*10;
  51. VARIB:=0.6*VOL/WINNER(CLOSE) ;
  52. 牛魔王: IF(VARIB>=1000000 AND VARI9<-1.618,70,0), , COLORYELLOW;

  53. DRAWICON(VARIB>=1000000 AND VARI9<-1.618,70,0) ;
  54. {定海神针}
  55. VA1:=REF(CLOSE,1);
  56. VA2:=SMA(MAX(CLOSE-VA1,0),7,1)/SMA(ABS(CLOSE-VA1),7,1)*100;
  57. VA3:=SMA(MAX(CLOSE-VA1,0),13,1)/SMA(ABS(CLOSE-VA1),13,1)*100;
  58. VA4:=BARSCOUNT(CLOSE);
  59. VA6:=VA2<20 AND VA3<25 AND VA4>50;
  60. DHSZ: (VA6)*70,LINETHICK2,COLORFF9933;
  61. {地瓜八号}
  62. J:=(REF(C,1)+REF(C,2)+REF(C,3)+REF(C,4)+REF(C,5))/5;
  63. J1:=J<COST(10) AND C/J>1.025 AND (HHV(C,5)-LLV(C,5))/LLV(C,5)*100>7 ;
  64. J2:= J1 AND REF(C,5)/REF(C,1)>1.003 AND MA(INDEXC,3)>=REF(MA(INDEXC,3),1);
  65. 地瓜: (FILTER(J2,10))*28,LINETHICK2,COLOR99CCCC;
  66. {出手-赢}
  67. VAR3:=REF(HIGH,1)*1.1;
  68. VAR4:=HIGH*1.1;
  69. VAR5:=(VAR4*VOL+VAR3*(CAPITAL-VOL))/CAPITAL;
  70. VAR6:=REF(LOW,1)*0.9;
  71. VAR7:=LOW*0.9;
  72. VAR8:=(VAR7*VOL+VAR6*(CAPITAL-VOL))/CAPITAL;
  73. VAR9:=EMA(VAR8,30);
  74. VARA:=EMA(VAR5,30);
  75. VARB:=VARA-2;
  76. VARC:=IF(CLOSE<=VAR9,VARB,VARA);
  77. VARD:=MA(CLOSE,80)-MA(CLOSE,10)/17;
  78. {出手:}STICKLINE(VARC-VARB=0 AND CROSS((EMA(EMA(EMA(CLOSE,3),3),3)-REF(EMA(EMA(EMA(CLOSE,3),3),3),1))/REF(EMA(EMA(EMA(CLOSE,3),3),3),1)*100,MA((EMA(EMA(EMA(CLOSE,3),3),3)-REF(EMA(EMA(EMA(CLOSE,3),3),3),1))/REF(EMA(EMA(EMA(CLOSE,3),3),3),1)*100,2)),80,0,3,0),LINETHICK3,COLORCC6699 , ;
  79. {赢:}DRAWTEXT(FILTER(VARC-VARB=0 AND CROSS((EMA(EMA(EMA(CLOSE,3),3),3)-REF(EMA(EMA(EMA(CLOSE,3),3),3),1))/REF(EMA(EMA(EMA(CLOSE,3),3),3),1)*100,MA((EMA(EMA(EMA(CLOSE,3),3),3)-REF(EMA(EMA(EMA(CLOSE,3),3),3),1))/REF(EMA(EMA(EMA(CLOSE,3),3),3),1)*100,2)),4),78,'★-赢'), ,COLORRED ;
  80. {等待底部买入}
  81. 买入: IF(CROSS((4*SMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5,1)-
  82. 3*SMA(SMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5,1),3,1)),(8)),58,0),STICK,COLOR0099FF,LINETHICK6;
  83. {导弹}
  84. VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
  85. VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
  86. VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
  87. VAR1D:=SMA(VAR1C,4,1);
  88. VAR1E:=SMA(VAR1D,3,1);
  89. VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
  90. VARE:=REF(LOW,1)*0.9;
  91. VARF:=LOW*0.9;
  92. VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
  93. VAR11:=EMA(VAR10,30);
  94. VAR12:=CLOSE-REF(CLOSE,1);
  95. VAR13:=MAX(VAR12,0);
  96. VAR14:=ABS(VAR12);
  97. VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;
  98. VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;
  99. VAR17:=BARSCOUNT(CLOSE);
  100. VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;
  101. VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
  102. VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;
  103. STICKLINE(VAR20,0,95,5,0),LINETHICK2,COLORRED,;
  104. {我卖}
  105. VAT3:=REF(CLOSE,1);
  106. VAT4:=SMA(MAX(CLOSE-VAT3,0),6,1)/SMA(ABS(CLOSE-VAT3),6,1)*100;
  107. 我卖: (CROSS(80,VAT4))*82,STICK,LINETHICK6,COLOR9900CC ;
  108. {玄黄卖出}
  109. 快逃: IF(CROSS((3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)),90),60,0),STICK,LINETHICK4,COLORGREEN;
  110. {底部雷达}
  111. VARO2:=(CLOSE-LLV(LOW,26))/(HHV(HIGH,26)-LLV(LOW,26))*100;
  112. VARO3:=SMA(SMA(VARO2,3,1),3,1);
  113. VARO4:=EMA(VARO3,5);
  114. VARO5:=LLV(LOW,26);
  115. VARO6:=HHV(HIGH,34);
  116. VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25;
  117. STICKLINE(CROSS(VARO4,10) AND VARO4>10,25,0,8,0),COLORYELLOW,;
  118. 建仓区: IF((VARO7<10),80,100), ,LINETHICK2 COLOR00CCFF;
  119. 派发区: IF((VARO7>90),20,0), , LINETHICK2 COLOR6699FF;
  120. VAY3:=(CLOSE-MA(CLOSE,30))/STD(CLOSE,15)*100;
  121. VAYA:=MA(CLOSE,60)-MA(CLOSE,5)/3.2;
  122. DRAWTEXT(CROSS(((CLOSE-MA(CLOSE,30))/STD(CLOSE,15)*100),(EMA(VAY3,18))) AND CLOSE<VAYA,HIGH+82,'★←-买卖信号成功率为80-95%')COLORYELLOW;
  123. {Z马神君}
  124. 天马行空线:=MA(COST(85),5);
  125. 训马线:=MA(COST(15),5);
  126. 黑马线:=MA(COST(50),5);
  127. 天马踏地线:=MA(COST(1),7);
  128. 牵马绳:=EMA(CLOSE,3);
复制代码

股票指标.jpg
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版| 感谢您的支持,本条链接自定义

Powered by Discuz! X3.1 © 2001-2015 Comsenz Inc. GMT+8, 2019-6-19 15:24 , Processed in 0.030583 second(s), 10 queries , Eaccelerator On.

135股票论坛 ( 京ICP备14020393号-1 ) QQ
快速回复 返回顶部 返回列表