查看: 0|回复: 0

飞鹰猎庄买卖主图指标公式(通达信)

[复制链接]

348

主题

348

帖子

1060

积分

金牌会员

Rank: 6Rank: 6

积分
1060
发表于 2019-5-28 11:03:27 | 显示全部楼层 |阅读模式
指标
适用软件: 通达信
画图位置: 主图
未来函数: 无未来
更多交流: QQ群:50203834 公众号:金股典/jingudian 
  1. MA5:MA(CLOSE,5);
  2. MA10:MA(CLOSE,10);
  3. MA20:MA(CLOSE,20);
  4. MA60:MA(CLOSE,60);
  5. BB:=REF(INDEXC,1)<REF(INDEXC,2) AND REF(C,2)*0.95>=REF(C,1) AND REF(O,1)/REF(C,1)>=1.05
  6. AND REF(C,1)<REF(O,1) AND C>O AND C/O>=1.05 AND C>REF(O,1)
  7. AND REF(VOL,1)<REF(VOL,2);
  8. STICKLINE(BB,O,C,4,0),COLORRED;
  9. STICKLINE(BB,O,H,0,0),COLORRED;
  10. STICKLINE(BB,L,C,0,0),COLORRED;
  11. DRAWTEXT(BB,L*0.98,'追!'),COLORYELLOW;
  12. VAR1:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-
  13. 3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);
  14. VAR2:=8;
  15. CC:=CROSS(VAR1,VAR2);
  16. DRAWTEXT(CC,L*0.98,'买!'),COLOR0099FF;
  17. TYP:=(H+L+C)/3;
  18. TYP1:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14))<=20 AND REF(MA(C,21),1)<MA(C,21);
  19. TJ1:=O<MAX(REF(C,1),REF(O,1));
  20. TJ2:=REF(C,1)>=MA(C,21) AND L/MA(C,21)>=1.015 AND MA(C,144)>MA(C,250) AND V<MA(V,10) AND MIN(REF(V,2),REF(V,1))>V;
  21. TJ3:=REF(MA(C,250),90)<REF(MA(C,144),90) AND MA(C,144)>MA(C,250) AND O>MA(C,250);
  22. TJ4:=MAX(REF(H,10)AND REF(H,9)AND REF(H,8)AND REF(H,7), REF(H,6));
  23. TOUJI:=TYP1 AND TJ1 AND TJ2 AND REF(C,2)/REF(O,2)<1.06 AND C/O<=1.05 AND HHV(H,5)/LLV(L,30)>=1.65 AND REF(H,5)/REF(L,1)>=1.15 AND REF(C,1)/REF(O,1)<=0.995 AND (L<REF(L,2) OR (REF(H,2)-REF(L,2))/(H-L)>=2) AND O/REF(L,1)<=1.04
  24. OR TYP1 AND TJ1 AND O/REF(L,1)<1.05 AND REF(L,1)/REF(O,4)<=0.85 AND REF(C,1)/REF(O,1)<=1.03 AND O<REF(C,1) AND HHV(H,5)/LLV(L,35)>1.35 AND V<MA(V,10);
  25. TOUJI2:=TYP1 AND TJ1 AND TJ2 AND O/REF(L,1)<1.05 AND O/LLV(L,3)<1.1 AND REF(C,1)/REF(0,1)<=1.05 AND HHV(H,4)/LLV(L,16)>=1.35 AND REF(O,4)/REF(C,2)>=1.08 AND REF(C,2)/REF(O,2)<=0.995 AND (REF(L,2)<REF(L,3) OR (REF(H,3)-REF(L,3))/(REF(H,1)-REF(L,1))>=2) AND L<MIN(REF(C,1),REF(O,1))
  26. OR TYP1 AND TJ1 AND HHV(H,10)/LLV(L,25)>=1.3 AND REF(C,5)<REF(H,5) AND REF(C,4)<REF(C,5) AND REF(C,3)<REF(C,4) AND REF(C,2)<REF(C,3) AND REF(C,1)<REF(C,2) AND L<REF(L,1) AND MA5/O<1.1;
  27. DATOUJI:=TYP1 AND TJ3 AND O<REF(C,5) AND O<=REF(C,1) AND REF(H,10)/O>=1.17 AND HHV(H,10)/LLV(L,30)>1.4 AND (MA(V,10)/HHV(V,10)>0.5 AND V/HHV(V,10)>0.2 AND V/HHV(V,10)<0.4 OR REF(V,3)>REF(V,2) AND REF(V,2)>REF(V,1)) AND REF(C,1)/REF(C,2)<=1.02;
  28. DATOUJI1:=TYP1 AND TJ3 AND O<REF(L,6) AND O<MIN(REF(C,5)AND REF(O,5),5) ;
  29. DRAWTEXT(TOUJI OR TOUJI2 OR DATOUJI OR DATOUJI1,L*0.98,'△'),COLORYELLOW;
  30. DRAWTEXT(CROSS(MA(VOL,10),MA(VOL,20)) AND MA(VOL,5)>MA(VOL,10) AND L<MA(C,20) AND C>=MA(C,20),L*0.98,'量托'),COLORWHITE;
  31. 卖出:=CROSS(90,SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100);
  32. DRAWTEXT(卖出,H*1.05,'短卖'),COLORGREEN;
  33. C3:=REF(C,1);
  34. 涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0);
  35. STICKLINE(涨停,OPEN,CLOSE,2,0),COLORRED;
  36. 跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);
  37. STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;
  38. W1:=C=HHV(C,20);
  39. W2:=BARSLAST(W1);
  40. W3:=IF(W2>0,REF(C,W2),REF(C,W2));
  41. W4:=CROSS(C,REF(W3,1));
  42. 突破盘整:=W4 AND COUNT(W4,5)=1;
  43. DRAWICON(突破盘整,L-0.10,1);
复制代码

股票指标.jpg
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版| 感谢您的支持,本条链接自定义

Powered by Discuz! X3.1 © 2001-2015 Comsenz Inc. GMT+8, 2019-9-17 12:53 , Processed in 0.031109 second(s), 10 queries , Eaccelerator On.

135股票指标 ( 京ICP备14020393号-1 ) QQ
快速回复 返回顶部 返回列表