查看: 0|回复: 0

macd变色龙指标公式(通达信)

[复制链接]

110

主题

110

帖子

338

积分

中级会员

Rank: 3Rank: 3

积分
338
发表于 2019-6-2 15:10:12 | 显示全部楼层 |阅读模式
指标
适用软件: 通达信
画图位置: 副图
未来函数: 无未来
更多交流: QQ群:50203834 公众号:金股典/jingudian 
  1. DIF1:=EMA(CLOSE,12) - EMA(CLOSE,26);
  2. DEA1:=EMA(DIF1,9);
  3. MACD1:=2*(DIF1-DEA1),STICK;
  4. MACD2:=EMA(MACD1,3);
  5. STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,1,0),COLORRED;
  6. STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,1,0),COLORGREEN;
  7. STICKLINE(MACD1<MACD2,0,MACD1,1,0),COLORCBCBC0;
  8. STICKLINE(MACD1>=0 OR MACD1<=0,0,0,50,1),COLORWHITE;
  9. DIF:DIF1,COLOR33FF33;
  10. DEA:DEA1,COLORYELLOW;
  11. MACD:MACD1,NODRAW,COLORMAGENTA;
  12. RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
  13. K:=SMA(RSV,3,1),COLORWHITE;
  14. D:=SMA(K,3,1),COLORYELLOW;
  15. J:=3*K-2*D,COLORFF00FF;
  16. MM:=IF(MACD< 0,MACD,0);
  17. JJ:=MM> REF(MM,1);
  18. ZZ:=REF(JJ,1)=1;
  19. 准备:=(JJ AND ZZ)*DEA;
  20. JH:=HHV(MAX(K,MAX(D,J)),250);
  21. DH:=HHV(MAX(DIF,DEA),250);
  22. SH:=INTPART(JH/DH)/2;
  23. DIFF50:=SH*DIF+50,COLORFFFF00;
  24. DEA50:=SH*DEA+50,COLORBLUE;
  25. 缩头:=IF(1.5*(DIFF50-DEA50)>0 AND REF(1.5*(DIFF50-DEA50),1)>REF(1.5*(DIFF50-DEA50),2) AND 1.5*(DIFF50-DEA50)< REF(1.5*(DIFF50-DEA50),1),1,0);
  26. 缩脚:=IF(1.5*(DIFF50-DEA50)<0 AND REF(1.5*(DIFF50-DEA50),1)< REF(1.5*(DIFF50-DEA50),2) AND 1.5*(DIFF50-DEA50)>REF(1.5*(DIFF50-DEA50),1),1,0);
  27. 杀多:=IF(1.5*(DIFF50-DEA50)<0 AND REF(1.5*(DIFF50-DEA50),1)> REF(1.5*(DIFF50-DEA50),2) AND 1.5*(DIFF50-DEA50)<REF(1.5*(DIFF50-DEA50),1),1,0);
  28. 诱空:=IF(1.5*(DIFF50-DEA50)>0 AND REF(1.5*(DIFF50-DEA50),1)< REF(1.5*(DIFF50-DEA50),2) AND 1.5*(DIFF50-DEA50)>REF(1.5*(DIFF50-DEA50),1),1,0);
  29. 阻力:=IF(CROSS(C,MA(C,20)) OR CROSS(C,MA(C,60)),10,0);
  30. DRAWTEXT(FILTER(杀多,3) AND 杀多,MACD+0.1,'杀多'),COLORFF00FF;
  31. DRAWTEXT(FILTER(缩头,3) AND 缩头,MACD+0.1,'卖'),COLORFF00FF;
  32. DRAWTEXT(FILTER(诱空,3) AND 诱空,MACD+0.1,'?洗'),COLOR00FF00;
  33. DRAWTEXT(FILTER(缩脚,3) AND 缩脚,MACD-0.1,'买'),COLOR00FF00;
  34. IF(MACD>=REF(MACD,1),DIF1,DRAWNULL),COLORRED,LINETHICK2;
复制代码

股票指标.jpg
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版| 感谢您的支持,本条链接自定义

Powered by Discuz! X3.1 © 2001-2015 Comsenz Inc. GMT+8, 2019-7-16 18:13 , Processed in 0.031016 second(s), 10 queries , Eaccelerator On.

135股票论坛 ( 京ICP备14020393号-1 ) QQ
快速回复 返回顶部 返回列表