查看: 0|回复: 0

主力持仓进场指标公式(通达信)

[复制链接]

104

主题

104

帖子

320

积分

中级会员

Rank: 3Rank: 3

积分
320
发表于 2019-6-2 15:22:35 | 显示全部楼层 |阅读模式
指标
适用软件: 通达信
画图位置: 副图
未来函数: 无未来
更多交流: QQ群:50203834 公众号:金股典/jingudian 
  1. RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
  2. K:=SMA(RSV,3,1);
  3. D:=SMA(K,3,1);
  4. DPYJ:=(K+D)/2,LINETHICK2 ;
  5. 基本线:=EMA(DPYJ,5)/1.5 ;
  6. 基本线2:=EMA(DPYJ,2)/1.5,COLORRED;
  7. AAA:=(C*2+H+L)/4*10;
  8. DF:=EMA(AAA,13)-EMA(AAA,34);
  9. DEAA:=EMA(DF,5);
  10. MACD:2*(DF-DEAA)*5.5,COLOR00FFFF,LINETHICK1;
  11. MACDFS:= IF(MACD<=0,MACD,0),COLOR00FF00,LINETHICK2;
  12. STICKLINE(MACDFS>REF(MACDFS,1),MACDFS,0,0.5,0),COLOR00FF00;
  13. MACDZS:=IF(MACD>=0,MACD,0),COLORFF00FF,LINETHICK2;
  14. STICKLINE(MACDZS>REF(MACDZS,1),MACDZS,0,0.5,0),COLORFF00FF;
  15. VAR2AAA:=REF(LOW,1);
  16. VAR3AAA:=SMA(ABS(LOW-VAR2AAA),13,1)/SMA(MAX(LOW-VAR2AAA,0),13,1)*100;
  17. VAR4AAA:=EMA(IF(CLOSE*1.2,VAR3AAA*13,VAR3AAA/13),13);
  18. VAR5AAA:=LLV(LOW,34);
  19. VAR6AAA:=HHV(VAR4AAA,34);
  20. VAR7AAA:=IF(LLV(LOW,56),1,0);
  21. VAR8AAA:=EMA(IF(LOW<=VAR5AAA,(VAR4AAA+VAR6AAA*2)/2,0),3)/618*VAR7AAA;
  22. VAR9AAA:=EMA(CLOSE,5);
  23. VAR10A:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*(10);
  24. VAR11A:=EMA(IF(LOW<=VAR5AAA,(VAR4AAA+VAR6AAA*2)/2,0),3)/618*VAR7AAA*(-1);
  25. VAR12A:=EMA(CLOSE,5)*(-1);
  26. 减仓:=IF(VAR12A<REF(VAR12A,1),VAR12A,0),COLOR10E410,LINETHICK1;
  27. 增仓:IF(VAR9AAA<REF(VAR9AAA,1),VAR9AAA*0.2,0),COLOR1010FF,LINETHICK1;
  28. 主力进场:IF(VAR8AAA>REF(VAR8AAA,1),VAR8AAA*8,0),COLOR10FFFF,LINETHICK1;
  29. 洗盘:IF(VAR11A>REF(VAR11A,1),VAR11A*8,0),COLORFFF810,LINETHICK1;
  30. 主力持仓:=LOW,COLORFF10FF,LINETHICK0;
  31. 增减力度:=VAR10A*5,COLORWHITE;
  32. XL1:=MA(LOW,2)*0.96;
  33. XL2:=MA(LOW,26)*0.85;
  34. XL3:REF(XL1,1)<XL2 AND REF(XL1,1)<XL1 AND REF(XL1,1)<REF(XL1,2);
  35. STICKLINE(XL3,0,VAR8AAA*3,4,0),COLOR006EFF;
  36. DRAWTEXT(XL3,VAR8AAA*2,'买'),COLOR0000FF;
  37. ↑买:DRAWICON(XL3,VAR8AAA*3,4),COLORRED;
  38. V0:0,COLORFFA2AF;
  39. 洗盘启动 :=(MACD>0 AND MACD<REF(MACD,1)
  40. AND 增减力度>REF(增减力度,1) AND 增减力度>0 )*10;
  41. 强区:增减力度>REF(增减力度,1) AND MACD>REF(MACD,1);
  42. TYP:=(HIGH+LOW+CLOSE)/3;
  43. CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
  44. A:=REF(C,1);
  45. RSI:=SMA(MAX(C-A,0),6,1)/SMA(ABS(C-A),6,1)*100;
  46. A1:=(C/MA(C,5)-1)*100<-10;
  47. A2:=(C/MA(C,13)-1)*100<-10;
  48. A3:=(C/MA(C,34)-1)*100<-15;
  49. A4:=RSI<18;
  50. A5:=CCI<-120;
  51. A6:=COUNT(ABS(C/REF(C,1)-1)*100>=6,30)>=1;
  52. 底部:(A1 AND A2 AND A3 AND A4 AND A5 AND A6)*20,COLOR00FFFF,LINETHICK2;
  53. 波段线:=5*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-3*SMA(SMA
  54. ((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)-SMA(SMA(SMA
  55. ((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),2,1),LINETHICK1,COLORRED;
  56. M1:=EMA(MA(波段线,5),3);
  57. STICKLINE(波段线>108 AND 波段线>=M1,MACD,MACD,5,0),COLORF0F000;
  58. STICKLINE(波段线<0 AND 波段线<M1,MACD,0,1,0),COLORRED;
  59. 启动:(FILTER((CROSS((EMA(CLOSE,2)-EMA(CLOSE,10)),EMA((EMA(CLOSE,2)-EMA(CLOSE,10)),2))
  60. AND EMA((EMA(CLOSE,2)-EMA(CLOSE,10)),2)<0 AND CROSS(C,MA(C,20))),90))*20;
复制代码

股票指标.jpg
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版| 感谢您的支持,本条链接自定义

Powered by Discuz! X3.1 © 2001-2015 Comsenz Inc. GMT+8, 2019-6-19 14:57 , Processed in 0.030819 second(s), 10 queries , Eaccelerator On.

135股票论坛 ( 京ICP备14020393号-1 ) QQ
快速回复 返回顶部 返回列表