查看: 0|回复: 0

启动金叉加仓主图指标公式(通达信)

[复制链接]

110

主题

110

帖子

338

积分

中级会员

Rank: 3Rank: 3

积分
338
发表于 2019-6-2 15:46:09 | 显示全部楼层 |阅读模式
指标
适用软件: 通达信
画图位置: 主图
未来函数: 无未来
更多交流: QQ群:50203834 公众号:金股典/jingudian 
  1. EMA13:EMA(C,13),COLOR0000FF,LINETHICK2;
  2. EMA34:EMA(C,34),COLORYELLOW;
  3. EMA55:EMA(C,55),COLORFF00FF;
  4. EMA120:EMA(C,120),COLORFFCC66;
  5. AR1:=EMA55>EMA34 AND EMA34>EMA13;
  6. AR2:=BARSLAST((C-EMA13)/EMA13*100<-6);
  7. AR3:=EMA13>=REF(EMA13,2);
  8. AR4:=COUNT(CROSS(C,EMA13),AR2)=1;
  9. AR5:=AR1 AND AR2 AND AR3 AND AR4;
  10. AR6:=AR5 AND FILTER(AR5,10);
  11. DRAWTEXT(AR6,L-0.09,'启动'),COLORYELLOW;
  12. STICKLINE(AR6,O,C,6,1),LINETHICK2,COLORYELLOW;
  13. BR1:=COUNT(BETWEEN((C-REF(C,1))/REF(C,1)*100,0,5) ,5)=5;
  14. BR2:=ABS((EMA13-EMA34)+(EMA34-EMA55))/C<0.2;
  15. BR3:=C>EMA55 AND (REF(C,1)<REF(EMA55,1) OR REF(C,2)<REF(EMA55,2) OR REF(C,3)<REF(EMA55,3) OR REF(C,4)<REF(EMA55,4) OR REF(C,5)<REF(EMA55,5));
  16. BR4:=BR1 AND BR2 AND BR3;
  17. DRAWTEXT(BR4 AND FILTER(BR4,10),L-0.09,'上升'),COLOR00C5FF;
  18. STICKLINE(BR4 AND FILTER(BR4,10),O,C,6,1),LINETHICK2,COLOR00C5FF;
  19. CR1:=(C-REF(C,1))/REF(C,1)*100>0.5;
  20. CR2:=V>MA(V,5)*0.6;
  21. CR3:=COUNT(CROSS(EMA13,EMA55),3)=1;
  22. CR4:=ABS(EMA34-EMA55)/EMA55<0.03;
  23. CR5:=EMA55<=EMA120 AND EMA55>=REF(EMA55,1);
  24. CR6:=FILTER(CR1 AND CR2 AND CR3 AND CR4 AND CR5,2);
  25. STICKLINE(CR6,O,C,6,1),LINETHICK2,COLORF00FF0;
  26. DRAWTEXT(CR6,L-0.09,'涨升'),COLORF00FF0;
  27. DR1:=EMA13>EMA34 AND EMA34<EMA55;
  28. DR2:=BARSLAST(CROSS(C,EMA55) );
  29. DR3:=H=HHV(H,DR2);
  30. DR4:=BARSLAST(DR3);
  31. DR5:=COUNT(O>C AND C<REF(C,1) AND C>EMA55 AND BETWEEN((C-EMA55)/EMA55,0,0.02),DR4)=1;
  32. DR6:=C>REF(C,1) ;
  33. DR7:= DR1 AND DR5 AND DR6 ;
  34. DR8:=DR7 AND FILTER(DR7 ,10);
  35. DRAWTEXT(DR8,L-0.09,'出击'),COLORD6BA63;{
  36. STICKLINE(DR8,O,C,6,1),LINETHICK2,COLORD6BA63;}
  37. ER:=BARSLAST(REF(CROSS(EMA55,EMA34),1)) AND CROSS(EMA34,EMA55);
  38. DRAWTEXT(ER,L-0.09,'金叉'),COLOR0099FF;{
  39. STICKLINE(ER,O,C,6,1),LINETHICK2,COLOR0099FF;}
  40. FR:=BARSLAST(REF(CROSS(EMA34,EMA13),1)) AND CROSS(EMA13,EMA34);
  41. DRAWTEXT(FR,L-0.09,'加仓'),COLORWHITE;{
  42. STICKLINE(FR,O,C,6,1),LINETHICK2,COLORWHITE;}
  43. GR1:=BARSLAST(BETWEEN("BIAS.BIAS2"(6,13,24),0,5) );
  44. GR2:=EMA13>EMA34 AND EMA34>EMA55 AND EMA13>REF(EMA13,1);
  45. GR3:=COUNT("BIAS.BIAS2"(6,13,24)>10 AND H=HHV(H,GR1),GR1);
  46. GR4:=H=HHV(H,GR1);
  47. GR5:="MACD.MACD"(12,26,9)<REF("MACD.MACD"(12,26,9),1);
  48. GR6:=GR2 AND GR3 AND GR4;
  49. GR7:=GR2 AND GR3 AND GR4 AND GR5;
  50. DRAWTEXT(GR6 AND GR7,H+0.13,'了结'),COLOR00FF00;{
  51. STICKLINE(GR6 AND GR7,H,H+0.09,4,0),COLOR00FF00;}
  52. HR2:=EMA13>=REF(EMA13,3) AND EMA34>=REF(EMA34,1) AND EMA55>=REF(EMA55,1) AND CROSS(C,EMA13) AND CROSS(C,EMA34) AND CROSS(C,EMA55);
  53. DRAWTEXT(HR2 AND FILTER(HR2,10),L-0.09,'推进'),COLORFFC8FF;
  54. STICKLINE(HR2 AND FILTER(HR2,10),O,C,6,1),LINETHICK2,COLORFFC8FF;
复制代码

股票指标.jpg
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版| 感谢您的支持,本条链接自定义

Powered by Discuz! X3.1 © 2001-2015 Comsenz Inc. GMT+8, 2019-7-16 18:25 , Processed in 0.031428 second(s), 11 queries , Eaccelerator On.

135股票论坛 ( 京ICP备14020393号-1 ) QQ
快速回复 返回顶部 返回列表