查看: 0|回复: 0

通达信自用火焰山抄底和9个选股指标公式

[复制链接]

418

主题

418

帖子

1272

积分

金牌会员

Rank: 6Rank: 6

积分
1272
发表于 2019-6-26 16:58:18 | 显示全部楼层 |阅读模式
指标
适用软件: 通达信
画图位置: 副图
未来函数: 无未来
更多交流: QQ群:50203834 公众号:金股典/jingudian 
使用说明:
1、底部红柱是火焰山,是底部标志。在跌幅不达45%时,只能是短线。
2、0以下的淡灰色柱是短期底部。在平衡市和牛市中用于抄底。
3、90以上的兰色和绿色柱是顶部提示,但出现兰色柱后,红色波段线在85以上,同时粘合K线持续上升,则可以持有,股价还有相当的上涨空间。
4、红箭头买进提示,绿箭头卖出提示。钱带子、红十字是买进提示。向上的手指是短线买进提示,一般持股3-5天。
5、0上的绿柱底部提示,白柱、兰柱是底部买进提示,如同时出现钱带子、红十字等,买进后一般有10%涨幅。

源码:

A:70;
B:90;
波段线:5*SMA((CLOSE- LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),2,1),NODRAW;
趁火打劫:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),NODRAW;
DRAWBAND(波段线,RGB(150,030,030),趁火打劫,RGB(20,150,20));
IF(波段线>=趁火打劫,波段线,DRAWNULL),COLORLIMAGENTA,LINETHICK2;
IF(波段线<趁火打劫,波段线,DRAWNULL),COLORGREEN,LINETHICK2;
M1:=EMA(MA(波段线,5),3);
STICKLINE(波段线>100 AND 波段线>=M1,波段线,100,3,1),COLORF0F000;
STICKLINE(波段线<0 AND 波段线<=M1,波段线,0,3,1),COLORLIGRAY;
底部买:=LLV(波段线,2)=LLV(波段线,8);
买进:=IF(CROSS(波段线,REF(波段线+0.01,1)) AND 底部买 AND 波段线<0,20,0);
STICKLINE(波段线<0 AND 波段线<M1,买进,0,1,0),COLORFF6699;
VAR1:=REF(LOW,1);
VAR2:=SMA(ABS(LOW-VAR1),3,1)/SMA(MAX(LOW-VAR1,0),3,1)*100;
VAR3:=EMA(IF(CLOSE*1.2,VAR2*10,VAR2/10),3);
VAR4:=LLV(LOW,38);
VAR5:=HHV(VAR3,38);
VAR6:=IF(LLV(LOW,90),1,0);
VAR7:=EMA(IF(LOW<=VAR4,(VAR3+VAR5*2)/2,0),3)/618*VAR6;
VAR71:=IF(VAR7>=100,100,VAR7);
主力吸货:VAR71,COLOR0000FF;
吸筹1:STICKLINE(VAR71,0,VAR71,6,0),COLOR0000FF;
吸筹2:STICKLINE(VAR71,0,VAR71,5,0),COLOR6600FF;
吸筹3:STICKLINE(VAR71,0,VAR71,4,0),COLORBB00FF;
吸筹4:STICKLINE(VAR71,0,VAR71,3,0),COLORFF00FF;
吸筹5:STICKLINE(VAR71,0,VAR71,2,0),COLORFF33FF;
吸筹6:STICKLINE(VAR71,0,VAR71,1,0),COLORFF66FF;
吸筹7:STICKLINE(VAR71,0,VAR71,0,0),COLORFF99FF;
MA5:=MA(CLOSE,5);
MA15:=MA(CLOSE,15);
MA30:=MA(CLOSE,30);
MA60:=MA(CLOSE,60);
离散量30:=100*(MA5-(MA15+MA30)/2)/MA30+50,COLOR00FFFF;
离散量60:100*(MA5-(MA15+MA30+MA60)/3)/MA60+50,COLORFFAA00;
粘合K:-3*(离散量30-离散量60)+50,COLORRED,LINETHICK2;
粘合D:=EMA(粘合K,3);
主升:BARSLAST(CROSS(粘合K,粘合D))*(粘合K>粘合D),COLORLIMAGENTA;
STICKLINE(粘合K>108,105,粘合K,5,1),COLORGREEN;
STICKLINE(主升,主升,主升+2,4,1),COLORLIMAGENTA;
DRAWICON(CROSS(离散量60,粘合K),离散量60*1.05,1);
DRAWICON(CROSS(粘合K,离散量60),离散量60*0.98,2);
隔岸观火:VAR5,COLOR0000FF,NODRAW;
关门捉贼: IF(趁火打劫<=10,30,0),COLORFFFF00,NODRAW;
擒贼擒王: IF(CROSS(趁火打劫,2),40,0),COLORFF0000,NODRAW;
RSV:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
买入:=(CROSS(K,D) AND K<30);
买:=买入 AND FILTER(买入,10);
STICKLINE(CROSS(趁火打劫,2),0,15,1,0),COLORWHITE;
STICKLINE(趁火打劫<=10,0,8,2,0),COLORLIGREEN;
STICKLINE(波段线<0 AND 波段线<M1,买进,0,4,0),COLORFF9900;
DRAWICON(买 AND 趁火打劫>10,10,9);
DRAWICON(CROSS(趁火打劫,11),-3,23);
XG:=LAST(趁火打劫<REF(趁火打劫,1),2,1) AND 趁火打劫>REF(趁火打劫,1) AND 趁火打劫>15;
DRAWICON(XG,-11,11);
股票指标.png


选股公式:

1、波段线:5*SMA((CLOSE- LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),2,1),NODRAW;
M1:=EMA(MA(波段线,5),3);
波段线<0 AND 波段线<=M1;

2、波段线:5*SMA((CLOSE- LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),2,1),NODRAW;
M1:=EMA(MA(波段线,5),3);
底部买:=LLV(波段线,2)=LLV(波段线,8);
买进:=IF(CROSS(波段线,REF(波段线+0.01,1)) AND 底部买 AND 波段线<0,20,0);
波段线<0 AND 波段线<M1

3、MA5:=MA(CLOSE,5);
MA15:=MA(CLOSE,15);
MA30:=MA(CLOSE,30);
MA60:=MA(CLOSE,60);
离散量30:=100*(MA5-(MA15+MA30)/2)/MA30+50,COLOR00FFFF;
离散量60:=100*(MA5-(MA15+MA30+MA60)/3)/MA60+50,COLORFFAA00;
粘合K:=-3*(离散量30-离散量60)+50,COLORRED,LINETHICK2;
CROSS(离散量60,粘合K);

4、趁火打劫:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),NODRAW;
CROSS(趁火打劫,2);

5、趁火打劫:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),NODRAW;
STICKLINE(趁火打劫<=10,0,8,2,0),COLORLIGREEN;

6、波段线:5*SMA((CLOSE- LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),2,1),NODRAW;
M1:=EMA(MA(波段线,5),3);
底部买:=LLV(波段线,2)=LLV(波段线,8);
买进:=IF(CROSS(波段线,REF(波段线+0.01,1)) AND 底部买 AND 波段线<0,20,0);
波段线<0 AND 波段线<M1;

7、趁火打劫:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),NODRAW;
RSV:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
买入:=(CROSS(K,D) AND K<30);
买:=买入 AND FILTER(买入,10);
买 AND 趁火打劫>10;

8、趁火打劫:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),NODRAW;
CROSS(趁火打劫,11);

9、趁火打劫:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),NODRAW;
XG:LAST(趁火打劫<REF(趁火打劫,1),2,1) AND 趁火打劫>REF(趁火打劫,1) AND 趁火打劫>15;

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版| 感谢您的支持,本条链接自定义

Powered by Discuz! X3.1 © 2001-2015 Comsenz Inc. GMT+8, 2019-11-19 16:07 , Processed in 0.034218 second(s), 11 queries , Eaccelerator On.

135股票指标 ( 京ICP备14020393号-1 ) QQ
快速回复 返回顶部 返回列表