查看: 0|回复: 0

波段神韵指标公式(通达信)

[复制链接]

110

主题

110

帖子

338

积分

中级会员

Rank: 3Rank: 3

积分
338
发表于 2019-6-26 17:37:08 | 显示全部楼层 |阅读模式
指标
适用软件: 通达信
画图位置: 副图
未来函数: 无未来
更多交流: QQ群:50203834 公众号:金股典/jingudian 
TYP := (HIGH + LOW + CLOSE)/3;
CCI1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,5));
差值1:=ABS(REF(CCI1,1)-CCI1),LINETHICK0;
CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));
差值2:=ABS(REF(CCI2,1)-CCI2),LINETHICK0;
CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20));
差值3:=ABS(REF(CCI3,1)-CCI3),LINETHICK0;
CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));
差值4:=ABS(REF(CCI4,1)-CCI4),LINETHICK0;
CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));
差值5:=ABS(REF(CCI5,1)-CCI5),LINETHICK0;
CCI:=(CCI1+CCI2+CCI3+CCI4+CCI5)/2,COLORRED,LINETHICK2;
天:=100,COLORBLUE;
TJ0:=CCI>50;
M1:=WINNER( MA(CLOSE,1))*200;
M2:=WINNER(MA(CLOSE,20))*200;
VAR1:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=3*VAR2-2*VAR3;
VAR5:=LLV(LOW,5);
VAR6:=HHV(HIGH,5);
VAR7:=EMA((CLOSE-VAR5)/(VAR6-VAR5)*100,4)*2;
VAR8:=EMA(0.667*REF(VAR7,1)+0.333*VAR7,2);
VAR9:=3*VAR7-2*VAR8;
VARA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VARB:=POW(MA(LOW,5),2)+MA(LOW,5);
VARC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARD:=(VARA-LLV(VARB,64))/(HHV(VARC,64)-LLV(VARB,64))*150+65-10;
VARE:=SMA(VARD,3,1)*1.5-100;
VARF:=SMA(VARE,3,1);
VAR10:=3*VARE-2*VARF;
VAR11:=(HIGH+LOW+CLOSE*2)/4;
VAR12:=EMA(VAR11,13);
VAR13:=STD(VAR11,13);
VAR14:=(VAR11-VAR12)*100/VAR13;
VAR15:=EMA(VAR14,5);
VAR17:=EMA(VAR15,13)+200-100;
VAR18:=EMA(VAR17,10);
VAR19:=3*VAR17-2*VAR18;
VAR1A:=VAR2+VAR7+VARE+VAR17;
VAR1B:=VAR3+VAR8+VARF+VAR18;
VAR1C:=VAR4+VAR9+VAR10+VAR19;
VAR1D:=(HIGH+LOW+CLOSE)/3;
VAR20:=(VAR1D-MA(VAR1D,34))/(0.015*AVEDEV(VAR1D,34));
VAR21:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
VAR22:=(HIGH+LOW+CLOSE+VAR1D)/4;
VAR23:=EMA(VAR22,24);
VAR24:=STD(VAR22,24);
VAR25:=(VAR22-VAR23)/VAR24*100;
VAR26:=(VAR1D-MA(VAR1D,24))/(0.015*AVEDEV(VAR1D,24));
VAR27:=EMA(VAR25,5);
VAR2A:=((VAR27+VAR26+VAR20)/3+165)/4;
VAR2B:=(EMA(EMA(EMA(VAR2A,15),10),5)-25)*2+VAR21;
VAR2C:=(VAR1A+VAR1B+VAR1C*30)/32/5-15;
VAR2D:=EMA(VAR2C,13);{13}
VAR2E:=(VAR2A+VAR2C)/2/1.1;
VAR28:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR29:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR30:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR31:=REF(CLOSE,1);
VAR32:=SMA(MAX(CLOSE-VAR31,0),5,1)/SMA(ABS(CLOSE-VAR31),5,1)*100;
VAR33:=(HIGH+LOW+CLOSE)/3;
VAR34:=(VAR33-MA(VAR33,14))/(0.015*AVEDEV(VAR33,14));
VAR35:=(VAR28>=-15.8 AND VAR28<=-12.2 AND VAR29<=-20.8 AND VAR30<=-27.5 AND VAR32<=11.7 AND VAR34<=-145)*100;
多空比例:=IF((M1-M2)>-0.02,M1-M2,-0.02),COLORF0F000;
超短:EMA(VAR2E,3),COLORGREEN ;
IF(超短>REF(超短,1), 超短,DRAWNULL),LINETHICK2,COLORRED;
短线:EMA(超短,5),COLORWHITE;
IF(短线>REF(短线,1), 短线,DRAWNULL),LINETHICK2,COLORRED;
IF(超短<REF(超短,1) AND 超短>短线, 超短,DRAWNULL),LINETHICK2,COLORYELLOW;
STICKLINE(IF(超短>REF(超短,1), 超短,DRAWNULL),0,10,3,0),COLORFF00FF;
趋势:EMA((VAR2B+VAR2D)/2,3) ,COLORYELLOW;
IF(趋势>REF(趋势,1), 趋势,DRAWNULL),LINETHICK2,COLORRED;
底部:=0,COLORF00FF0,LINETHICK2;
中位:=50,POINTDOT,COLORYELLOW,LINETHICK4;
风险:=80,COLORWHITE,POINTDOT;
顶:=100,COLORBLUE;
逃命:=120,COLORGREEN,LINETHICK2;
STICKLINE(IF(超短<REF(超短,1), 超短,DRAWNULL),0,10,3,0),COLOR00FF00;
DRAWTEXT(CROSS(短线,超短) AND CROSS(趋势,超短) AND CROSS(趋势,短线),
REF(超短,2)*1.2,'逃'),COLORGREEN;
DRAWBAND(超短,RGB(200,50,55),短线,RGB(0,100,50));
TJ1:=CROSS(超短,短线) AND 短线<50 AND TJ0 ;
TJ2:=CROSS(超短,短线) AND 短线<0 AND 趋势<0;
TJ10:=CROSS(超短,短线) AND 短线<30;
DRAWICON(TJ10,短线,26);
SL:=CROSS(短线,超短) AND 短线>80;
DRAWICON(SL,短线,19);
STICKLINE(TJ1,0,20,4,0),COLOR000099;
STICKLINE(TJ1,0,20,2,0),COLOR0000BB;
STICKLINE(TJ1,0,20,1,0),COLOR0000DD;
STICKLINE(TJ1,0,20,0.3,0),COLOR0000FF;
DRAWTEXT(TJ1,25,'买底'),COLOR0000FF;
STICKLINE(TJ2,0,50,4,0),COLOR009999;
STICKLINE(TJ2,0,50,2,0),COLOR00BBBB;
STICKLINE(TJ2,0,50,1,0),COLOR00DDDD;
STICKLINE(TJ2,0,50,0.3,0),COLOR00FFFF;
DRAWTEXT(TJ2,53,'超底'),COLOR00FFFF;
{金叉}
XXX:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(XXX,3,1);
D:=SMA(K,3,1);
叉1:=CROSS(K,D);
AA:=MACD.DIF;
AB:=MACD.DEA;
叉2:=CROSS(AA,AB);
金叉:=叉1 AND 叉2;
STICKLINE(金叉,0,5,4,0),COLORYELLOW;
STICKLINE(金叉,0,10,3,0),COLORYELLOW;
STICKLINE(金叉,0,19,1,0),COLORYELLOW;
STICKLINE(金叉,0,22,0,0),COLORYELLOW;
DRAWTEXT(金叉,23,'章鱼哥'),COLOR00FFFF;
股票指标.png


回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版| 感谢您的支持,本条链接自定义

Powered by Discuz! X3.1 © 2001-2015 Comsenz Inc. GMT+8, 2019-7-20 02:39 , Processed in 0.029996 second(s), 10 queries , Eaccelerator On.

135股票论坛 ( 京ICP备14020393号-1 ) QQ
快速回复 返回顶部 返回列表