查看: 0|回复: 0

通达信中多波段指标公式

[复制链接]

418

主题

418

帖子

1272

积分

金牌会员

Rank: 6Rank: 6

积分
1272
发表于 2019-9-28 10:56:41 | 显示全部楼层 |阅读模式
指标
适用软件: 通达信
画图位置: 副图
未来函数: 无未来
更多交流: QQ群:50203834 公众号:金股典/jingudian 
X:=REF(CLOSE,1)<REF(CLOSE,2) AND REF(VOL,1)>MAX(REF(MA(VOL,5),1),MAX(REF(MA(VOL,10),1),REF(MA(VOL,20),1))) AND REF(VOL,1)>REF(MA(VOL,20),1)*1.1;
Y:=IF(X,MIN(REF(LOW,1),LOW),0);
Z1:=REF(Y,BARSLAST(X));
X1:=REF(CLOSE,1)<REF(OPEN,1) AND REF(VOL,1)>MAX(REF(MA(VOL,5),1),MAX(REF(MA(VOL,10),1),REF(MA(VOL,20),1))) AND REF(AMOUNT,1)=REF(HHV(AMOUNT,20),1) OR REF(CLOSE,1)<REF(OPEN,1) AND REF(AMOUNT,1)=REF(HHV(AMOUNT,20),1);
Y1:=IF(X1,REF(CLOSE,1),0);
Z2:=REF(Y1,BARSLAST(X1));
RSV1:=(CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*100;
KK:=SMA(RSV1,5,1);
中多:SMA(KK,10,1),COLOR669933;
STICKLINE(KK<=中多 ,KK,中多,3,0),COLOR669933;
VARE:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
RSV3:=SMA(SMA(VARE,3,1),3,1);
RSV4:=3*SMA(VARE,3,1)-2*RSV3;
短多:EMA(RSV4,5),COLORRED;
DRAWICON(CROSS(短多,中多),短多,1);
DRAWICON(CROSS(中多,短多),中多,2);
STICKLINE(SMA(VARE,3,1)>RSV3 ,SMA(VARE,3,1),RSV3,3,0), COLORRED;
STICKLINE(SMA(VARE,3,1)>RSV3 AND CLOSE>Z1 AND CLOSE>Z2 ,SMA(VARE,3,1),RSV3,3,0), COLORCYAN;
STICKLINE(SMA(VARE,3,1)>RSV3 ,SMA(VARE,3,1),RSV3,3,0), COLORYELLOW;
VAR1:=100*(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21));
RSV7:=SMA(VAR1,3,1);
STICKLINE(FILTER( RSV7<8, 50) ,0,20,4,0), COLORRED;
STICKLINE(FILTER( RSV7<8,50) ,0,8,15,0), COLORYELLOW;
STICKLINE(FILTER( RSV7>92, 50),92,100,15,0), COLOR66CC33;
STICKLINE(FILTER( RSV7>92, 50),80,92,4,0), COLORRED;
VAR2Q:=(MA(CLOSE,80)-MA(CLOSE,13)/3);
RSV8:= MA((CLOSE-VAR2Q)/VAR2Q,1);
XA:=EMA(RSV8,12)*0.7;
XB:=EMA(RSV8,3);
IF(LLV(XB-XA,12)>0,0,-5),COLORGREEN,LINETHICK2;
103,COLORGREEN,LINETHICK2;
0,COLORCYAN,LINETHICK2;
DIFF :=( EMA(CLOSE,20) - EMA(CLOSE,90))*100;
DEA :=EMA(DIFF,45);
MACD :=2*(DIFF-DEA);
STICKLINE(DIFF<=0 AND DEA<=DIFF AND REF(DIFF,1)<REF(DEA,1) ,0,3,40,0),COLOR66CC33;
STICKLINE(DIFF<=0 AND DEA<=DIFF AND REF(DIFF,1)<REF(DEA,1) ,3,6,30,0),COLOR00FFFF;
STICKLINE(DIFF<=0 AND DEA<=DIFF AND REF(DIFF,1)<REF(DEA,1),6,20,0,0),COLORRED;
STICKLINE(DIFF>=0 AND DEA>=DIFF AND REF(DIFF,1)>REF(DEA,1),97,100,40,0),COLORFF00FF;
STICKLINE(DIFF>=0 AND DEA>=DIFF AND REF(DIFF,1)>REF(DEA,1),94,97,30,0),COLOR00FFFF;
STICKLINE(DIFF>=0 AND DEA>=DIFF AND REF(DIFF,1)>REF(DEA,1),80,94,1,0),COLORFF0000;
突破线:50,COLORWHITE,LINETHICK2;

最新股票指标.jpg


回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版| 感谢您的支持,本条链接自定义

Powered by Discuz! X3.1 © 2001-2015 Comsenz Inc. GMT+8, 2019-10-21 17:54 , Processed in 0.033525 second(s), 11 queries , Eaccelerator On.

135股票指标 ( 京ICP备14020393号-1 ) QQ
快速回复 返回顶部 返回列表