查看: 0|回复: 0

通达信大趋势指标公式

[复制链接]

418

主题

418

帖子

1272

积分

金牌会员

Rank: 6Rank: 6

积分
1272
发表于 2019-9-28 12:00:10 | 显示全部楼层 |阅读模式
指标
适用软件: 通达信
画图位置: 副图
未来函数: 无未来
更多交流: QQ群:50203834 公众号:金股典/jingudian 
VA:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR2:=2*ABS(VA);
VAR3:=100-(100-3*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1),15,1));
VAR4:=100-(100-3*SMA((OPEN-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1),15,1));
VAR5:=(HIGH+LOW+CLOSE)/3;
VAR6:=(VAR5-MA(VAR5,10))/(0.015*AVEDEV(VAR5,10));
VAR7:=(VAR5-MA(VAR5,30))/(0.015*AVEDEV(VAR5,30));
VAR8:=IF(VAR6>=150 AND VAR6<200 AND VAR7>=150 AND VAR7<200,10,0);
VAR9:=IF(VAR6<=-150 AND VAR6>-200 AND VAR7<=-150 AND VAR7>-200,-10,VAR8);
VARA:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VARB:=100-ABS(VARA);
VARC:=3*SMA((INDEXC-LLV(INDEXL,55))/(HHV(INDEXH,55)-LLV(INDEXL,55))*100,20,1)-2*SMA(SMA((INDEXC-LLV(INDEXL,55))/(HHV(INDEXH,55)-LLV(INDEXL,55))*100,20,1),15,1);
VARD:=3*SMA((INDEXO-LLV(INDEXL,55))/(HHV(INDEXH,55)-LLV(INDEXL,55))*100,20,1)-2*SMA(SMA((INDEXO-LLV(INDEXL,55))/(HHV(INDEXH,55)-LLV(INDEXL,55))*100,20,1),15,1);
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VA0:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VA1:=EMA(VA0,30);
VA2:=VA1-CLOSE;
VA3:=REF(CLOSE,1);
VA4:=SMA(MAX(CLOSE-VA3,0),7,1)/SMA(ABS(CLOSE-VA3),7,1)*100;
VA5:=SMA(MAX(CLOSE-VA3,0),13,1)/SMA(ABS(CLOSE-VA3),13,1)*100;
VA6:=BARSCOUNT(CLOSE);
VA7:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
VA8:=((-100)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+50)*2;
VA9:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAA:=(SMA(VA9,4,1)-50)*2;
VAB:=SMA(VAA,3,1);
VAC:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAD:=SMA(VAC,4,1);
VAE:=SMA(VAD,3,1);
VAF:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=IF(VA7<=25 AND VA8<-95 AND VAF>20 AND VAB<-30 AND VAE<30 AND VA2>=-0.25 AND VA4<22 AND VA5<28 AND VA6>50,80,0);
大趋势: VAR3;
顶线: IF(VARB<90,VARB,100);
多方: IF(VA>0,VA,0), LINESTICK;
空方: 0-IF(VA<0,VAR2,0), LINESTICK;
抄底: VAR20 AND PWINNER(5,CLOSE)<1.1,COLORRED;
预警系统: IF(VAR7>=200 AND VAR6>=150 OR CROSS(65,多方),15,IF(VAR7<=-200 AND VAR6<=-150,-15,VAR9))+65,COLOREE00EE;
STICKLINE(VAR3<=REF(VAR4,1),VAR3,VAR4,8,0),COLORWHITE;
STICKLINE(VAR3>REF(VAR4,1),VAR3,VAR4,8,0),COLORRED;
VAR21:=CLOSE>MA(CLOSE,20) AND MA(CLOSE,20)>=REF(MA(CLOSE,20),1);
VAR22:=CLOSE;
VAR23:=多方>60 AND 预警系统>65 AND 顶线=100;
VAR24:=多方>48 AND 预警系统>65 AND 顶线<100;
VAR25:=空方<-38 AND 预警系统<65;
VAR26:=抄底>50 AND 顶线<90;
VAR27:=VAR3>REF(VAR4,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
VAR28:=VAR3<=REF(VAR4,1) AND CLOSE=REF(空方,1) AND VARC ;
DRAWTEXT(VAR21 AND COUNT(VAR21,30)=1,10,'上升通道!'),COLORYELLOW;
VAR29:DRAWTEXT(VAR22 AND COUNT(VAR22,30)=1,55,'下降通道!');
VAR2A:DRAWTEXT(VAR23 AND COUNT(VAR23,30)=1,55,'上涨过急!');
VAR2B:DRAWTEXT(VAR24 AND COUNT(VAR24,30)=1,75,'庄家出货!');
VAR2C:DRAWTEXT(VAR25 AND COUNT(VAR25,30)=1,50,'有小反弹!');
VAR2D:DRAWTEXT(VAR26 AND COUNT(VAR26,30)=1,30,'抢反弹!');
VAR2E:DRAWTEXT(VAR27 AND COUNT(VAR27,30)=1,-10,'资金进场!');
DRAWTEXT(VAR28 AND COUNT(VAR28,30)=1,90,'见顶回落!'),COLORYELLOW;

最新股票指标.jpg


回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版| 感谢您的支持,本条链接自定义

Powered by Discuz! X3.1 © 2001-2015 Comsenz Inc. GMT+8, 2019-10-21 18:36 , Processed in 0.071263 second(s), 11 queries , Eaccelerator On.

135股票指标 ( 京ICP备14020393号-1 ) QQ
快速回复 返回顶部 返回列表