查看: 0|回复: 0

通达信鬼眼鬼指指标公式

[复制链接]

418

主题

418

帖子

1272

积分

金牌会员

Rank: 6Rank: 6

积分
1272
发表于 2019-9-28 12:26:22 | 显示全部楼层 |阅读模式
指标
适用软件: 通达信
画图位置: 副图
未来函数: 无未来
更多交流: QQ群:50203834 公众号:金股典/jingudian 
VAR1:=IF(YEAR>=2334 AND MONTH>0,0,1);
VAR2:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;
VAR3:=SMA(VAR2,3,1);
VAR4:=SMA(VAR3,3,1);
VAR5:=3*VAR3-2*VAR4;
VAR6:=LLV(LOW,5);
VAR7:=HHV(HIGH,5);
VAR8:=EMA((CLOSE-VAR6)/(VAR7-VAR6)*100,4)*2;
VAR9:=EMA(0.667*REF(VAR8,1)+0.333*VAR8,2);
VARA:=3*VAR8-2*VAR9;
VARB:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VARC:=POW(MA(LOW,5),2)+MA(LOW,5);
VARD:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARE:=(VARB-LLV(VARC,64))/(HHV(VARD,64)-LLV(VARC,64))*150+65-10;
VARF:=SMA(VARE,3,1)*1.5-100;
VAR10:=SMA(VARF,3,1);
VAR11:=3*VARF-2*VAR10;
VAR12:=(HIGH+LOW+CLOSE*2)/4;
VAR13:=EMA(VAR12,13);
VAR14:=STD(VAR12,13);
VAR15:=(VAR12-VAR13)*100/VAR14;
VAR16:=EMA(VAR15,5);
VAR17:=EMA(VAR16,13);
VAR18:=EMA(VAR16,13)+200-100;
VAR19:=EMA(VAR18,10);
VAR1A:=3*VAR18-2*VAR19;
VAR1B:=VAR3+VAR8+VARF+VAR18;
VAR1C:=VAR4+VAR9+VAR10+VAR19;
VAR1D:=VAR5+VARA+VAR11+VAR1A;
VAR1E:=(HIGH+LOW+CLOSE)/3;
VAR1F:=AMOUNT/VOL/100;
VAR20:=SUM(AMOUNT,5)/SUM(VOL,5)/100;
VAR21:=(VAR1E-MA(VAR1E,34))/(0.015*AVEDEV(VAR1E,34));
VAR22:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
VAR23:=(HIGH+LOW+CLOSE+VAR1E)/4;
VAR24:=EMA(VAR23,24);
VAR25:=STD(VAR23,24);
VAR26:=(VAR23-VAR24)/VAR25*100;
VAR27:=(VAR1E-MA(VAR1E,24))/(0.015*AVEDEV(VAR1E,24));
VAR28:=EMA(VAR26,5);
VAR29:=(VAR1F-MA(VAR1F,21))/(0.015*AVEDEV(VAR1F,21));
VAR2A:=(VAR20-MA(VAR20,90))/(0.015*AVEDEV(VAR20,90));
VAR2B:=((VAR28+VAR27+VAR21)/3+165)/4;
VAR2C:=(EMA(EMA(EMA(VAR2B,15),10),5)-25)*2+VAR22;
VAR2D:=(VAR1B+VAR1C+VAR1D*30)/32/5-15;
VAR2E:=EMA(VAR2D,13);
VAR2F:=(VAR2B+VAR2D)/2/1.1;
VAR30:=VAR2F*VAR1;
短A: EMA(VAR30,1),COLORRED;
短B: EMA(短A,5),COLORFFCC66;
趋势线: EMA((VAR2C+VAR2E)/2,2),COLOR0099FF;
生死线: EMA(趋势线,40),COLORGREEN,LINETHICK2;
VAR31:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR32:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR33:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR34:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
VAR35:=(CLOSE-VAR34)/VAR34*100;
VAR36:=REF(VAR35,1)<-40 AND VAR35>REF(VAR35,1) AND REF(VAR35,1)<REF(VAR35,2) AND VAR35-REF(VAR35,1)>2.5;
VAR37:=(MA(AMOUNT,5)/MA(VOL,5)/100-MA(AMOUNT,110)/MA(VOL,110)/100)/(MA(AMOUNT,5)/MA(VOL,5)/100)<-0.273;
VAR38:=(CLOSE-MA(CLOSE,30))/MA(CLOSE,30)<-0.125;
VAR39:=VAR37 AND VAR38;
VAR3A:=VAR31>=-45 AND VAR31<=-10 AND VAR32<=-15 AND VAR33<=-20;
VAR3B:=COUNT(VAR3A,1)>=1;
VAR3C:=1;
VAR3D:=VAR39 AND VAR3B;
VAR3E:=(MA(AMOUNT,5)*VAR3C/MA(VOL,5)/100-MA(AMOUNT,125)/MA(VOL,125)/100)/(MA(AMOUNT,5)/MA(VOL,5)/100)<(-0.4)*VAR3C;
VAR3F:=HHV(HIGH,500);
VAR40:=LLV(LOW,500);
VAR41:=HHV(HIGH,250);
VAR42:=LLV(LOW,250);
VAR43:=EMA(CLOSE,34);
VAR44:=MA(VAR43*0.82,5);
VAR45:=CLOSE-REF(MA(CLOSE,20),11)<-2;
VAR46:=LLV(LOW,125);
VAR47:=MA((VAR3F*0.45+VAR41*0.5+VAR40+VAR42+VAR46)/5,35);
VAR48:=VAR47;
VAR49:=SMA(AMOUNT/VOL/100,13,1)*0.85;
VAR4A:=CLOSE-REF(MA(CLOSE,20),11);
VAR4B:=CLOSE<VAR44 AND VAR3E AND CLOSE<VAR49 OR CLOSE<VAR44 AND VAR45 AND VAR3E OR CLOSE<VAR44 AND CLOSE<VAR49 OR CLOSE<VAR44 AND VAR3E AND CLOSE<VAR49 OR VAR3E AND CLOSE<VAR48 OR VAR3E AND VAR45 AND VAR4A<-1.5 OR VAR3E AND CLOSE<VAR44 OR VAR3E AND VAR4A<-1.5 OR VAR45 AND CLOSE<VAR49 OR CLOSE<VAR48 AND VAR4A<-1.5 OR CLOSE<VAR44 AND VAR45;
VAR4C:=VAR37 AND VAR38;
VAR4D:=VAR31>=-45 AND VAR31<=-7 AND VAR32<=-11 AND VAR33<=-14;
VAR4E:=COUNT(VAR4D,1)>=1;
VAR4F:=VAR4C AND VAR4E;
VAR50:=VAR3E AND CLOSE<VAR44 AND VAR45 AND CLOSE<VAR48 AND VAR4B AND VAR4F;
VAR51:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR52:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR53:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR54:=REF(CLOSE,1);
VAR55:=SMA(MAX(CLOSE-VAR54,0),5,1)/SMA(ABS(CLOSE-VAR54),5,1)*100;
VAR56:=(HIGH+LOW+CLOSE)/3;
VAR57:=(VAR56-MA(VAR56,14))/(0.015*AVEDEV(VAR56,14));
VAR58:=REF(CLOSE,2)*0.865;
VAR59:=REF(CLOSE,13)*0.772;
VAR5A:=MIN(VAR58,VAR59);
VAR5B:=100*VOL/CAPITAL;
VAR5C:=VAR51>=-15.8 AND VAR51<=-12.2 AND VAR52<=-20.8 AND VAR53<=-27.5 AND VAR55<=11.7 AND VAR57<=-145;
鬼指: IF(VAR36 OR VAR3D OR VAR50 OR VAR5C OR (CLOSE-VAR5A)/CLOSE<0.03 AND SUM(VAR5B,5)/5<1.8,100,-32),COLORYELLOW;
风险区: STICKLINE(趋势线>105,140,130,10,1),COLORRED;
鬼顶: STICKLINE(趋势线>135,140,130,10,0),COLORBLUE;
鬼道: STICKLINE(BETWEEN(趋势线,CROSS(趋势线,150),140),-40,-30,0,0),COLORFFCC66;
安全区: STICKLINE(趋势线<-15,-41,-31,10,1),COLOR0099FF;
鬼底: STICKLINE(趋势线<-26,-41,-31,4,0),COLORWHITE;
鬼眼:IF(CROSS(100,短A) OR CROSS(80,短A),105,120),COLORFFCCCC;
DRAWTEXT(CROSS(趋势线,130) OR CROSS(趋势线,135) OR CROSS(135,趋势线) OR CROSS(132,趋势线) OR CROSS(130,趋势线) OR CROSS(128,趋势线) OR CROSS(126,趋势线) OR CROSS(124,趋势线),140,'◆'),COLORYELLOW;
DRAWICON(CROSS(短B,趋势线) AND 趋势线<=-17 OR CROSS(趋势线,生死线) AND 生死线<=5,{-15}0,1);

最新股票指标.jpg


回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版| 感谢您的支持,本条链接自定义

Powered by Discuz! X3.1 © 2001-2015 Comsenz Inc. GMT+8, 2019-10-21 18:53 , Processed in 0.032180 second(s), 10 queries , Eaccelerator On.

135股票指标 ( 京ICP备14020393号-1 ) QQ
快速回复 返回顶部 返回列表